aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/twister/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-18 15:14:57 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-18 15:14:57 +0000
commit2f31f6488fc45cfcb998f900f0bb0e7987a6b06e (patch)
treeb61b1965e672cbfbc413084d564e65454bf0286a /net-p2p/twister/Makefile
parentf84bddd9c2463df378b01403cde0d0433c25b7dd (diff)
downloadports-2f31f6488fc45cfcb998f900f0bb0e7987a6b06e.tar.gz
ports-2f31f6488fc45cfcb998f900f0bb0e7987a6b06e.zip
Convert to USES=autoreconf
Notes
Notes: svn path=/head/; revision=384229
Diffstat (limited to 'net-p2p/twister/Makefile')
-rw-r--r--net-p2p/twister/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/net-p2p/twister/Makefile b/net-p2p/twister/Makefile
index f60e042db21b..d1635785bb9b 100644
--- a/net-p2p/twister/Makefile
+++ b/net-p2p/twister/Makefile
@@ -27,9 +27,8 @@ GH_TAGNAME= v${PORTVERSION}
USE_BDB= yes
WANT_BDB_VER= 48
USE_OPENSSL= yes
-USES= gmake iconv
+USES= autoreconf gmake iconv libtool
-USE_AUTOTOOLS= libtoolize:env aclocal:env autoconf:env autoheader:env automake:env
GNU_CONFIGURE= yes
CONFIGURE_WRKSRC=${WRKSRC}/libtorrent
CONFIGURE_ARGS= --with-libiconv \
@@ -52,10 +51,9 @@ PORTDOCS= README.md
WITH_OPENSSL_PORT= yes
.endif
-pre-configure:
- ${REINPLACE_CMD} -e 's|%%PORTVERSION%%|${PORTVERSION}|' \
+post-patch:
+ @${REINPLACE_CMD} 's|%%PORTVERSION%%|${PORTVERSION}|' \
${WRKSRC}/share/genbuild.sh
- (cd ${CONFIGURE_WRKSRC} && ./autotool.sh)
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/twisterd ${STAGEDIR}${PREFIX}/bin