aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/twister/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-07-05 18:36:55 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-07-05 18:36:55 +0000
commit975bb59729a14dfdc7f2fa6259d6a89461265d25 (patch)
tree1d1acec6c855af1051347101ea56c8402fb8c984 /net-p2p/twister/Makefile
parent5eafe13d23e38376561f7f3971af8d3282ba2fb2 (diff)
downloadports-975bb59729a14dfdc7f2fa6259d6a89461265d25.tar.gz
ports-975bb59729a14dfdc7f2fa6259d6a89461265d25.zip
Fix build on FreeBSD-9.
Notes
Notes: svn path=/head/; revision=360794
Diffstat (limited to 'net-p2p/twister/Makefile')
-rw-r--r--net-p2p/twister/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/net-p2p/twister/Makefile b/net-p2p/twister/Makefile
index 611286f0cac7..566d238497e9 100644
--- a/net-p2p/twister/Makefile
+++ b/net-p2p/twister/Makefile
@@ -45,13 +45,18 @@ BUILD_WRKSRC= ${WRKSRC}/src
MAKE_ENV= BOOST_INCLUDE_PATH=${LOCALBASE}/include \
BOOST_LIB_PATH=${LOCALBASE}/lib \
BDB_INCLUDE_PATH=${BDB_INCLUDE_DIR} \
- BDB_LIB_PATH=${BDB_LIB_DIR}
+ BDB_LIB_PATH=${BDB_LIB_DIR} \
+ ICONV_LIB="${ICONV_LIB}"
PLIST_FILES= bin/twisterd
PORTDOCS= README.md
.include <bsd.port.options.mk>
+.if (${OPSYS} == FreeBSD && ${OSVERSION} < 1000000)
+WITH_OPENSSL_PORT= yes
+.endif
+
pre-configure:
(cd ${CONFIGURE_WRKSRC} && ./autotool.sh)
.if ${PORT_OPTIONS:MUPNP}