aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/verlihub-plugins-luascript/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-07-05 07:06:19 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-07-05 07:06:19 +0000
commit43726892a294f63361b82be27a01f718317ebc43 (patch)
treebbffa8b659fbef13de46db9b7bb4fd1fcaed3ed0 /net-p2p/verlihub-plugins-luascript/Makefile
parent5553af0e0f4f7b2c079e4878eeecad2650b2c59a (diff)
downloadports-43726892a294f63361b82be27a01f718317ebc43.tar.gz
ports-43726892a294f63361b82be27a01f718317ebc43.zip
LuaScript plugin for the VerliHub.
Verlihub is a Linux/Unix Direct Connect protocol server (Hub). It is written in c++, has relatively low CPU and RAM usage, and has many useful features. It also uses a MySQL Database. Additional functionality is available through a versatile 'plugin' system. WWW: http://www.verlihub-project.org/ PR: ports/112393 Submitted by: Mikle Davidkin <skylord at vt.net.ru>
Notes
Notes: svn path=/head/; revision=194980
Diffstat (limited to 'net-p2p/verlihub-plugins-luascript/Makefile')
-rw-r--r--net-p2p/verlihub-plugins-luascript/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-p2p/verlihub-plugins-luascript/Makefile b/net-p2p/verlihub-plugins-luascript/Makefile
new file mode 100644
index 000000000000..f32a38dbd5e2
--- /dev/null
+++ b/net-p2p/verlihub-plugins-luascript/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: verlihub-plugins-luascript
+# Date created: 3 May 2007
+# Whom: Skylord
+#
+# $FreeBSD$
+#
+
+PORTNAME= luascript
+PORTVERSION= 1.6
+CATEGORIES= net-p2p
+
+MAINTAINER= skylord@vt.net.ru
+COMMENT= LuaScript plugin for the VerliHub - a Direct Connect protocol server (Hub)
+
+PLUGIN_NAME= lua
+
+USE_LUA= 5.1
+CONFIGURE_ENV= CXXFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
+CPPFLAGS= -I${LUA_INCDIR}
+LDFLAGS= -L${LUA_LIBDIR}
+
+PLIST_FILES= share/verlihub/scripts/google.lua \
+ share/verlihub/scripts/lua4to5.lua.inc \
+ share/verlihub/scripts/ptokax.lua.inc \
+ share/verlihub/scripts/ptokaxtest.lua \
+ share/verlihub/scripts/script.lua \
+ share/verlihub/scripts/trivia.lua
+PLIST_DIRS= share/verlihub/scripts
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/net-p2p/verlihub-plugins/Makefile.plugins"
+.include <bsd.port.post.mk>