aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 15:28:28 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 15:28:28 +0000
commite836ab008ac38916a93472f2840e03e2e8470ef5 (patch)
tree1485083919fd5b153bf056ea17ac895ea758a8a9 /net-p2p
parent35d8b48dff5490ff5d7232109c287da637b58811 (diff)
downloadports-e836ab008ac38916a93472f2840e03e2e8470ef5.tar.gz
ports-e836ab008ac38916a93472f2840e03e2e8470ef5.zip
Replace lang/lua with the new lang/lua51
lang/lua51 is working the same way lang/lua52, chase ports using lua 5.1 Make the default lua lua52 Make all lua ports using USES=lua Approved by: portmgr (implicit)
Notes
Notes: svn path=/head/; revision=355360
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/eiskaltdcpp-lib/Makefile8
-rw-r--r--net-p2p/verlihub-plugins-luascript/Makefile4
2 files changed, 6 insertions, 6 deletions
diff --git a/net-p2p/eiskaltdcpp-lib/Makefile b/net-p2p/eiskaltdcpp-lib/Makefile
index e9c63fa6720a..140759dafc00 100644
--- a/net-p2p/eiskaltdcpp-lib/Makefile
+++ b/net-p2p/eiskaltdcpp-lib/Makefile
@@ -18,9 +18,7 @@ BUILD_DEPENDS+= chrpath:${PORTSDIR}/devel/chrpath
PROJECTHOST= eiskaltdc
-USE_XZ= yes
-USE_GCC= yes
-USES= cmake gettext
+USES= cmake gettext tar:xz compiler:gcc-c++11-lib
USE_OPENSSL= yes
USE_LDCONFIG= yes
@@ -38,9 +36,9 @@ CMAKE_ARGS+= -DUSE_MINIUPNP:BOOL=OFF
CMAKE_ARGS+= -DCMAKE_SKIP_RPATH:BOOL=ON
.if ${PORT_OPTIONS:MLUA}
-USE_LUA= 5.1
+USES+= lua
CMAKE_ARGS+= -DLUA_SCRIPT:BOOL=ON
-IGNORE= crashes on connect attempt if built with Lua support
+#IGNORE= crashes on connect attempt if built with Lua support
.else
CMAKE_ARGS+= -DLUA_SCRIPT:BOOL=OFF
.endif
diff --git a/net-p2p/verlihub-plugins-luascript/Makefile b/net-p2p/verlihub-plugins-luascript/Makefile
index 680adfe5a9d2..3f77fc699277 100644
--- a/net-p2p/verlihub-plugins-luascript/Makefile
+++ b/net-p2p/verlihub-plugins-luascript/Makefile
@@ -12,6 +12,7 @@ MAINTAINER= me@skylord.ru
PLUGIN_NAME= lua
PLUGIN_DESC= LuaScript
+USES= lua:51
USE_LUA= 5.1
WRKSRC= ${WRKDIR}/${DISTNAME}
@@ -31,7 +32,8 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSOCKET}
-LUA_COMPS+= socket:lib
+BUILD_DEPENDS+= ${LUA_MODLIBDIR}/socket/core.so:${PORTSDIR}/net/luasocket
+RUN_DEPENDS+= ${LUA_MODLIBDIR}/socket/core.so:${PORTSDIR}/net/luasocket
CONFIGURE_ARGS+= --with-luasocket
post-patch::