aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-03-10 03:10:26 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-03-10 03:10:26 +0000
commit37aa24678c5c2f330093171d784ad6cfe4887958 (patch)
tree46aba6f45eb103af8f0147977ce4e667fad28339 /net-p2p
parent917f75faee1253aa6974470807798c3143158261 (diff)
downloadports-37aa24678c5c2f330093171d784ad6cfe4887958.tar.gz
ports-37aa24678c5c2f330093171d784ad6cfe4887958.zip
Update to version 1.7.4c
Requested by: pav, too many
Notes
Notes: svn path=/head/; revision=103488
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/xmule/Makefile29
-rw-r--r--net-p2p/xmule/distinfo4
-rw-r--r--net-p2p/xmule/files/patch-ED2K-Links.HOWTO44
-rw-r--r--net-p2p/xmule/files/patch-Makefile.in14
-rw-r--r--net-p2p/xmule/files/patch-src::ClientCredits.cpp11
-rw-r--r--net-p2p/xmule/pkg-plist3
6 files changed, 75 insertions, 30 deletions
diff --git a/net-p2p/xmule/Makefile b/net-p2p/xmule/Makefile
index e83b8ebe6261..9bd2667f3182 100644
--- a/net-p2p/xmule/Makefile
+++ b/net-p2p/xmule/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xmule
-PORTVERSION= 1.6.1
-PORTREVISION= 1
+PORTVERSION= 1.7.4c
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= xmule
@@ -24,7 +23,6 @@ USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GNOME= gnomehier \
gnomehack \
- gtk20 \
gnomeprefix
USE_REINPLACE= yes
USE_GMAKE= yes
@@ -43,18 +41,17 @@ post-patch:
@${REINPLACE_CMD} -E \
-e 's|(Linux)|FreeBSD/\1|' \
${WRKSRC}/src/*.cpp
-# remove ^M
+# update documentation with correct prefix
@${REINPLACE_CMD} -E \
- -e 's| ||' \
- ${WRKSRC}/src/MD5Sum.cpp
-# do not install a generic named ed2k binary
+ -e 's|/usr/X11R6/(bin/${PORTNAME}-ed2k-handler)|${PREFIX}/\1|' \
+ ${WRKSRC}/ED2K-Links.HOWTO
+# use BSD_INSTALL_* macros
@${REINPLACE_CMD} -E \
- -e 's|^(bin_PROGRAMS.+)ed2k|\1|' \
- ${WRKSRC}/src/Makefile.in
-# update documentation regarding aforementioned change
+ -e 's|cp -f|${INSTALL_DATA}|' \
+ ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -E \
- -e 's|/usr/local/bin/ed2k|${PREFIX}/bin/${PORTNAME}-ed2k-handler|' \
- ${WRKSRC}/ED2K-Links.HOWTO
+ -e 's|cp -p|${INSTALL_DATA}|' \
+ ${WRKSRC}/po/Makefile.in.in
pre-configure:
@${FIND} ${WRKSRC} -type f -name "Makefile.in" | \
@@ -62,12 +59,10 @@ pre-configure:
${REINPLACE_CMD} -E \
-e 's!^(AUTOCONF|AUTOHEADER|AUTOMAKE|ACLOCAL).*$$!\1=${TRUE}!'
-post-build:
-# build the generic named ed2k binary
-# it will installed in an adhoc fashion
- @cd ${BUILD_WRKSRC}/src; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ed2k
-
post-install:
+# install xmule binary
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} \
+ ${PREFIX}/bin
# do not install a generic named ed2k binary
# install it under a more specific name
@${INSTALL_PROGRAM} ${WRKSRC}/src/ed2k \
diff --git a/net-p2p/xmule/distinfo b/net-p2p/xmule/distinfo
index 9687f3a3bd13..9102188fe11f 100644
--- a/net-p2p/xmule/distinfo
+++ b/net-p2p/xmule/distinfo
@@ -1,2 +1,2 @@
-MD5 (xmule-1.6.1.tar.bz2) = 7db64383f0b2ed33f09f1cb5e34dd161
-SIZE (xmule-1.6.1.tar.bz2) = 1250111
+MD5 (xmule-1.7.4c.tar.bz2) = 8a9c445ff0eb1d97c2ecf677e5225f36
+SIZE (xmule-1.7.4c.tar.bz2) = 1169516
diff --git a/net-p2p/xmule/files/patch-ED2K-Links.HOWTO b/net-p2p/xmule/files/patch-ED2K-Links.HOWTO
new file mode 100644
index 000000000000..3780a708b5d1
--- /dev/null
+++ b/net-p2p/xmule/files/patch-ED2K-Links.HOWTO
@@ -0,0 +1,44 @@
+--- ED2K-Links.HOWTO.orig Thu Mar 4 12:46:20 2004
++++ ED2K-Links.HOWTO Tue Mar 9 21:21:16 2004
+@@ -14,7 +14,7 @@
+ the mentioned directory:
+
+ [Protocol]
+- exec=/usr/local/bin/ed2k "%u"
++ exec=/usr/X11R6/bin/xmule-ed2k-handler "%u"
+ protocol=ed2k
+ input=none
+ output=none
+@@ -39,12 +39,12 @@
+ create xmule_submit.sh with this content:
+
+ #!/bin/sh
+- /usr/local/bin/ed2k "ed2k://$1";
++ xmule-ed2k-handler "ed2k://$1";
+
+ now edit (as root) /etc/opera6rc or as non-root ~/.opera/opera6.ini:
+
+ [Trusted Applications]
+- ed2k=/usr/local/bin/xmule_submit.sh
++ ed2k=/usr/X11R6/bin/xmule_submit.sh
+
+ [User Prefs]
+ TrustedExternalURLProtocols=ed2k
+@@ -59,7 +59,7 @@
+ TrustedExternalURLProtocols=ed2k
+
+ in [Trusted Applications]
+- ed2k=/path/to/ed2k ed2k://%u
++ ed2k=/usr/X11R6/bin/xmule-ed2k-handler ed2k://%u
+
+ (Credits: ender)
+
+@@ -96,7 +96,7 @@
+
+ -create a file called "ed2k.cmd" with the following content:
+
+- ed2k ed2k:$URI_DATA
++ xmule-ed2k-handler ed2k:$URI_DATA
+
+ [do this with your favorite text-editor, the file doesn't have to be executable]
+
diff --git a/net-p2p/xmule/files/patch-Makefile.in b/net-p2p/xmule/files/patch-Makefile.in
new file mode 100644
index 000000000000..9eee2c105565
--- /dev/null
+++ b/net-p2p/xmule/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+--- Makefile.in.orig Tue Mar 9 23:59:49 2004
++++ Makefile.in Tue Mar 9 23:59:54 2004
+@@ -55,8 +55,9 @@
+
+ install: all
+ @mkdir -p @bindir@
+- @mkdir -p @datadir@/{applications,locale,pixmaps}
+- @cp -f src/{ed2k,xmule} @bindir@
++ @mkdir -p @datadir@/applications
++ @mkdir -p @datadir@/locale
++ @mkdir -p @datadir@/pixmaps
+ @cd po && $(MAKE) install
+ @cp -f xmule.desktop @datadir@/applications
+ @cp -f xmule.xpm @datadir@/pixmaps
diff --git a/net-p2p/xmule/files/patch-src::ClientCredits.cpp b/net-p2p/xmule/files/patch-src::ClientCredits.cpp
deleted file mode 100644
index 8277638bcad3..000000000000
--- a/net-p2p/xmule/files/patch-src::ClientCredits.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ClientCredits.cpp.orig Tue May 27 15:25:08 2003
-+++ src/ClientCredits.cpp Tue May 27 15:25:19 2003
-@@ -22,7 +22,7 @@
- #include "ClientCredits.h"
- #include "opcodes.h"
- #include <math.h>
--#include "/usr/include/time.h"
-+#include <sys/time.h>
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
diff --git a/net-p2p/xmule/pkg-plist b/net-p2p/xmule/pkg-plist
index aa4552a1e9e8..49eb51394a60 100644
--- a/net-p2p/xmule/pkg-plist
+++ b/net-p2p/xmule/pkg-plist
@@ -29,3 +29,6 @@ share/locale/tr/LC_MESSAGES/xmule.mo
@unexec rmdir %D/share/locale/ee 2>/dev/null || true
@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/de 2>/dev/null || true
+@unexec rmdir %D/share/gnome/pixmaps 2>/dev/null || true
+@unexec rmdir %D/share/gnome/locale 2>/dev/null || true
+@unexec rmdir %D/share/gnome/applications 2>/dev/null || true