aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-25 16:17:19 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-25 16:17:19 +0000
commit4d32bbcef6444fe1625b9b0a62da9c7aceadd457 (patch)
tree6b3679b99a4f945bc127fb23b5a99279be3b083d /net-p2p
parent414b46fbfaae08a771f7e9f52f788799be25a7c9 (diff)
downloadports-4d32bbcef6444fe1625b9b0a62da9c7aceadd457.tar.gz
ports-4d32bbcef6444fe1625b9b0a62da9c7aceadd457.zip
Move USE_BDB support from bsd.databases.mk to its own file.
Also: - Deorbit WANT_BDB_VER, one can use USES=bdb:<ver> instead. - USE_BDB can't happen after bsd.port.pre.mk because it is a USES. PR: 208971 Submitted by: mat Exp-run by: antoine With hat: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D5951
Notes
Notes: svn path=/head/; revision=414018
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/digitalcoin/Makefile3
-rw-r--r--net-p2p/dogecoin/Makefile3
-rw-r--r--net-p2p/namecoin/Makefile3
-rw-r--r--net-p2p/twister/Makefile3
4 files changed, 4 insertions, 8 deletions
diff --git a/net-p2p/digitalcoin/Makefile b/net-p2p/digitalcoin/Makefile
index 18e7301c06a5..4a5a75c5ae70 100644
--- a/net-p2p/digitalcoin/Makefile
+++ b/net-p2p/digitalcoin/Makefile
@@ -21,8 +21,7 @@ GH_TAGNAME= 96b098a
USES= desktop-file-utils gmake
USE_OPENSSL= yes
-USE_BDB= yes
-WANT_BDB_VER= 48
+USE_BDB= 48
USE_QT4= corelib gui qmake_build linguisttools_build uic_build \
moc_build rcc_build
diff --git a/net-p2p/dogecoin/Makefile b/net-p2p/dogecoin/Makefile
index c89b8bf02875..6dd3477308be 100644
--- a/net-p2p/dogecoin/Makefile
+++ b/net-p2p/dogecoin/Makefile
@@ -31,8 +31,7 @@ CONFIGURE_ARGS+= --with-incompatible-bdb \
CRYPTO_CFLAGS="-I${OPENSSLINC} -L${OPENSSLLIB}" CRYPTO_LIBS="-lcrypto"
CONFIGURE_ENV+= OBJC="${CC}" OBJCFLAGS="${CFLAGS}" OBJCXX="${CXX}" OBJCXXFLAGS="${CXXFLAGS}"
USE_OPENSSL= yes
-USE_BDB= yes
-WANT_BDB_VER= 5
+USE_BDB= 5
CXXFLAGS+= -I${LOCALBASE}/include -I${BDB_INCLUDE_DIR} \
-L${LOCALBASE}/lib -L${BDB_LIB_DIR}
diff --git a/net-p2p/namecoin/Makefile b/net-p2p/namecoin/Makefile
index 19fd126e9034..1180e8e00ef3 100644
--- a/net-p2p/namecoin/Makefile
+++ b/net-p2p/namecoin/Makefile
@@ -27,8 +27,7 @@ USE_GITHUB= yes
USES= gmake compiler:c++11-lib
MAKE_JOBS_UNSAFE=yes
USE_OPENSSL= yes
-USE_BDB= yes
-WANT_BDB_VER= 48
+USE_BDB= 48
CXXFLAGS+= -I${LOCALBASE}/include -I${BDB_INCLUDE_DIR}
CXXFLAGS+= -L${LOCALBASE}/lib -L${BDB_LIB_DIR}
diff --git a/net-p2p/twister/Makefile b/net-p2p/twister/Makefile
index 25f1d8ea3d72..8492c7c4c7f8 100644
--- a/net-p2p/twister/Makefile
+++ b/net-p2p/twister/Makefile
@@ -25,8 +25,7 @@ OPTIONS_DEFINE= DOCS
USE_GITHUB= yes
GH_ACCOUNT= miguelfreitas
-USE_BDB= yes
-WANT_BDB_VER= 48
+USE_BDB= 48
USE_OPENSSL= yes
USES= autoreconf:build gmake iconv libtool