aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-05-04 00:55:30 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-05-04 00:55:30 +0000
commitea53a519ba2318f639eb99060c5c8a7a67039160 (patch)
tree949aff6fa409147431ae17a8684fbfd85b5ef0a5 /net-p2p
parent88caba5c547f31f0639d90c962571ecc692b8a88 (diff)
downloadports-ea53a519ba2318f639eb99060c5c8a7a67039160.tar.gz
ports-ea53a519ba2318f639eb99060c5c8a7a67039160.zip
TorrentVolve is a cross-platform PHP-driven web-based BitTorrent client. It
focuses on speed and reliability, while also providing a full feature set. It includes a user management system, a Torrent file manager, and a configurable Torrent downloader. WWW: http://torrentvolve.sourceforge.net/
Notes
Notes: svn path=/head/; revision=191511
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/torrentvolve/Makefile35
-rw-r--r--net-p2p/torrentvolve/distinfo3
-rw-r--r--net-p2p/torrentvolve/files/patch-site__lib__torrentmodules__tvAzureusBridge__tvTelnetClient__client.php16
-rw-r--r--net-p2p/torrentvolve/pkg-descr6
-rw-r--r--net-p2p/torrentvolve/pkg-plist96
6 files changed, 157 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index 49018f39abdc..b167120de0cf 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -121,6 +121,7 @@
SUBDIR += torrent_swapper
SUBDIR += torrentflux
SUBDIR += torrentsniff
+ SUBDIR += torrentvolve
SUBDIR += trackerbt
SUBDIR += transmission
SUBDIR += transmission-gtk2
diff --git a/net-p2p/torrentvolve/Makefile b/net-p2p/torrentvolve/Makefile
new file mode 100644
index 000000000000..7acc9946f34e
--- /dev/null
+++ b/net-p2p/torrentvolve/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: torrentvolve
+# Date created: 2007-04-19
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= torrentvolve
+DISTVERSION= 1.4-beta
+CATEGORIES= net-p2p java
+MASTER_SITES= SF
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Cross-platform PHP-driven web-based BitTorrent client
+
+RUN_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+USE_PHP= simplexml
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+DATADIR= ${WWWDIR}/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${CP} -R config site ${DATADIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/INSTALL.TXT ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-p2p/torrentvolve/distinfo b/net-p2p/torrentvolve/distinfo
new file mode 100644
index 000000000000..631afb8645c5
--- /dev/null
+++ b/net-p2p/torrentvolve/distinfo
@@ -0,0 +1,3 @@
+MD5 (torrentvolve-1.4-beta.zip) = 7fae45596936d36106573c305b0825d3
+SHA256 (torrentvolve-1.4-beta.zip) = ddc2e64e471f3132e32e8b3e779920874b23793bd3a6038ad36b001f2f85f3e0
+SIZE (torrentvolve-1.4-beta.zip) = 7354164
diff --git a/net-p2p/torrentvolve/files/patch-site__lib__torrentmodules__tvAzureusBridge__tvTelnetClient__client.php b/net-p2p/torrentvolve/files/patch-site__lib__torrentmodules__tvAzureusBridge__tvTelnetClient__client.php
new file mode 100644
index 000000000000..6b14ada6bcca
--- /dev/null
+++ b/net-p2p/torrentvolve/files/patch-site__lib__torrentmodules__tvAzureusBridge__tvTelnetClient__client.php
@@ -0,0 +1,16 @@
+--- ./site/lib/torrentmodules/tvAzureusBridge/tvTelnetClient/client.php.orig Tue Jan 2 07:14:20 2007
++++ ./site/lib/torrentmodules/tvAzureusBridge/tvTelnetClient/client.php Sun Apr 22 18:57:45 2007
+@@ -74,10 +74,10 @@
+ public function startLocalServer() {
+
+ $path = $this->appPath . '../azureusServer';
+- $command = 'java -Dazureus.config.path="' . $path . '" -jar "' . $path . '/Azureus2.jar" --ui=telnet';
++ $command = 'env JAVA_VERSION=1.5+ java -Dazureus.config.path="' . $path . '" -jar "' . $path . '/Azureus2.jar" --ui=telnet';
+
+ if (strtoupper(substr(PHP_OS, 0, 3) == 'WIN')) popen('start /D"' . $path . '" ' . $command, 'w');
+ else exec("$command > /dev/null 2>&1 &");
+ }
+ }
+-?>
+\ No newline at end of file
++?>
diff --git a/net-p2p/torrentvolve/pkg-descr b/net-p2p/torrentvolve/pkg-descr
new file mode 100644
index 000000000000..5dfeebea646d
--- /dev/null
+++ b/net-p2p/torrentvolve/pkg-descr
@@ -0,0 +1,6 @@
+TorrentVolve is a cross-platform PHP-driven web-based BitTorrent client. It
+focuses on speed and reliability, while also providing a full feature set. It
+includes a user management system, a Torrent file manager, and a configurable
+Torrent downloader.
+
+WWW: http://torrentvolve.sourceforge.net/
diff --git a/net-p2p/torrentvolve/pkg-plist b/net-p2p/torrentvolve/pkg-plist
new file mode 100644
index 000000000000..13048a64db27
--- /dev/null
+++ b/net-p2p/torrentvolve/pkg-plist
@@ -0,0 +1,96 @@
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.TXT
+%%DATADIR%%/site/admin/addUser.php
+%%DATADIR%%/site/admin/index.php
+%%DATADIR%%/site/admin/install.php
+%%DATADIR%%/site/admin/login.php
+%%DATADIR%%/site/admin/users.php
+%%DATADIR%%/site/archive.php
+%%DATADIR%%/site/download.php
+%%DATADIR%%/site/forgotPassword.php
+%%DATADIR%%/site/index.php
+%%DATADIR%%/site/install.php
+%%DATADIR%%/site/lib/configuration.php
+%%DATADIR%%/site/lib/directory.php
+%%DATADIR%%/site/lib/driveSpace.php
+%%DATADIR%%/site/lib/load_settings.php
+%%DATADIR%%/site/lib/pclzip.lib.php
+%%DATADIR%%/site/lib/torrent.php
+%%DATADIR%%/site/lib/torrent_module_loader.php
+%%DATADIR%%/site/lib/torrentmodules/i_torrent_functions.php
+%%DATADIR%%/site/lib/torrentmodules/tvAzureusBridge/azureusServer/Azureus2.jar
+%%DATADIR%%/site/lib/torrentmodules/tvAzureusBridge/azureusServer/commons-cli.jar
+%%DATADIR%%/site/lib/torrentmodules/tvAzureusBridge/azureusServer/log4j.jar
+%%DATADIR%%/site/lib/torrentmodules/tvAzureusBridge/torrent_functions.php
+%%DATADIR%%/site/lib/torrentmodules/tvAzureusBridge/tvTelnetClient/client.php
+%%DATADIR%%/site/lib/update_manager.php
+%%DATADIR%%/site/lib/user.php
+%%DATADIR%%/site/load.php
+%%DATADIR%%/site/login.php
+%%DATADIR%%/site/logout.php
+%%DATADIR%%/site/master.php
+%%DATADIR%%/site/master/css/adminAddUser.css
+%%DATADIR%%/site/master/css/adminIndex.css
+%%DATADIR%%/site/master/css/adminUsers.css
+%%DATADIR%%/site/master/css/archive.css
+%%DATADIR%%/site/master/css/forgotPassword.css
+%%DATADIR%%/site/master/css/index.css
+%%DATADIR%%/site/master/css/install.css
+%%DATADIR%%/site/master/css/load.css
+%%DATADIR%%/site/master/css/login.css
+%%DATADIR%%/site/master/css/master.css
+%%DATADIR%%/site/master/css/masterIndex.css
+%%DATADIR%%/site/master/css/torrentSettings.css
+%%DATADIR%%/site/master/css/userIndex.css
+%%DATADIR%%/site/master/images/admin.gif
+%%DATADIR%%/site/master/images/adminAddUser.gif
+%%DATADIR%%/site/master/images/archiveDownloadedFiles.gif
+%%DATADIR%%/site/master/images/archiveTorrents.gif
+%%DATADIR%%/site/master/images/background.gif
+%%DATADIR%%/site/master/images/bannerAutoDownload.gif
+%%DATADIR%%/site/master/images/bannerTorrents.gif
+%%DATADIR%%/site/master/images/btnBrowse.gif
+%%DATADIR%%/site/master/images/btnUpload.gif
+%%DATADIR%%/site/master/images/configureTorrent.gif
+%%DATADIR%%/site/master/images/driveInformation.gif
+%%DATADIR%%/site/master/images/driveStatus.gif
+%%DATADIR%%/site/master/images/installLogo.gif
+%%DATADIR%%/site/master/images/leftBorder.gif
+%%DATADIR%%/site/master/images/loadTorrent.gif
+%%DATADIR%%/site/master/images/loginButton.gif
+%%DATADIR%%/site/master/images/loginLogo.gif
+%%DATADIR%%/site/master/images/logo.gif
+%%DATADIR%%/site/master/images/logo.old.gif
+%%DATADIR%%/site/master/images/minus.gif
+%%DATADIR%%/site/master/images/password.gif
+%%DATADIR%%/site/master/images/plus.gif
+%%DATADIR%%/site/master/images/removeTorrent.gif
+%%DATADIR%%/site/master/images/retrievePassword.gif
+%%DATADIR%%/site/master/images/searchHDD.gif
+%%DATADIR%%/site/master/images/single.gif
+%%DATADIR%%/site/master/images/startTorrent.gif
+%%DATADIR%%/site/master/images/stopTorrent.gif
+%%DATADIR%%/site/master/images/topBannerBack.gif
+%%DATADIR%%/site/master/images/torrentPercent.gif
+%%DATADIR%%/site/master/images/userAdministration.gif
+%%DATADIR%%/site/master/js/adminAddUser.js
+%%DATADIR%%/site/master/js/login.js
+%%DATADIR%%/site/master/js/userIndex.js
+%%DATADIR%%/site/torrentSettings.php
+%%DATADIR%%/site/user/index.php
+%%DATADIR%%/site/user/install.php
+%%DATADIR%%/site/user/login.php
+@dirrm %%DATADIR%%/site/user
+@dirrm %%DATADIR%%/site/master/js
+@dirrm %%DATADIR%%/site/master/images
+@dirrm %%DATADIR%%/site/master/css
+@dirrm %%DATADIR%%/site/master
+@dirrm %%DATADIR%%/site/lib/torrentmodules/tvAzureusBridge/tvTelnetClient
+@dirrm %%DATADIR%%/site/lib/torrentmodules/tvAzureusBridge/azureusServer
+@dirrm %%DATADIR%%/site/lib/torrentmodules/tvAzureusBridge
+@dirrm %%DATADIR%%/site/lib/torrentmodules
+@dirrm %%DATADIR%%/site/lib
+@dirrm %%DATADIR%%/site/admin
+@dirrm %%DATADIR%%/site
+@dirrm %%DATADIR%%/config
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%