aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-06-23 20:00:35 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-06-23 20:00:35 +0000
commit94d2f727da23cbb065a8adb8a3ea36011868739a (patch)
tree2fb537def40bdce6f62718ec1361ce3920a07e72 /net-p2p
parent2cbd3442fb5a0feaec0b3a9ed249c278692dade5 (diff)
downloadports-94d2f727da23cbb065a8adb8a3ea36011868739a.tar.gz
ports-94d2f727da23cbb065a8adb8a3ea36011868739a.zip
Verlihub Contro Panel is a tool for the administration of your hubsoft
VerliHub 0.9.7 (or higher). It's written in PHP so you can use it on every OS that runs Apache Web Server with PHP support. WWW: http://vhcp.verlihub-project.org/viewforum.php?f=32 PR: ports/135886 Submitted by: Maxim Ignatenko
Notes
Notes: svn path=/head/; revision=236549
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/vhcp/Makefile57
-rw-r--r--net-p2p/vhcp/distinfo3
-rw-r--r--net-p2p/vhcp/files/pkg-message.in4
-rw-r--r--net-p2p/vhcp/pkg-descr5
5 files changed, 70 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index c21fb96d2eee..4388b1940adc 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -138,6 +138,7 @@
SUBDIR += verlihub-plugins-luascript
SUBDIR += verlihub-plugins-messanger
SUBDIR += verlihub-plugins-stats
+ SUBDIR += vhcp
SUBDIR += vuze
SUBDIR += xnap
diff --git a/net-p2p/vhcp/Makefile b/net-p2p/vhcp/Makefile
new file mode 100644
index 000000000000..17b4de0ace41
--- /dev/null
+++ b/net-p2p/vhcp/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: vhcp
+# Date created: 20 June 2009
+# Whom: Maxim Ignatenko
+#
+# $FreeBSD$
+#
+
+PORTNAME= vhcp
+PORTVERSION= 1.7g2
+CATEGORIES= net-p2p www
+MASTER_SITES= SF
+DISTNAME= vhcp_v${PORTVERSION}
+
+MAINTAINER= gelraen.ua@gmail.com
+COMMENT= Verlihub control panel
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_PHP= mysql gd
+NO_BUILD= YES
+WANT_PHP_WEB= YES
+DEFAULT_PHP_VER= 5
+VHCPDIR?= www/vhcp
+SUB_FILES= pkg-message
+SUB_LIST+= VHCPDIR=${VHCPDIR}
+PLIST= ${WRKDIR}/pkg-plist
+
+pre-install:
+ @if [ -f ${WRKSRC}/config.php ]; then \
+ ${MV} ${WRKSRC}/config.php ${WRKSRC}/config.php.dist ; fi
+ @cd ${WRKSRC} && \
+ ${ECHO_CMD} "@unexec if cmp -s %D/${VHCPDIR}/config.php.dist \
+ %D/${VHCPDIR}/config.php; then \
+ ${RM} -f %D/${VHCPDIR}/config.php; fi" > ${PLIST} && \
+ ${FIND} -s * -type f | \
+ ${SED} -e 's|^|${VHCPDIR}/|g' >> ${PLIST} && \
+ ${ECHO_CMD} "@exec if [ ! -f %D/${VHCPDIR}/config.php ] ; then \
+ ${CP} -p %D/${VHCPDIR}/config.php.dist \
+ %D/${VHCPDIR}/config.php; fi" >> ${PLIST} && \
+ ${FIND} -d * -type d | \
+ ${SED} -e 's|^|@dirrm ${VHCPDIR}/|g' >> ${PLIST} && \
+ ${ECHO_CMD} @dirrm ${VHCPDIR} >> ${PLIST}
+
+do-install:
+ -@${MKDIR} ${PREFIX}/${VHCPDIR}
+ @${CHOWN} ${WWWOWN}:${WWWGRP} ${PREFIX}/${VHCPDIR}
+ @${CHMOD} 755 ${PREFIX}/${VHCPDIR}
+ @${CP} -R ${WRKSRC}/ ${PREFIX}/${VHCPDIR}
+ if [ ! -f ${PREFIX}/${VHCPDIR}/config.php ]; then \
+ ${CP} ${PREFIX}/${VHCPDIR}/config.php.dist \
+ ${PREFIX}/${VHCPDIR}/config.php ; \
+ fi
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net-p2p/vhcp/distinfo b/net-p2p/vhcp/distinfo
new file mode 100644
index 000000000000..1cc093f79940
--- /dev/null
+++ b/net-p2p/vhcp/distinfo
@@ -0,0 +1,3 @@
+MD5 (vhcp_v1.7g2.tar.gz) = 4583f1fc0578f2b85620eaa8cdd79723
+SHA256 (vhcp_v1.7g2.tar.gz) = 2e366a428009952b8d7b4358a143d5125a35258ae3a8007dd4b00309380b6462
+SIZE (vhcp_v1.7g2.tar.gz) = 235611
diff --git a/net-p2p/vhcp/files/pkg-message.in b/net-p2p/vhcp/files/pkg-message.in
new file mode 100644
index 000000000000..ec8f6c418fff
--- /dev/null
+++ b/net-p2p/vhcp/files/pkg-message.in
@@ -0,0 +1,4 @@
+
+Don't forget to edit %%PREFIX%%/%%VHCPDIR%%/config.php to point to your
+existing verlihub config database
+
diff --git a/net-p2p/vhcp/pkg-descr b/net-p2p/vhcp/pkg-descr
new file mode 100644
index 000000000000..b5bfe2f74326
--- /dev/null
+++ b/net-p2p/vhcp/pkg-descr
@@ -0,0 +1,5 @@
+Verlihub Contro Panel is a tool for the administration of your hubsoft
+VerliHub 0.9.7 (or higher). It's written in PHP so you can use it on
+every OS that runs Apache Web Server with PHP support.
+
+WWW: http://vhcp.verlihub-project.org/viewforum.php?f=32