aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
committerAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
commit54a0b86543e9ffa811825f0afecea56e89aac2a5 (patch)
treef56fb969c6a70f5e63287a4f791d035ab1ef0ddc /net-p2p
parent1fccb46f1497a538f24ec00f14b7826570bc0a3a (diff)
downloadports-54a0b86543e9ffa811825f0afecea56e89aac2a5.tar.gz
ports-54a0b86543e9ffa811825f0afecea56e89aac2a5.zip
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Notes
Notes: svn path=/head/; revision=148323
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/apollon/Makefile2
-rw-r--r--net-p2p/cdonkey/Makefile2
-rw-r--r--net-p2p/dcd/Makefile2
-rw-r--r--net-p2p/dclib/Makefile2
-rw-r--r--net-p2p/edonkey-tool-hash/Makefile2
-rw-r--r--net-p2p/fcptools/Makefile2
-rw-r--r--net-p2p/gift/Makefile2
-rw-r--r--net-p2p/gkrellm-gift/Makefile2
-rw-r--r--net-p2p/gnunet/Makefile3
-rw-r--r--net-p2p/libfreenet/Makefile2
-rw-r--r--net-p2p/libtorrent/Makefile2
-rw-r--r--net-p2p/mldonkey-devel/Makefile2
-rw-r--r--net-p2p/mldonkey/Makefile2
-rw-r--r--net-p2p/rtorrent/Makefile2
-rw-r--r--net-p2p/verlihub-plugins/Makefile2
-rw-r--r--net-p2p/verlihub/Makefile2
16 files changed, 16 insertions, 17 deletions
diff --git a/net-p2p/apollon/Makefile b/net-p2p/apollon/Makefile
index bce6f1c95924..fd4b9d195342 100644
--- a/net-p2p/apollon/Makefile
+++ b/net-p2p/apollon/Makefile
@@ -22,7 +22,7 @@ USE_KDELIBS_VER=3
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
.include <bsd.port.pre.mk>
diff --git a/net-p2p/cdonkey/Makefile b/net-p2p/cdonkey/Makefile
index d806d330287f..7d09fa56279a 100644
--- a/net-p2p/cdonkey/Makefile
+++ b/net-p2p/cdonkey/Makefile
@@ -21,7 +21,7 @@ PLIST_FILES= bin/cDonkey
USE_BZIP2= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-berkeley-db="${LOCALBASE}/include/db3:${LOCALBASE}/lib"
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/cDonkey-${PORTVERSION}
diff --git a/net-p2p/dcd/Makefile b/net-p2p/dcd/Makefile
index 90b507259478..702f14b8f1d2 100644
--- a/net-p2p/dcd/Makefile
+++ b/net-p2p/dcd/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= mraleks@bk.ru
COMMENT= Direct Connect Hub clone for Unix
USE_BZIP2= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
diff --git a/net-p2p/dclib/Makefile b/net-p2p/dclib/Makefile
index 77729151784a..8858c847be8e 100644
--- a/net-p2p/dclib/Makefile
+++ b/net-p2p/dclib/Makefile
@@ -23,7 +23,7 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
USE_OPENSSL= yes
INSTALLS_SHLIB= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/net-p2p/edonkey-tool-hash/Makefile b/net-p2p/edonkey-tool-hash/Makefile
index 42734de85a04..65e0bc642ad9 100644
--- a/net-p2p/edonkey-tool-hash/Makefile
+++ b/net-p2p/edonkey-tool-hash/Makefile
@@ -18,7 +18,7 @@ COMMENT= Both calculates 'eDonkey/Overnet hashes' producing ed2k:// file links
PLIST_FILES= bin/edonkey-tool-hash
USE_REINPLACE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/ed2k_hash-${PORTVERSION}
diff --git a/net-p2p/fcptools/Makefile b/net-p2p/fcptools/Makefile
index 492bc06d754f..8c02412aa76b 100644
--- a/net-p2p/fcptools/Makefile
+++ b/net-p2p/fcptools/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= lioux@FreeBSD.org
COMMENT= FreeNet client library and command-line tools for shell scripting
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --includedir=${PREFIX}/include/${PORTNAME:L}
INSTALLS_SHLIB= yes
diff --git a/net-p2p/gift/Makefile b/net-p2p/gift/Makefile
index 9c3a1ccef895..b58adea5b45a 100644
--- a/net-p2p/gift/Makefile
+++ b/net-p2p/gift/Makefile
@@ -18,7 +18,7 @@ COMMENT= An OpenFT, Gnutella and FastTrack p2p network client
LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis
-USE_LIBLTDL= yes
+USE_AUTOTOOLS= libltdl:15
USE_BZIP2= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
diff --git a/net-p2p/gkrellm-gift/Makefile b/net-p2p/gkrellm-gift/Makefile
index 2239f2bc1dc7..cdf37db41d9a 100644
--- a/net-p2p/gkrellm-gift/Makefile
+++ b/net-p2p/gkrellm-gift/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= gift.0:${PORTSDIR}/net/gift
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
USE_X_PREFIX= yes
PLIST_FILES= libexec/gkrellm2/plugins/gift.so
diff --git a/net-p2p/gnunet/Makefile b/net-p2p/gnunet/Makefile
index aee271e4031c..77d34182b123 100644
--- a/net-p2p/gnunet/Makefile
+++ b/net-p2p/gnunet/Makefile
@@ -20,13 +20,12 @@ COMMENT= An anonymous, distributed, reputation-based network
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
-USE_LIBLTDL= yes
+USE_AUTOTOOLS= libltdl:15 libtool:13:inc
USE_BZIP2= yes
USE_GETOPT_LONG= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnometarget gtk20 lthack
-USE_INC_LIBTOOL_VER=13
USE_OPENSSL= yes
USE_REINPLACE= yes
diff --git a/net-p2p/libfreenet/Makefile b/net-p2p/libfreenet/Makefile
index dc23fadbf3f5..4128446f84fc 100644
--- a/net-p2p/libfreenet/Makefile
+++ b/net-p2p/libfreenet/Makefile
@@ -18,7 +18,7 @@ COMMENT= Freenet library written in C
USE_REINPLACE= yes
USE_OPENSSL= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --includedir=${PREFIX}/include/libfreenet
INSTALLS_SHLIB= yes
diff --git a/net-p2p/libtorrent/Makefile b/net-p2p/libtorrent/Makefile
index 2e8ffe170236..49771d90035f 100644
--- a/net-p2p/libtorrent/Makefile
+++ b/net-p2p/libtorrent/Makefile
@@ -19,7 +19,7 @@ USE_GCC= 3.4
USE_GNOME= pkgconfig gnomehack
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-USE_INC_LIBTOOL_VER= 13
+USE_AUTOTOOLS= libtool:13:inc
CONFIGURE_ARGS= --disable-debug
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/net-p2p/mldonkey-devel/Makefile b/net-p2p/mldonkey-devel/Makefile
index f89ad3d606cc..6a13bc815a29 100644
--- a/net-p2p/mldonkey-devel/Makefile
+++ b/net-p2p/mldonkey-devel/Makefile
@@ -23,7 +23,7 @@ CONFLICTS= mldonkey-[0-9]*
USE_BZIP2= yes
USE_ICONV= yes
USE_RC_SUBR= yes
-WANT_AUTOCONF_VER= 259
+USE_AUTOTOOLS= autoconf:259:env
USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/net-p2p/mldonkey/Makefile b/net-p2p/mldonkey/Makefile
index 94243bb28bda..1c93695909a1 100644
--- a/net-p2p/mldonkey/Makefile
+++ b/net-p2p/mldonkey/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
CONFLICTS= mldonkey-devel-[0-9]*
USE_BZIP2= yes
-WANT_AUTOCONF_VER= 259
+USE_AUTOTOOLS= autoconf:259:env
USE_REINPLACE= yes
USE_OPENSSL= yes
USE_ICONV= yes
diff --git a/net-p2p/rtorrent/Makefile b/net-p2p/rtorrent/Makefile
index c49825599c58..1e678dbeaa93 100644
--- a/net-p2p/rtorrent/Makefile
+++ b/net-p2p/rtorrent/Makefile
@@ -23,7 +23,7 @@ USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-debug
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-USE_INC_LIBTOOL_VER= 13
+USE_AUTOTOOLS= libtool:13:inc
SUB_FILES= pkg-message
diff --git a/net-p2p/verlihub-plugins/Makefile b/net-p2p/verlihub-plugins/Makefile
index d97da078109b..08def04562d9 100644
--- a/net-p2p/verlihub-plugins/Makefile
+++ b/net-p2p/verlihub-plugins/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua
WRKSRC= ${WRKDIR}/vh_plugins-0.1
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15:inc
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/include/verlihub
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/verlihub -I${LOCALBASE}/include/mysql"
diff --git a/net-p2p/verlihub/Makefile b/net-p2p/verlihub/Makefile
index 071d57db9bf6..33a204d8a2c5 100644
--- a/net-p2p/verlihub/Makefile
+++ b/net-p2p/verlihub/Makefile
@@ -25,7 +25,7 @@ WRKSRC= ${WRKDIR}/verlihub-0.9.8c
USE_MYSQL= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15:inc
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"