aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-09-03 17:40:21 +0000
committerSteve Wills <swills@FreeBSD.org>2012-09-03 17:40:21 +0000
commit24b332e8ee1c07c1d5a33a1265ebb3fc70a74d9b (patch)
tree537028858204a0e76868de5f2bfb19d29e992e27 /net-p2p
parent5f7a2eef1ddfb7a0f0b3ce12577e2439f527b661 (diff)
downloadports-24b332e8ee1c07c1d5a33a1265ebb3fc70a74d9b.tar.gz
ports-24b332e8ee1c07c1d5a33a1265ebb3fc70a74d9b.zip
- Fix another high CPU usage condition
Notes
Notes: svn path=/head/; revision=303607
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin/Makefile2
-rw-r--r--net-p2p/bitcoin/files/patch-bitcoin.cpp20
2 files changed, 21 insertions, 1 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index 08500a34979b..ed680bf4fd5b 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bitcoin
PORTVERSION= 0.6.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-p2p finance
MAINTAINER= ports@FreeBSD.org
diff --git a/net-p2p/bitcoin/files/patch-bitcoin.cpp b/net-p2p/bitcoin/files/patch-bitcoin.cpp
new file mode 100644
index 000000000000..d42c22427af8
--- /dev/null
+++ b/net-p2p/bitcoin/files/patch-bitcoin.cpp
@@ -0,0 +1,20 @@
+--- src/qt/bitcoin.cpp.orig 2012-06-19 16:44:55.000000000 -0400
++++ src/qt/bitcoin.cpp 2012-09-03 13:30:43.641710746 -0400
+@@ -134,7 +134,7 @@
+ #ifndef BITCOIN_QT_TEST
+ int main(int argc, char *argv[])
+ {
+-#if !defined(MAC_OSX) && !defined(WIN32)
++#if !defined(MAC_OSX) && !defined(WIN32) && !defined(__FreeBSD__)
+ // TODO: implement qtipcserver.cpp for Mac and Windows
+
+ // Do this early as we don't want to bother initializing if we are just calling IPC
+@@ -261,7 +261,7 @@
+ // Place this here as guiref has to be defined if we dont want to lose URIs
+ ipcInit();
+
+-#if !defined(MAC_OSX) && !defined(WIN32)
++#if !defined(MAC_OSX) && !defined(WIN32) && !defined(__FreeBSD__)
+ // TODO: implement qtipcserver.cpp for Mac and Windows
+
+ // Check for URI in argv