aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-09-23 19:45:49 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-09-23 19:45:49 +0000
commit873369f4d160ac3470591fccbf59708c7ca107dd (patch)
tree1bab6578b6b771e3f4b49298b042455886453cb8 /net-p2p
parent285ba66f92e5ce540bc7b6ee3b5ec60401971ed7 (diff)
downloadports-873369f4d160ac3470591fccbf59708c7ca107dd.tar.gz
ports-873369f4d160ac3470591fccbf59708c7ca107dd.zip
Restore ktorren-4.2 behaviour - don't check for mounted fs. The check
was added to support removable storages, but it causes problem with btrfs and zfs: https://bugs.kde.org/306825
Notes
Notes: svn path=/head/; revision=304764
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/Makefile1
-rw-r--r--net-p2p/ktorrent/files/patch-ktorrent__core.cpp29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-p2p/ktorrent/Makefile b/net-p2p/ktorrent/Makefile
index 48175f69246a..52ec958ca4fe 100644
--- a/net-p2p/ktorrent/Makefile
+++ b/net-p2p/ktorrent/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ktorrent
DISTVERSION= 4.3.0
+PORTREVISION= 1
CATEGORIES= net-p2p kde
MASTER_SITES= http://ktorrent.org/downloads/${DISTVERSION}/
diff --git a/net-p2p/ktorrent/files/patch-ktorrent__core.cpp b/net-p2p/ktorrent/files/patch-ktorrent__core.cpp
new file mode 100644
index 000000000000..c5f146054f64
--- /dev/null
+++ b/net-p2p/ktorrent/files/patch-ktorrent__core.cpp
@@ -0,0 +1,29 @@
+--- ./ktorrent/core.cpp.orig 2012-09-01 08:59:57.000000000 +0000
++++ ./ktorrent/core.cpp 2012-09-23 19:02:36.644549119 +0000
+@@ -1206,26 +1206,6 @@
+
+ bool Core::checkMissingFiles(TorrentInterface* tc)
+ {
+- QStringList not_mounted;
+- while(!tc->isStorageMounted(not_mounted))
+- {
+- QString msg = i18n("One or more storage volumes are not mounted. In order to start this torrent, they need to be mounted.");
+- KGuiItem retry(i18n("Retry"), "emblem-mounted");
+- if(KMessageBox::warningContinueCancelList(gui, msg, not_mounted, QString(), retry) == KMessageBox::Continue)
+- {
+- not_mounted.clear();
+- continue;
+- }
+- else
+- {
+- if(not_mounted.size() == 1)
+- tc->handleError(i18n("Storage volume %1 is not mounted", not_mounted.first()));
+- else
+- tc->handleError(i18n("Storage volumes %1 are not mounted", not_mounted.join(", ")));
+- return false;
+- }
+- }
+-
+ QStringList missing;
+ if(!tc->hasMissingFiles(missing))
+ return true;