aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2010-08-21 20:04:36 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2010-08-21 20:04:36 +0000
commit567a4282c07dae5f76285fb6f6c41fa63a37cbbf (patch)
treed4655ea11b920d27dfd43631a40f629a01043de2 /net-p2p
parentd00d8a05db3f29e07b7ab83daba101ff662543ee (diff)
downloadports-567a4282c07dae5f76285fb6f6c41fa63a37cbbf.tar.gz
ports-567a4282c07dae5f76285fb6f6c41fa63a37cbbf.zip
Update to 1.3.0_rc2
Notes
Notes: svn path=/head/; revision=259693
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/Makefile6
-rw-r--r--net-p2p/deluge/distinfo6
-rw-r--r--net-p2p/deluge/files/patch-setup.py49
-rw-r--r--net-p2p/deluge/pkg-plist4
4 files changed, 26 insertions, 39 deletions
diff --git a/net-p2p/deluge/Makefile b/net-p2p/deluge/Makefile
index f8e73e65f323..5651ec82c7b7 100644
--- a/net-p2p/deluge/Makefile
+++ b/net-p2p/deluge/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= deluge
-DISTVERSION= 1.3.0_rc1
-PORTREVISION= 1
+DISTVERSION= 1.3.0_rc2
PORTEPOCH= 1
CATEGORIES= net-p2p python
MASTER_SITES= http://download.deluge-torrent.org/source/
@@ -76,8 +75,7 @@ INSTALLS_ICONS= yes
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g ; \
- s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' \
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/setup.py
${REINPLACE_CMD} -e '/"new_release_check":/s|True,|False,|g ; \
/"geoip_db_location":/s|/usr/share/GeoIP/GeoIP.dat|${LOCALBASE}/share/GeoIP/GeoIP.dat|g' \
diff --git a/net-p2p/deluge/distinfo b/net-p2p/deluge/distinfo
index 56189270886e..263a2e1cb25d 100644
--- a/net-p2p/deluge/distinfo
+++ b/net-p2p/deluge/distinfo
@@ -1,3 +1,3 @@
-MD5 (deluge-1.3.0_rc1.tar.bz2) = 9ee0e29c915d7a837371cfcb60b00000
-SHA256 (deluge-1.3.0_rc1.tar.bz2) = 0586fc60dff584799954fad64597fb9436e4754a1ec06ccad59ca8f3f0d8db71
-SIZE (deluge-1.3.0_rc1.tar.bz2) = 2312181
+MD5 (deluge-1.3.0_rc2.tar.bz2) = 248fb524c6b05157294125f6b16f27ca
+SHA256 (deluge-1.3.0_rc2.tar.bz2) = 068c3fa0032eec8749ac8a5fcbe28293eae451d162438ce9ca4ace031a4b577a
+SIZE (deluge-1.3.0_rc2.tar.bz2) = 2343332
diff --git a/net-p2p/deluge/files/patch-setup.py b/net-p2p/deluge/files/patch-setup.py
index e865b7a6f230..294f27b847e4 100644
--- a/net-p2p/deluge/files/patch-setup.py
+++ b/net-p2p/deluge/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2010-01-10 06:16:08.000000000 +0900
-+++ setup.py 2010-01-13 16:48:06.000000000 +0900
-@@ -67,7 +67,6 @@
+--- setup.py.orig 2010-08-20 18:20:27.000000000 -0300
++++ setup.py 2010-08-21 16:49:05.000000000 -0300
+@@ -68,7 +68,6 @@
"-D_FILE_OFFSET_BITS=64",
"-DNDEBUG",
"-DTORRENT_USE_OPENSSL=1",
@@ -8,8 +8,8 @@
]
if windows_check():
-@@ -113,12 +112,14 @@
- sysconfig.get_config_vars()["OPT"] = " ".join(cv_opt.split())
+@@ -115,12 +114,14 @@
+ remove_from_cflags(removals)
_library_dirs = [
+ '%%LOCALBASE%%/lib'
@@ -24,7 +24,7 @@
]
if windows_check():
-@@ -140,14 +141,6 @@
+@@ -142,14 +143,6 @@
'zlib'
]
else:
@@ -39,7 +39,7 @@
if osx_check():
_include_dirs += [
'/opt/local/include/boost-1_35',
-@@ -161,7 +154,6 @@
+@@ -163,7 +156,6 @@
'boost_iostreams',
'boost_python',
'boost_thread',
@@ -47,39 +47,24 @@
'ssl',
'z'
]
-@@ -204,12 +196,6 @@
-
- # Check for a system libtorrent and if found, then do not build the libtorrent extension
- build_libtorrent = True
--try:
-- from deluge._libtorrent import lt
--except ImportError:
-- build_libtorrent = True
--else:
-- build_libtorrent = False
-
- if build_libtorrent and os.path.exists("libtorrent"):
- # There isn't a system libtorrent library, so let's build the one included with deluge
-@@ -219,6 +205,7 @@
- include_dirs = _include_dirs,
- libraries = _libraries,
- library_dirs = _library_dirs,
-+ extra_link_args = ['%%PTHREAD_LIBS%%'],
- sources = _sources
- )
+@@ -212,6 +204,7 @@
+ build_libtorrent = True
+ else:
+ build_libtorrent = False
++build_libtorrent = False
-@@ -356,8 +343,8 @@
+ if build_libtorrent:
+ got_libtorrent = False
+@@ -392,8 +385,6 @@
for cmd_name in self.get_sub_commands():
self.run_command(cmd_name)
_install.run(self)
- if not self.root:
- self.do_egg_install()
-+# if not self.root:
-+# self.do_egg_install()
cmdclass = {
'build': build,
-@@ -371,7 +358,7 @@
+@@ -409,7 +400,7 @@
# Data files to be installed to the system
_data_files = [
@@ -88,7 +73,7 @@
('share/icons/hicolor/128x128/apps', ['deluge/data/icons/hicolor/128x128/apps/deluge.png']),
('share/icons/hicolor/16x16/apps', ['deluge/data/icons/hicolor/16x16/apps/deluge.png']),
('share/icons/hicolor/192x192/apps', ['deluge/data/icons/hicolor/192x192/apps/deluge.png']),
-@@ -386,7 +373,7 @@
+@@ -424,7 +415,7 @@
('share/icons/hicolor/96x96/apps', ['deluge/data/icons/hicolor/96x96/apps/deluge.png']),
('share/applications', ['deluge/data/share/applications/deluge.desktop']),
('share/pixmaps', ['deluge/data/pixmaps/deluge.png', 'deluge/data/pixmaps/deluge.xpm']),
diff --git a/net-p2p/deluge/pkg-plist b/net-p2p/deluge/pkg-plist
index 9fbd63756def..c74234b30613 100644
--- a/net-p2p/deluge/pkg-plist
+++ b/net-p2p/deluge/pkg-plist
@@ -1166,6 +1166,9 @@ bin/deluged
%%PYTHON_SITELIBDIR%%/deluge/ui/web/icons/add_url.png
%%PYTHON_SITELIBDIR%%/deluge/ui/web/icons/alert.png
%%PYTHON_SITELIBDIR%%/deluge/ui/web/icons/all.png
+%%PYTHON_SITELIBDIR%%/deluge/ui/web/icons/apple-pre-114.png
+%%PYTHON_SITELIBDIR%%/deluge/ui/web/icons/apple-pre-57.png
+%%PYTHON_SITELIBDIR%%/deluge/ui/web/icons/apple-pre-72.png
%%PYTHON_SITELIBDIR%%/deluge/ui/web/icons/back.png
%%PYTHON_SITELIBDIR%%/deluge/ui/web/icons/bottom.png
%%PYTHON_SITELIBDIR%%/deluge/ui/web/icons/checking.png
@@ -1301,6 +1304,7 @@ bin/deluged
%%PYTHON_SITELIBDIR%%/deluge/ui/web/js/ext-extensions/form/ToggleField.js
%%PYTHON_SITELIBDIR%%/deluge/ui/web/js/ext-extensions/grid/BufferView.js
%%PYTHON_SITELIBDIR%%/deluge/ui/web/js/ext-extensions/layout/FormLayoutFix.js
+%%PYTHON_SITELIBDIR%%/deluge/ui/web/js/ext-extensions/tree/MultiSelectionModelFix.js
%%PYTHON_SITELIBDIR%%/deluge/ui/web/js/ext-extensions/tree/TreeGrid.js
%%PYTHON_SITELIBDIR%%/deluge/ui/web/js/ext-extensions/tree/TreeGridColumnResizer.js
%%PYTHON_SITELIBDIR%%/deluge/ui/web/js/ext-extensions/tree/TreeGridColumns.js