aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-10-12 15:10:08 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-10-12 15:10:08 +0000
commit95e23217c4b34349c53cc454adadf54155c56a1e (patch)
treeb865792224f7b82f36c388d033bda07fc146a926 /net-p2p
parentc4835ebf8ac7c77df6e3b7417e2bd6232660e285 (diff)
downloadports-95e23217c4b34349c53cc454adadf54155c56a1e.tar.gz
ports-95e23217c4b34349c53cc454adadf54155c56a1e.zip
Fix build
Installs sample gnunet-conf Installs some documentation PR: ports/72299 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu>
Notes
Notes: svn path=/head/; revision=119048
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gnunet/Makefile17
-rw-r--r--net-p2p/gnunet/files/patch-src_applications_afs_module_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_applications_afs_tools_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_applications_chat_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_applications_dht_tools_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_applications_stats_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_applications_tbench_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_applications_testbed_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_applications_tracekit_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_conf_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_include_gnunet__util.h34
-rw-r--r--net-p2p/gnunet/files/patch-src_server_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_transports_udp6.c21
-rw-r--r--net-p2p/gnunet/pkg-plist5
14 files changed, 214 insertions, 3 deletions
diff --git a/net-p2p/gnunet/Makefile b/net-p2p/gnunet/Makefile
index 1a718dfd488d..2e986296acc8 100644
--- a/net-p2p/gnunet/Makefile
+++ b/net-p2p/gnunet/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gnunet
PORTVERSION= 0.6.4
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.ovmj.org/GNUnet/download/ \
${MASTER_SITE_GNU}
@@ -19,8 +20,6 @@ COMMENT= An anonymous, distributed, reputation-based network
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
-BROKEN= "Does not compile"
-
USE_LIBLTDL= yes
USE_BZIP2= yes
USE_GETOPT_LONG= yes
@@ -35,7 +34,7 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
-CONFIGURE_ARGS= --disable-ltdl-install
+CONFIGURE_ARGS= --disable-ltdl-install --with-crypto
LDFLAGS+= -L${LOCALBASE}/lib
.if defined(WITH_GDBM)
@@ -103,5 +102,17 @@ post-patch:
${REINPLACE_CMD} -e \
's|^#include <values.h>|#include <limits.h>|g' \
${WRKSRC}/src/applications/afs/module/manager.c
+ ${REINPLACE_CMD} -e \
+ 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/src/include/gnunet_util.h
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/contrib/gnunet.root ${PREFIX}/etc/gnunet.conf-dist
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/contrib/gnunet.user ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/net-p2p/gnunet/files/patch-src_applications_afs_module_Makefile.in b/net-p2p/gnunet/files/patch-src_applications_afs_module_Makefile.in
new file mode 100644
index 000000000000..a8aa2b712cc5
--- /dev/null
+++ b/net-p2p/gnunet/files/patch-src_applications_afs_module_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/applications/afs/module/Makefile.in.orig Fri Oct 1 01:42:15 2004
++++ src/applications/afs/module/Makefile.in Fri Oct 1 01:44:57 2004
+@@ -713,7 +713,7 @@
+ $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+- $(AM_LDFLAGS) $(LDFLAGS) -o $@
++ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
+ CFLAGS = @CFLAGS@
+ DIST_SOURCES = $(libgnunetafs_database_bdb_la_SOURCES) \
+ $(libgnunetafs_database_directory_la_SOURCES) \
diff --git a/net-p2p/gnunet/files/patch-src_applications_afs_tools_Makefile.in b/net-p2p/gnunet/files/patch-src_applications_afs_tools_Makefile.in
new file mode 100644
index 000000000000..dbe532414a7c
--- /dev/null
+++ b/net-p2p/gnunet/files/patch-src_applications_afs_tools_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/applications/afs/tools/Makefile.in.orig Fri Oct 1 01:56:26 2004
++++ src/applications/afs/tools/Makefile.in Fri Oct 1 01:57:39 2004
+@@ -241,7 +241,7 @@
+ $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+- $(AM_LDFLAGS) $(LDFLAGS) -o $@
++ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
+ CFLAGS = @CFLAGS@
+ DIST_SOURCES = $(gnunet_delete_SOURCES) $(gnunet_directory_SOURCES) \
+ $(gnunet_download_SOURCES) $(gnunet_insert_SOURCES) \
diff --git a/net-p2p/gnunet/files/patch-src_applications_chat_Makefile.in b/net-p2p/gnunet/files/patch-src_applications_chat_Makefile.in
new file mode 100644
index 000000000000..05696ef81ebd
--- /dev/null
+++ b/net-p2p/gnunet/files/patch-src_applications_chat_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/applications/chat/Makefile.in.orig Sat Oct 2 17:15:45 2004
++++ src/applications/chat/Makefile.in Sat Oct 2 17:16:11 2004
+@@ -196,7 +196,7 @@
+ $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+- $(AM_LDFLAGS) $(LDFLAGS) -o $@
++ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
+ CFLAGS = @CFLAGS@
+ DIST_SOURCES = $(libgnunetchat_protocol_la_SOURCES) \
+ $(gnunet_chat_SOURCES)
diff --git a/net-p2p/gnunet/files/patch-src_applications_dht_tools_Makefile.in b/net-p2p/gnunet/files/patch-src_applications_dht_tools_Makefile.in
new file mode 100644
index 000000000000..dbe020fc06c6
--- /dev/null
+++ b/net-p2p/gnunet/files/patch-src_applications_dht_tools_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/applications/dht/tools/Makefile.in.orig Sat Oct 2 17:57:30 2004
++++ src/applications/dht/tools/Makefile.in Sat Oct 2 17:57:54 2004
+@@ -210,7 +210,7 @@
+ $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+- $(AM_LDFLAGS) $(LDFLAGS) -o $@
++ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
+ CFLAGS = @CFLAGS@
+ DIST_SOURCES = $(libgnunetdht_api_la_SOURCES) $(gnunet_dht_join_SOURCES) \
+ $(gnunet_dht_query_SOURCES)
diff --git a/net-p2p/gnunet/files/patch-src_applications_stats_Makefile.in b/net-p2p/gnunet/files/patch-src_applications_stats_Makefile.in
new file mode 100644
index 000000000000..011dcc74e946
--- /dev/null
+++ b/net-p2p/gnunet/files/patch-src_applications_stats_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/applications/stats/Makefile.in.orig Sat Oct 2 17:02:35 2004
++++ src/applications/stats/Makefile.in Sat Oct 2 17:03:46 2004
+@@ -171,7 +171,7 @@
+ $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+- $(AM_LDFLAGS) $(LDFLAGS) -o $@
++ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
+ CFLAGS = @CFLAGS@
+ DIST_SOURCES = $(gnunet_stats_SOURCES)
+ DIST_COMMON = Makefile.am Makefile.in
diff --git a/net-p2p/gnunet/files/patch-src_applications_tbench_Makefile.in b/net-p2p/gnunet/files/patch-src_applications_tbench_Makefile.in
new file mode 100644
index 000000000000..fe90a3e1c509
--- /dev/null
+++ b/net-p2p/gnunet/files/patch-src_applications_tbench_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/applications/tbench/Makefile.in.orig Sat Oct 2 17:25:58 2004
++++ src/applications/tbench/Makefile.in Sat Oct 2 17:26:29 2004
+@@ -197,7 +197,7 @@
+ $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+- $(AM_LDFLAGS) $(LDFLAGS) -o $@
++ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
+ CFLAGS = @CFLAGS@
+ DIST_SOURCES = $(libgnunettbench_protocol_la_SOURCES) \
+ $(gnunet_tbench_SOURCES)
diff --git a/net-p2p/gnunet/files/patch-src_applications_testbed_Makefile.in b/net-p2p/gnunet/files/patch-src_applications_testbed_Makefile.in
new file mode 100644
index 000000000000..6987d7a50f18
--- /dev/null
+++ b/net-p2p/gnunet/files/patch-src_applications_testbed_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/applications/testbed/Makefile.in.orig Sat Oct 2 17:35:28 2004
++++ src/applications/testbed/Makefile.in Sat Oct 2 17:35:49 2004
+@@ -212,7 +212,7 @@
+ $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+- $(AM_LDFLAGS) $(LDFLAGS) -o $@
++ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
+ CFLAGS = @CFLAGS@
+ DIST_SOURCES = $(libgnunettestbed_protocol_la_SOURCES) \
+ $(gnunet_testbed_SOURCES)
diff --git a/net-p2p/gnunet/files/patch-src_applications_tracekit_Makefile.in b/net-p2p/gnunet/files/patch-src_applications_tracekit_Makefile.in
new file mode 100644
index 000000000000..19b24e7a177c
--- /dev/null
+++ b/net-p2p/gnunet/files/patch-src_applications_tracekit_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/applications/tracekit/Makefile.in.orig Sat Oct 2 17:46:14 2004
++++ src/applications/tracekit/Makefile.in Sat Oct 2 17:46:50 2004
+@@ -197,7 +197,7 @@
+ $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+- $(AM_LDFLAGS) $(LDFLAGS) -o $@
++ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
+ CFLAGS = @CFLAGS@
+ DIST_SOURCES = $(libgnunettracekit_protocol_la_SOURCES) \
+ $(gnunet_tracekit_SOURCES)
diff --git a/net-p2p/gnunet/files/patch-src_conf_Makefile.in b/net-p2p/gnunet/files/patch-src_conf_Makefile.in
new file mode 100644
index 000000000000..52a4e64b1ae8
--- /dev/null
+++ b/net-p2p/gnunet/files/patch-src_conf_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/conf/Makefile.in.orig Fri Oct 1 01:13:52 2004
++++ src/conf/Makefile.in Fri Oct 1 01:18:56 2004
+@@ -184,7 +184,7 @@
+
+
+ gnunet_setup_LDFLAGS = \
+- $(curses_lib)
++ $(curses_lib) $(LTLIBINTL)
+
+
+ gnunet_setup_LDADD = \
diff --git a/net-p2p/gnunet/files/patch-src_include_gnunet__util.h b/net-p2p/gnunet/files/patch-src_include_gnunet__util.h
new file mode 100644
index 000000000000..114bfecf7e0a
--- /dev/null
+++ b/net-p2p/gnunet/files/patch-src_include_gnunet__util.h
@@ -0,0 +1,34 @@
+
+$FreeBSD$
+
+--- src/include/gnunet_util.h.orig Tue Aug 24 17:58:14 2004
++++ src/include/gnunet_util.h Sat Oct 2 23:25:56 2004
+@@ -628,7 +628,7 @@
+ * Default names of the configuration files.
+ */
+ #define DEFAULT_CLIENT_CONFIG_FILE "~/.gnunet/gnunet.conf"
+-#define DEFAULT_DAEMON_CONFIG_FILE "/etc/gnunet.conf"
++#define DEFAULT_DAEMON_CONFIG_FILE "%%PREFIX%%/etc/gnunet.conf"
+
+ /* *******************API *********************** */
+
+@@ -1027,8 +1027,8 @@
+ * @param ip the IP to check (in network byte order)
+ * @return NO if the IP is not in the list, YES if it it is
+ */
+-int checkIP6Listed(const CIDR6Network * list,
+- const IP6addr * ip);
++int checkIP6Listed(CIDR6Network * list,
++ IP6addr * ip);
+
+ /**
+ * Parse a network specification. The argument specifies
+@@ -1041,7 +1041,7 @@
+ * @param routeList a string specifying the forbidden networks
+ * @return the converted list, NULL if the synatx is flawed
+ */
+-CIDR6Network * parseRoutes6(const char * routeList);
++CIDR6Network * parseRoutes6(char * routeList);
+
+
+
diff --git a/net-p2p/gnunet/files/patch-src_server_Makefile.in b/net-p2p/gnunet/files/patch-src_server_Makefile.in
new file mode 100644
index 000000000000..e323d1093104
--- /dev/null
+++ b/net-p2p/gnunet/files/patch-src_server_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/server/Makefile.in.orig Sat Oct 2 22:42:44 2004
++++ src/server/Makefile.in Sat Oct 2 22:43:53 2004
+@@ -265,7 +265,7 @@
+ $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+- $(AM_LDFLAGS) $(LDFLAGS) -o $@
++ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
+ CFLAGS = @CFLAGS@
+ DIST_SOURCES = $(gnunet_peer_info_SOURCES) \
+ $(gnunet_transport_check_SOURCES) $(gnunet_update_SOURCES) \
diff --git a/net-p2p/gnunet/files/patch-src_transports_udp6.c b/net-p2p/gnunet/files/patch-src_transports_udp6.c
new file mode 100644
index 000000000000..880a836c35ea
--- /dev/null
+++ b/net-p2p/gnunet/files/patch-src_transports_udp6.c
@@ -0,0 +1,21 @@
+
+$FreeBSD$
+
+--- src/transports/udp6.c.orig Fri Oct 1 01:38:25 2004
++++ src/transports/udp6.c Fri Oct 1 01:39:15 2004
+@@ -275,6 +275,7 @@
+ #endif
+ /* quick test of the packet, if failed, repeat! */
+ if (size != ntohs(udp6m.size)) {
++ char * tmp = MALLOC(INET6_ADDRSTRLEN);
+ LOG(LOG_WARNING,
+ _("Packed received from %s:%d (UDP6) failed format check."),
+ inet_ntop(AF_INET6,
+@@ -282,6 +283,7 @@
+ tmp,
+ INET6_ADDRSTRLEN),
+ ntohs(incoming.sin6_port));
++ FREE(tmp);
+ goto RETRY;
+ }
+ GNUNET_ASSERT(sizeof(struct in6_addr) == sizeof(IP6addr));
diff --git a/net-p2p/gnunet/pkg-plist b/net-p2p/gnunet/pkg-plist
index bfcc6a03b809..b4d0154c1b74 100644
--- a/net-p2p/gnunet/pkg-plist
+++ b/net-p2p/gnunet/pkg-plist
@@ -19,6 +19,7 @@ bin/gnunet-tracekit
bin/gnunet-transport-check
bin/gnunet-update
bin/gnunetd
+etc/gnunet.conf-dist
include/gnunet_afs_esed2.h
include/gnunet_core.h
include/gnunet_dht.h
@@ -65,3 +66,7 @@ share/locale/de/LC_MESSAGES/GNUnet.mo
%%WITH_IPV6%%lib/libgnunettransport_tcp6.so
%%WITH_IPV6%%lib/libgnunettransport_udp6.so
@dirrm share/GNUnet
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/gnunet.user
+%%PORTDOCS%%@dirrm %%DOCSDIR%%