aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-12-26 10:48:12 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-12-26 10:48:12 +0000
commit693fac0b2ceb521c8fdf2677c7ecdbf20aa72ff6 (patch)
treed96a4c37c105086265d7e30044a4d4b72147cf57 /net-p2p
parentf2f38e6e7cb7eb01439fdd0ecd16759410420dd3 (diff)
downloadports-693fac0b2ceb521c8fdf2677c7ecdbf20aa72ff6.tar.gz
ports-693fac0b2ceb521c8fdf2677c7ecdbf20aa72ff6.zip
o Add dependency on dns/py-dnspython which enable a notification
when there is a newer version of BitTorrent available o Style fix: Remove a extraneous trailing space in Makefile o Change default from disabled to enabled for BitTorrent option --enable_bad_libc_workaround: 'enable workaround for a bug in BSD libc that makes file reads very slow.' This has been verified to be true; the behavior, not the reason o Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=125211
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/py-bittorrent-devel/Makefile5
-rw-r--r--net-p2p/py-bittorrent-devel/files/patch-BitTorrent::defaultargs.py11
2 files changed, 15 insertions, 1 deletions
diff --git a/net-p2p/py-bittorrent-devel/Makefile b/net-p2p/py-bittorrent-devel/Makefile
index 8c8466cdabe3..8b3a40481538 100644
--- a/net-p2p/py-bittorrent-devel/Makefile
+++ b/net-p2p/py-bittorrent-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= BitTorrent
PORTVERSION= 3.9.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES?= net python
MASTER_SITES= http://www.bittorrent.com/
@@ -19,6 +20,8 @@ PKGNAMESUFFIX?= -devel
MAINTAINER= lioux@FreeBSD.org
COMMENT?= A peer-to-peer tool for distributing files written in Python
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dns/__init__.py:${PORTSDIR}/dns/py-dnspython
+
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_REINPLACE= yes
@@ -58,7 +61,7 @@ post-patch:
-e 's|/usr/bin/env python|${LOCALBASE}/bin/python|'
post-install:
-.ifndef(NOPORTDOCS)
+.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
diff --git a/net-p2p/py-bittorrent-devel/files/patch-BitTorrent::defaultargs.py b/net-p2p/py-bittorrent-devel/files/patch-BitTorrent::defaultargs.py
new file mode 100644
index 000000000000..d0fa6f8e8052
--- /dev/null
+++ b/net-p2p/py-bittorrent-devel/files/patch-BitTorrent::defaultargs.py
@@ -0,0 +1,11 @@
+--- BitTorrent/defaultargs.py.orig Sun Dec 26 08:41:09 2004
++++ BitTorrent/defaultargs.py Sun Dec 26 08:41:16 2004
+@@ -83,7 +83,7 @@
+ 'if nonzero, set the TOS option for peer connections to this value'),
+ ('filesystem_encoding', '',
+ "character encoding used on the local filesystem. If left empty, autodetected. Autodetection doesn't work under python versions older than 2.3"),
+- ('enable_bad_libc_workaround', 0,
++ ('enable_bad_libc_workaround', 1,
+ 'enable workaround for a bug in BSD libc that makes file reads very slow.'),
+ ]
+