aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2009-10-29 13:30:35 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2009-10-29 13:30:35 +0000
commite4d9946f25871b33c0e946236a7aa2cfbf2d5007 (patch)
tree0e5c8538147fe41ccc2ec82d729a39d62e788781 /net-p2p
parent80d89d86ca40a4fcf08ff7950de5c468d46351df (diff)
downloadports-e4d9946f25871b33c0e946236a7aa2cfbf2d5007.tar.gz
ports-e4d9946f25871b33c0e946236a7aa2cfbf2d5007.zip
Add a patch to fix crash when total number of connections exceeds 1024.
Submitted by: Andrew Stadtler, Paul Belanger Obtained from: http://libtorrent.rakshasa.no/ticket/1581
Notes
Notes: svn path=/head/; revision=243466
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent-devel/Makefile2
-rw-r--r--net-p2p/libtorrent-devel/files/patch-src_torrent_poll__kqueue.cc9
2 files changed, 10 insertions, 1 deletions
diff --git a/net-p2p/libtorrent-devel/Makefile b/net-p2p/libtorrent-devel/Makefile
index c6fd4deadffd..ad69976c66d3 100644
--- a/net-p2p/libtorrent-devel/Makefile
+++ b/net-p2p/libtorrent-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libtorrent-devel
PORTVERSION= 0.12.5
-PORTREVISION= 0
+PORTREVISION= 1
DISTNAME= ${PORTNAME:S/-devel//}-${PORTVERSION}
MAINTAINER= flz@FreeBSD.org
diff --git a/net-p2p/libtorrent-devel/files/patch-src_torrent_poll__kqueue.cc b/net-p2p/libtorrent-devel/files/patch-src_torrent_poll__kqueue.cc
index e1de953422ff..d0d718b680c4 100644
--- a/net-p2p/libtorrent-devel/files/patch-src_torrent_poll__kqueue.cc
+++ b/net-p2p/libtorrent-devel/files/patch-src_torrent_poll__kqueue.cc
@@ -9,3 +9,12 @@
#endif
namespace torrent {
+@@ -113,7 +113,7 @@
+ if (fd == -1)
+ return NULL;
+
+- return new PollKQueue(fd, 1024, maxOpenSockets);
++ return new PollKQueue(fd, 16384, maxOpenSockets);
+ }
+
+ PollKQueue::PollKQueue(int fd, int maxEvents, int maxOpenSockets) :