aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2010-11-17 12:44:25 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2010-11-17 12:44:25 +0000
commit727deaa1c8b372a6c724e087d2dcd1aa9ba647b6 (patch)
tree23ce35d0e9c6fced171c0347403dd5b2dd316ba4 /net-p2p
parente2ab383ecb50d5143490e85e1789377d38cd51c6 (diff)
downloadports-727deaa1c8b372a6c724e087d2dcd1aa9ba647b6.tar.gz
ports-727deaa1c8b372a6c724e087d2dcd1aa9ba647b6.zip
A fast and lightweight QT4 BitTorrent client, loosely based on the GTK+ client.
This is the only Transmission client that can act as its own self-contained session (as the GTK+ and Mac clients do), and can also connect to a remote session (as the web client and transmission-remote terminal client do). Transmission has been built from the ground up to be a lightweight, yet powerful BitTorrent client. Its simple, intuitive interface is designed to integrate tightly with whatever computing environment you choose to use. Transmission strikes a balance between providing useful functionality without feature bloat. Furthermore, it is free for anyone to use or modify. WWW: http://www.transmissionbt.com/
Notes
Notes: svn path=/head/; revision=264691
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/transmission-qt4/Makefile59
-rw-r--r--net-p2p/transmission-qt4/pkg-descr13
-rw-r--r--net-p2p/transmission-qt4/pkg-plist12
4 files changed, 85 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index 04544488dee0..72e1d2ce5412 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -123,6 +123,7 @@
SUBDIR += transmission-cli
SUBDIR += transmission-daemon
SUBDIR += transmission-gtk2
+ SUBDIR += transmission-qt4
SUBDIR += transmisson-remote-gui
SUBDIR += tribler
SUBDIR += tvrss
diff --git a/net-p2p/transmission-qt4/Makefile b/net-p2p/transmission-qt4/Makefile
new file mode 100644
index 000000000000..e93f09419b8f
--- /dev/null
+++ b/net-p2p/transmission-qt4/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: transmission-qt4
+# Date created: 23 October 2010
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -qt4
+
+MAINTAINER= mezz@FreeBSD.org
+COMMENT= A fast and lightweight QT4 BitTorrent client
+
+LIB_DEPENDS= ${GEN_LIB_DEPENDS}
+RUN_DEPENDS= ${GEN_RUN_DEPENDS}
+
+DESCR= ${.CURDIR}/pkg-descr
+MASTERDIR= ${.CURDIR}/../transmission-cli
+PLIST= ${.CURDIR}/pkg-plist
+SLAVEPORT= qt4
+
+USE_QT_VER= 4
+QT_NONSTANDARD= yes
+QT_COMPONENTS= gui dbus network
+USE_GNOME= desktopfileutils
+
+EXTRA_CONF_ARGS=--disable-cli \
+ --disable-daemon \
+ --disable-gtk \
+ --disable-libnotify \
+ --disable-mac \
+ --disable-nls
+
+MAN1= transmission-qt.1
+
+post-patch: general-patch
+ @${REINPLACE_CMD} -e 's|/share/man|/man|g ; /PKGCONFIG/s| openssl||g' \
+ ${WRKSRC}/qt/qtr.pro
+
+post-build:
+ @(cd ${WRKSRC}/qt ; ${QMAKE} ${QMAKEFLAGS} qtr.pro ; gmake)
+
+do-install:
+ @(cd ${WRKSRC}/qt ; ${SETENV} INSTALL_ROOT=${PREFIX} ${MAKE} install)
+
+post-install: general-install
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/qt/README.txt ${DOCSDIR}/README-qt4
+.endif
+ @${MKDIR} ${PREFIX}/share/applications
+ @${INSTALL_DATA} ${WRKSRC}/qt/transmission-qt.desktop \
+ ${PREFIX}/share/applications/
+ @${MKDIR} ${PREFIX}/share/pixmaps
+ @${INSTALL_DATA} ${WRKSRC}/qt/icons/transmission.png \
+ ${PREFIX}/share/pixmaps/transmission-qt.png
+ @-update-desktop-database
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net-p2p/transmission-qt4/pkg-descr b/net-p2p/transmission-qt4/pkg-descr
new file mode 100644
index 000000000000..1e252e2875e1
--- /dev/null
+++ b/net-p2p/transmission-qt4/pkg-descr
@@ -0,0 +1,13 @@
+A fast and lightweight QT4 BitTorrent client, loosely based on the GTK+ client.
+
+This is the only Transmission client that can act as its own self-contained
+session (as the GTK+ and Mac clients do), and can also connect to a remote
+session (as the web client and transmission-remote terminal client do).
+
+Transmission has been built from the ground up to be a lightweight, yet
+powerful BitTorrent client. Its simple, intuitive interface is designed
+to integrate tightly with whatever computing environment you choose to
+use. Transmission strikes a balance between providing useful functionality
+without feature bloat. Furthermore, it is free for anyone to use or modify.
+
+WWW: http://www.transmissionbt.com/
diff --git a/net-p2p/transmission-qt4/pkg-plist b/net-p2p/transmission-qt4/pkg-plist
new file mode 100644
index 000000000000..11f5b41a91a1
--- /dev/null
+++ b/net-p2p/transmission-qt4/pkg-plist
@@ -0,0 +1,12 @@
+bin/transmission-qt
+share/applications/transmission-qt.desktop
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README-qt4
+share/pixmaps/transmission-qt.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/applications
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true