aboutsummaryrefslogtreecommitdiff
path: root/net/3proxy
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-07-30 07:36:28 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-07-30 07:36:28 +0000
commit32c57f94b6988ce83484d659acc1aa01b5040f56 (patch)
tree37917eab1592a5068cc1509635e595e6d7b45360 /net/3proxy
parentc90209e91a23d20b71a882911ff7415afb9457b5 (diff)
downloadports-32c57f94b6988ce83484d659acc1aa01b5040f56.tar.gz
ports-32c57f94b6988ce83484d659acc1aa01b5040f56.zip
New port: net/3proxy
3[APA3A] tiny proxy 3Proxy (pronounce it as "Zaraza tiny proxy") is really tiny cross-platform (Win32&Unix) proxy servers set. It includes HTTP proxy with HTTPS and FTP support, SOCKSv4/SOCKSv4.5/SOCKSv5 proxy, POP3 proxy, TCP and UDP portmappers. You can use every proxy as a standalone program (socks, proxy, tcppm, udppm, pop3p) or use combined program (3proxy). PR: 54968 Submitted by: Timofey Chernousov <tim@gwd.nnn.tstu.ru> Approved by: fjoe (mentor) (implicit)
Notes
Notes: svn path=/head/; revision=85898
Diffstat (limited to 'net/3proxy')
-rw-r--r--net/3proxy/Makefile44
-rw-r--r--net/3proxy/distinfo1
-rw-r--r--net/3proxy/files/3proxy.sh17
-rw-r--r--net/3proxy/files/patch-aa17
-rw-r--r--net/3proxy/files/patch-ab26
-rw-r--r--net/3proxy/pkg-descr23
-rw-r--r--net/3proxy/pkg-plist14
7 files changed, 142 insertions, 0 deletions
diff --git a/net/3proxy/Makefile b/net/3proxy/Makefile
new file mode 100644
index 000000000000..98512e6832af
--- /dev/null
+++ b/net/3proxy/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: 3proxy
+# Date created: 2003 July 25
+# Whom: tim@relay.nnn.tstu.ru
+#
+# $FreeBSD$
+#
+
+PORTNAME= 3proxy
+PORTVERSION= 0.4b
+CATEGORIES= net
+MASTER_SITES= http://www.security.nnov.ru/soft/3proxy/${PORTVERSION}/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= tim@relay.nnn.tstu.ru
+COMMENT= Proxy servers set (support HTTP(S), FTP, SOCKS, POP3, TCP & UDP)
+
+NO_WRKSUBDIR= yes
+MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
+
+pre-build:
+ if [ ! -f ${WRKSRC}/Makefile ]; then \
+ ${CP} ${WRKSRC}/Makefile.unix ${WRKSRC}/Makefile; \
+ fi
+
+do-install:
+.for i in 3proxy dighosts mycrypt pop3p proxy socks tcppm udppm
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/bin/
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/3proxy.cfg.sample ${PREFIX}/etc
+ ${SED} -e "s|%%PREFIX%%|${PREFIX}|g" ${FILESDIR}/3proxy.sh \
+ > ${WRKSRC}/3proxy.sh
+ ${INSTALL_SCRIPT} ${WRKSRC}/3proxy.sh ${PREFIX}/etc/rc.d/
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in License Readme Release.notes
+ ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/3proxy/distinfo b/net/3proxy/distinfo
new file mode 100644
index 000000000000..ea2a396094c4
--- /dev/null
+++ b/net/3proxy/distinfo
@@ -0,0 +1 @@
+MD5 (3proxy.tgz) = ccb25a2aee41b913ac591240a406dd14
diff --git a/net/3proxy/files/3proxy.sh b/net/3proxy/files/3proxy.sh
new file mode 100644
index 000000000000..decae6e80a07
--- /dev/null
+++ b/net/3proxy/files/3proxy.sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+case "$1" in
+'start')
+ %%PREFIX%%/bin/3proxy %%PREFIX%%/etc/3proxy.cfg & echo -n " 3proxy"
+ ;;
+
+'stop')
+ /usr/bin/killall 3proxy
+ ;;
+
+*)
+ echo "Usage: ${0} { start | stop }"
+ exit 1
+ ;;
+esac
+exit 0
diff --git a/net/3proxy/files/patch-aa b/net/3proxy/files/patch-aa
new file mode 100644
index 000000000000..b7a4dfef7362
--- /dev/null
+++ b/net/3proxy/files/patch-aa
@@ -0,0 +1,17 @@
+--- Makefile.unix.orig Mon Jul 28 13:06:40 2003
++++ Makefile.unix Mon Jul 28 13:24:40 2003
+@@ -3,11 +3,11 @@
+ # 3 proxy Makefile for GCC/Unix/Linux/Cygwin
+ #
+
+-CC = gcc
+-CFLAGS = -Wall -O2 -s -c -pthread -DNOODBC
++CC ?= gcc
++CFLAGS += -Wall -O2 -s -c ${PTHREAD_CFLAGS} -DNOODBC
+ COUT = -o
+ LN = gcc
+-LDFLAGS = -Wall -O2 -s -pthread
++LDFLAGS += -Wall -O2 -s ${PTHREAD_LIBS}
+ LIBS =
+ LNOUT = -o
+ EXESUFFICS =
diff --git a/net/3proxy/files/patch-ab b/net/3proxy/files/patch-ab
new file mode 100644
index 000000000000..e26f0f5af28c
--- /dev/null
+++ b/net/3proxy/files/patch-ab
@@ -0,0 +1,26 @@
+--- 3proxy.cfg.sample.orig Mon Jul 28 14:50:42 2003
++++ 3proxy.cfg.sample Mon Jul 28 14:51:55 2003
+@@ -332,12 +332,12 @@
+ # this example shows you how to include passwd file. For included files
+ # <CR> and <LF> are treated as field separators.
+
+-service
++#service
+ # service is required under NT if you want 3proxy to start as service
+
+
+ #log /usr/local/etc/3proxy/logs/3proxy.log D
+-log c:\3proxy\logs\3proxy.log D
++log /var/log/3proxy.log D
+ # log allows to specify log file location and rotation, D means logfile
+ # is created daily
+
+@@ -421,7 +421,7 @@
+ # like multimedia streams or online games.
+
+ auth strong
+-fflush
++flush
+ allow 3APA3A,test
+ socks
+ # for socks we will use password authentication and different access control -
diff --git a/net/3proxy/pkg-descr b/net/3proxy/pkg-descr
new file mode 100644
index 000000000000..8d8666e4e8e7
--- /dev/null
+++ b/net/3proxy/pkg-descr
@@ -0,0 +1,23 @@
+3[APA3A] tiny proxy 3Proxy (pronounce it as "Zaraza tiny proxy") is really
+tiny cross-platform (Win32&Unix) proxy servers set. It includes HTTP proxy
+with HTTPS and FTP support, SOCKSv4/SOCKSv4.5/SOCKSv5 proxy, POP3 proxy,
+TCP and UDP portmappers. You can use every proxy as a standalone program
+(socks, proxy, tcppm, udppm, pop3p) or use combined program (3proxy).
+Combined proxy additionally supports features like access control,
+bandwidth limiting, limiting daily/weekly/monthly traffic amount, proxy
+chaining, log rotation, sylog and ODBC logging, etc. It's created to be
+small, simple (I'd like to say secure - but it's just a beta) and yet
+functional. It may be compiled with Visual C or gcc. Native Win32 version
+included in archive and supports installation as NT/2K/XP service.
+Currently 3proxy is tested to work under Windows 98/NT/2000/2003/XP,
+FreeBSD/i386, Linux/i386, Linux/Alpha. See Release Notes and Changes for
+features list.
+3proxy is FreeWare. It can be used under terms of GNU/GPL or under it own
+license (please read License Agreement).
+
+For licensing or commercial support please e-mail to 3proxy@security.nnov.ru
+
+WWW: http://www.security.nnov.ru/soft/3proxy/
+
+-- Timofey
+tim@relay.nnn.tstu.ru
diff --git a/net/3proxy/pkg-plist b/net/3proxy/pkg-plist
new file mode 100644
index 000000000000..83838c855b6e
--- /dev/null
+++ b/net/3proxy/pkg-plist
@@ -0,0 +1,14 @@
+bin/3proxy
+bin/dighosts
+bin/mycrypt
+bin/pop3p
+bin/proxy
+bin/socks
+bin/tcppm
+bin/udppm
+etc/3proxy.cfg.sample
+etc/rc.d/3proxy.sh
+%%PORTDOCS%%%%DOCSDIR%%/License
+%%PORTDOCS%%%%DOCSDIR%%/Readme
+%%PORTDOCS%%%%DOCSDIR%%/Release.notes
+%%PORTDOCS%%@dirrm %%DOCSDIR%%