aboutsummaryrefslogtreecommitdiff
path: root/net/GeoIP/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-27 15:53:24 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-27 15:53:24 +0000
commit103461f308a5883cd425097e1d8ad36a5740e662 (patch)
treec8ca3994db53f4b69919f7696df6d70b9b43d479 /net/GeoIP/Makefile
parent2f8715d081acd906c5735e5be26eea1823b1dcbe (diff)
downloadports-103461f308a5883cd425097e1d8ad36a5740e662.tar.gz
ports-103461f308a5883cd425097e1d8ad36a5740e662.zip
- Update GeoIP to 1.6.2 and switch to its new github location.
- Add net/geoipupdate, the formal tool to fetch updates. It is for paid subscribers. People using the free version should continue using the geoipupdate.sh script in net/GeoIP. This program is used to fetch the GeoIP2 and GeoIP databases. It requires an active GeoIP subscription. Please see https://www.maxmind.com/en/geolocation_landing for details about obtaining a subscription. If you wish to install the free versions of the GeoIP databases, please use the geoipudate.sh script provided in net/GeoIP. WWW: https://github.com/maxmind/geoipupdate
Notes
Notes: svn path=/head/; revision=366333
Diffstat (limited to 'net/GeoIP/Makefile')
-rw-r--r--net/GeoIP/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/net/GeoIP/Makefile b/net/GeoIP/Makefile
index 9fdfe2e960c6..3fbfbf240d8a 100644
--- a/net/GeoIP/Makefile
+++ b/net/GeoIP/Makefile
@@ -2,14 +2,18 @@
# $FreeBSD$
PORTNAME= GeoIP
-PORTVERSION= 1.6.0
-PORTREVISION= 2
+PORTVERSION= 1.6.2
CATEGORIES= net geography
-MASTER_SITES= http://geolite.maxmind.com/download/geoip/api/c/
MAINTAINER= adamw@FreeBSD.org
COMMENT= Find the country that any IP address or hostname originates from
+USE_GITHUB= yes
+GH_ACCOUNT= maxmind
+GH_PROJECT= geoip-api-c
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 2e9100a
+
USES= libtool pathfix
USE_AUTOTOOLS= aclocal automake libtoolize autoconf
AUTOMAKE_ARGS= --add-missing
@@ -20,9 +24,15 @@ GNU_CONFIGURE= yes
SUB_FILES= geoipupdate.sh pkg-message
+OPTIONS_DEFINE= DOCS
+PORTDOCS= COPYING ChangeLog LICENSE README.md
+
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/geoipupdate.sh ${STAGEDIR}${PREFIX}/bin
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libGeoIP.so.*
@${MKDIR} ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:C|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>