aboutsummaryrefslogtreecommitdiff
path: root/net/GeoIP/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2002-08-15 13:34:10 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2002-08-15 13:34:10 +0000
commit521432de4f8a147ff5b3ca9e97d825607a42e314 (patch)
treebd37d9e5e19d4db5b517de17a5b007891454b24e /net/GeoIP/Makefile
parent47a4e24d512f397265e26b6f271ee1996380d8e9 (diff)
downloadports-521432de4f8a147ff5b3ca9e97d825607a42e314.tar.gz
ports-521432de4f8a147ff5b3ca9e97d825607a42e314.zip
new port: misc/GeoIP
GeoIP is a C library that enables the user to find the country that any IP address or hostname originates from. PR: ports/41536 Submitted by: Yen-Ming Lee <leeym@utopia.leeym.com>
Notes
Notes: svn path=/head/; revision=64539
Diffstat (limited to 'net/GeoIP/Makefile')
-rw-r--r--net/GeoIP/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/net/GeoIP/Makefile b/net/GeoIP/Makefile
new file mode 100644
index 000000000000..7529cfb370bb
--- /dev/null
+++ b/net/GeoIP/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: GeoIP
+# Date created: 10 August 2002
+# Whom: Yen-Ming Lee <leeym@leeym.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GeoIP
+PORTVERSION= 1.0.0
+CATEGORIES= misc
+MASTER_SITES= http://maxmind.com/download/geoip/api/c/
+
+MAINTAINER= leeym@leeym.com
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --with-gnu-ld=yes
+INSTALLS_SHLIB= yes
+
+MAN1= geoiplookup.1 geoipupdate.1
+
+.include <bsd.port.mk>