aboutsummaryrefslogtreecommitdiff
path: root/net/GeoIP
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2002-08-15 13:34:10 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2002-08-15 13:34:10 +0000
commit521432de4f8a147ff5b3ca9e97d825607a42e314 (patch)
treebd37d9e5e19d4db5b517de17a5b007891454b24e /net/GeoIP
parent47a4e24d512f397265e26b6f271ee1996380d8e9 (diff)
downloadports-521432de4f8a147ff5b3ca9e97d825607a42e314.tar.gz
ports-521432de4f8a147ff5b3ca9e97d825607a42e314.zip
new port: misc/GeoIP
GeoIP is a C library that enables the user to find the country that any IP address or hostname originates from. PR: ports/41536 Submitted by: Yen-Ming Lee <leeym@utopia.leeym.com>
Notes
Notes: svn path=/head/; revision=64539
Diffstat (limited to 'net/GeoIP')
-rw-r--r--net/GeoIP/Makefile23
-rw-r--r--net/GeoIP/distinfo1
-rw-r--r--net/GeoIP/pkg-comment1
-rw-r--r--net/GeoIP/pkg-descr11
-rw-r--r--net/GeoIP/pkg-plist9
5 files changed, 45 insertions, 0 deletions
diff --git a/net/GeoIP/Makefile b/net/GeoIP/Makefile
new file mode 100644
index 000000000000..7529cfb370bb
--- /dev/null
+++ b/net/GeoIP/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: GeoIP
+# Date created: 10 August 2002
+# Whom: Yen-Ming Lee <leeym@leeym.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GeoIP
+PORTVERSION= 1.0.0
+CATEGORIES= misc
+MASTER_SITES= http://maxmind.com/download/geoip/api/c/
+
+MAINTAINER= leeym@leeym.com
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --with-gnu-ld=yes
+INSTALLS_SHLIB= yes
+
+MAN1= geoiplookup.1 geoipupdate.1
+
+.include <bsd.port.mk>
diff --git a/net/GeoIP/distinfo b/net/GeoIP/distinfo
new file mode 100644
index 000000000000..8ae3a7b53e97
--- /dev/null
+++ b/net/GeoIP/distinfo
@@ -0,0 +1 @@
+MD5 (GeoIP-1.0.0.tar.gz) = 49a31eb7a0ebe07fe4013a93d0c0177a
diff --git a/net/GeoIP/pkg-comment b/net/GeoIP/pkg-comment
new file mode 100644
index 000000000000..15f274e738a3
--- /dev/null
+++ b/net/GeoIP/pkg-comment
@@ -0,0 +1 @@
+Find the country that any IP address or hostname originates from
diff --git a/net/GeoIP/pkg-descr b/net/GeoIP/pkg-descr
new file mode 100644
index 000000000000..9dcae6ca2c7c
--- /dev/null
+++ b/net/GeoIP/pkg-descr
@@ -0,0 +1,11 @@
+GeoIP is a C library that enables the user to find the country that any
+IP address or hostname originates from. It uses a file based database
+that is accurate as of March 2002. This database simply contains IP blocks
+as keys, and countries as values. This database should be more complete and
+accurate than using reverse DNS lookups.
+
+This module can be used to automatically select the geographically closest
+mirror, to analyze your web server logs to determine the countries of your
+visitors, for credit card fraud detection, and for software export controls.
+
+WWW: http://maxmind.com/geoip/
diff --git a/net/GeoIP/pkg-plist b/net/GeoIP/pkg-plist
new file mode 100644
index 000000000000..88690d0a41f2
--- /dev/null
+++ b/net/GeoIP/pkg-plist
@@ -0,0 +1,9 @@
+bin/geoiplookup
+bin/geoipupdate
+etc/GeoIP.conf.default
+include/GeoIP.h
+lib/libGeoIP.a
+lib/libGeoIP.so
+lib/libGeoIP.so.1
+share/GeoIP/GeoIP.dat
+@dirrm share/GeoIP