aboutsummaryrefslogtreecommitdiff
path: root/net/Makefile
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>2001-03-13 21:12:21 +0000
committerAndreas Klemm <andreas@FreeBSD.org>2001-03-13 21:12:21 +0000
commit285996cdec4e777695f67857f0f77879b0614258 (patch)
tree21f57361d4f5047a701a148cd983f1f4ae682451 /net/Makefile
parentd8406966d6bacb3659d136807edaa0e2ee8bfa6c (diff)
downloadports-285996cdec4e777695f67857f0f77879b0614258.tar.gz
ports-285996cdec4e777695f67857f0f77879b0614258.zip
new port p5-Net-Patricia
This module uses a Patricia Trie data structure to quickly perform IP address prefix matching for applications such as IP subnet, network or routing table lookups. The data structure is based on a radix tree using a radix of two, so sometimes you see patricia implementations called "radix" as well. The term "Trie" is derived from the word "retrieval" but is pronounced like "try". Patricia stands for "Practical Algorithm to Retrieve Information Coded as Alphanumeric", and was first suggested for routing table lookups by Van Jacobsen. Patricia Trie performance characteristics are well-known as it has been employed for routing table lookups within the BSD kernel since the 4.3 Reno release. The BSD radix code is thoroughly described in "TCP/IP Illustrated, Volume 2" by Wright and Stevens and in the paper ``A Tree-Based Packet Routing Table for Berkeley Unix'' by Keith Sklower. WWW: http://net.doit.wisc.edu/~plonka/Net-Patricia/
Notes
Notes: svn path=/head/; revision=39790
Diffstat (limited to 'net/Makefile')
-rw-r--r--net/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index fceb1238ce76..a24348495970 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -206,6 +206,7 @@
SUBDIR += p5-Net-IPv4Addr
SUBDIR += p5-Net-Jabber
SUBDIR += p5-Net-Netmask
+ SUBDIR += p5-Net-Patricia
SUBDIR += p5-Net-RawIP
SUBDIR += p5-Net-SNMP
SUBDIR += p5-Net-Telnet