aboutsummaryrefslogtreecommitdiff
path: root/net/amcl
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-04-16 04:16:49 +0000
committerWill Andrews <will@FreeBSD.org>2000-04-16 04:16:49 +0000
commitf594e54bbe8e9022679e3d90c74e0fcd75703ba6 (patch)
treef285ac9e46974394eae43ecc414fefcf6bcf770c /net/amcl
parentad4d1e476c1813a5ee9d7101a3fc07d45caa9f89 (diff)
downloadports-f594e54bbe8e9022679e3d90c74e0fcd75703ba6.tar.gz
ports-f594e54bbe8e9022679e3d90c74e0fcd75703ba6.zip
Add AMCL, which is a GTK-based MUD client.
Notes
Notes: svn path=/head/; revision=27634
Diffstat (limited to 'net/amcl')
-rw-r--r--net/amcl/Makefile28
-rw-r--r--net/amcl/distinfo1
-rw-r--r--net/amcl/pkg-comment1
-rw-r--r--net/amcl/pkg-descr9
-rw-r--r--net/amcl/pkg-plist1
5 files changed, 40 insertions, 0 deletions
diff --git a/net/amcl/Makefile b/net/amcl/Makefile
new file mode 100644
index 000000000000..fcabb71289d0
--- /dev/null
+++ b/net/amcl/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: amcl
+# Date created: 15 Apr 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= amcl
+PORTVERSION= 0.7.0
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.sourceforge.net/pub/sourceforge/amcl/ \
+ http://www.localhost.nu/apps/amcl/tars/ \
+ http://amcl.alliances.org/tars/ \
+ ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= games/muds
+DISTNAME= ${PORTNAME}-${PORTVERSION}pl1
+
+MAINTAINER= will@FreeBSD.org
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= GTK_CONFIG="${GTK_CONFIG}"
+
+.include <bsd.port.mk>
diff --git a/net/amcl/distinfo b/net/amcl/distinfo
new file mode 100644
index 000000000000..0bd27be3f46d
--- /dev/null
+++ b/net/amcl/distinfo
@@ -0,0 +1 @@
+MD5 (amcl-0.7.0pl1.tar.gz) = 6e88daf39a3d2fbe4fa61f375df51031
diff --git a/net/amcl/pkg-comment b/net/amcl/pkg-comment
new file mode 100644
index 000000000000..81f8a2589abb
--- /dev/null
+++ b/net/amcl/pkg-comment
@@ -0,0 +1 @@
+GTK-based MUD client with triggers, aliases, colors, etc.
diff --git a/net/amcl/pkg-descr b/net/amcl/pkg-descr
new file mode 100644
index 000000000000..6852b4dc4b26
--- /dev/null
+++ b/net/amcl/pkg-descr
@@ -0,0 +1,9 @@
+AMCL is short for Another MUD CLient. It is based
+on GTK, and offers many features, such as full support
+for ANSI colors, aliases, command history, triggers,
+automapping, multiple connections, and so forth.
+
+WWW: http://www.localhost.nu/apps/amcl/
+Author: Robin Ericsson <lobbin@localhost.nu>
+
+- Will <andrews@technologist.com>
diff --git a/net/amcl/pkg-plist b/net/amcl/pkg-plist
new file mode 100644
index 000000000000..ccbc437e24d8
--- /dev/null
+++ b/net/amcl/pkg-plist
@@ -0,0 +1 @@
+bin/amcl