aboutsummaryrefslogtreecommitdiff
path: root/net/amule1/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-25 20:31:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-25 20:31:18 +0000
commit35d437f6fc17bd1a1109b6cb356d3e759d67c277 (patch)
tree37b6577f5100f11e6a8e49775db71188e926b9da /net/amule1/Makefile
parentcb62a41a1e4ef32be48e451acb8d5d0e373e0c2b (diff)
downloadports-35d437f6fc17bd1a1109b6cb356d3e759d67c277.tar.gz
ports-35d437f6fc17bd1a1109b6cb356d3e759d67c277.zip
Add aMule, yet another eDonkey peer2peer network client.
WWW: http://sourceforge.net/projects/amule/ PR: ports/62969 Submitted by: Ganael LAPLANCHE <ganael.laplanche@martymac.com>
Notes
Notes: svn path=/head/; revision=102127
Diffstat (limited to 'net/amule1/Makefile')
-rw-r--r--net/amule1/Makefile64
1 files changed, 64 insertions, 0 deletions
diff --git a/net/amule1/Makefile b/net/amule1/Makefile
new file mode 100644
index 000000000000..0f2af98f39e7
--- /dev/null
+++ b/net/amule1/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: amule
+# Date created: Wed Nov 05 09:30:00 UTC 2003
+# Whom: Ganael LAPLANCHE <ganael.laplanche@martymac.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aMule
+PORTVERSION= 1.2.6
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= amule
+
+MAINTAINER= ganael.laplanche@martymac.com
+COMMENT= Just another eMule P2P Client
+
+LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk \
+ curl.2:${PORTSDIR}/ftp/curl
+
+USE_X_PREFIX= yes
+USE_GNOME= gnomehier gnomehack gnomeprefix
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-included-gettext \
+ --with-libintl-prefix=${LOCALBASE} \
+ --with-libiconv-prefix=${LOCALBASE} \
+ --with-wx-config=${WX_CONFIG} \
+ --with-wxbase-config=${WX_CONFIG}
+
+OPTIONS= OPTIMIZE "Build with optimization" off \
+ STATIC "Enable static linking" off \
+ RELGRP "Use release group code" off
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+WX_CONFIG?= ${X11BASE}/bin/wxgtk2-2.4-config
+
+# Configure options
+.if defined(WITH_OPTIMIZE)
+CONFIGURE_ARGS+= --enable-optimise
+.endif
+
+.if defined(WITH_STATIC)
+CONFIGURE_ARGS+= --enable-static
+.endif
+
+.if defined(WITH_RELGRP)
+CONFIGURE_ARGS+= --enable-releasegrp
+.endif
+
+post-build:
+# Build the generic named ed2k binary
+# It will be installed in an adhoc fashion
+ @cd ${BUILD_WRKSRC}/src && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ed2k
+
+post-install:
+# Do not install a generic named ed2k binary
+# Install it under a more specific name
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/ed2k \
+ ${PREFIX}/bin/amule-ed2k-handler
+
+.include <bsd.port.mk>