aboutsummaryrefslogtreecommitdiff
path: root/net/arprelease/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
commiteb81a88093e7d71530eebb2957f8ba4317b26ee6 (patch)
tree9290c97700f22b8ed6b87a10fda7d195dac09f04 /net/arprelease/Makefile
parente6b247dce1d9f6355a583ef6269fdbba110eaea8 (diff)
downloadports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.tar.gz
ports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.zip
- Patch net/libnet* to versioned libraries and header files, so they can
coexist PR: ports/103861 Submitted by: alepulver Tested by: pointyhat With hat: portmgr
Notes
Notes: svn path=/head/; revision=183770
Diffstat (limited to 'net/arprelease/Makefile')
-rw-r--r--net/arprelease/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/net/arprelease/Makefile b/net/arprelease/Makefile
index 71fa99e54495..9e7d92bc7bc8 100644
--- a/net/arprelease/Makefile
+++ b/net/arprelease/Makefile
@@ -7,7 +7,7 @@
PORTNAME= arprelease
PORTVERSION= 1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,19 +15,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Libnet tool to flush arp cache entries from devices (eg. routers)
-BUILD_DEPENDS= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= bin/arprelease
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet-config
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
do-build:
(cd ${WRKSRC} && \
- ${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib \
- -o arprelease arprelease.c \
- `${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --libs`)
+ ${CC} ${CFLAGS} `${LIBNET_CONFIG} --defines` \
+ `${LIBNET_CONFIG} --cflags` -o arprelease arprelease.c \
+ `${LIBNET_CONFIG} --libs`)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/arprelease ${PREFIX}/bin