aboutsummaryrefslogtreecommitdiff
path: root/net/arts++
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>2000-11-08 05:13:26 +0000
committerAndreas Klemm <andreas@FreeBSD.org>2000-11-08 05:13:26 +0000
commit8e5a62e8392b77b6df76cafba996abf57c45502c (patch)
treee251346f2081d678b0529d9d64a993a12657a49d /net/arts++
parent72f023b59980d0c514a6bf37aaa5a22651132953 (diff)
downloadports-8e5a62e8392b77b6df76cafba996abf57c45502c.tar.gz
ports-8e5a62e8392b77b6df76cafba996abf57c45502c.zip
new port arts++
A network data storage and analysis library from CAIDA
Notes
Notes: svn path=/head/; revision=34899
Diffstat (limited to 'net/arts++')
-rw-r--r--net/arts++/Makefile25
-rw-r--r--net/arts++/distinfo1
-rw-r--r--net/arts++/pkg-comment1
-rw-r--r--net/arts++/pkg-descr9
-rw-r--r--net/arts++/pkg-plist97
5 files changed, 133 insertions, 0 deletions
diff --git a/net/arts++/Makefile b/net/arts++/Makefile
new file mode 100644
index 000000000000..6f735f8da23e
--- /dev/null
+++ b/net/arts++/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: arts++
+# Date created: Di 7 Nov 2000 19:48:50 CET
+# Whom: Andreas Klemm <andreas@klemm.gtn.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= arts++
+PORTVERSION= 1-1-a6
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.caida.org/pub/arts++/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= andreas@FreeBSD.org
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS+=--enable-shared
+
+MANL= artsportagg.l artsports.l artsprotos.l artsnets.l artsdump.l \
+ artsases.l artstoc.l artsagg.l artsprotoagg.l artsnetagg.l \
+ artsasagg.l artsportms.l artsportmagg.l artsintfms.l \
+ artsintfmagg.l artsnexthops.l artsnexthopagg.l artstos.l
+
+.include <bsd.port.mk>
diff --git a/net/arts++/distinfo b/net/arts++/distinfo
new file mode 100644
index 000000000000..f8808ab823b7
--- /dev/null
+++ b/net/arts++/distinfo
@@ -0,0 +1 @@
+MD5 (arts++-1-1-a6.tar.gz) = b0a0934452a3cc4e07aa53f8121e81e6
diff --git a/net/arts++/pkg-comment b/net/arts++/pkg-comment
new file mode 100644
index 000000000000..9a786e8b04b0
--- /dev/null
+++ b/net/arts++/pkg-comment
@@ -0,0 +1 @@
+A network data storage and analysis library from CAIDA
diff --git a/net/arts++/pkg-descr b/net/arts++/pkg-descr
new file mode 100644
index 000000000000..dcfe77237170
--- /dev/null
+++ b/net/arts++/pkg-descr
@@ -0,0 +1,9 @@
+arts++ is a support package for CAIDA's cflowd and skitter.
+
+It provides a C++ class library and simple applications for handling
+data produced by cflowd and skitter.
+
+See: http://www.caida.org/tools/measurement/cflowd/
+ http://www.caida.org/tools/measurement/skitter/
+
+WWW: http://www.caida.org/tools/utilities/arts/
diff --git a/net/arts++/pkg-plist b/net/arts++/pkg-plist
new file mode 100644
index 000000000000..93820949c83a
--- /dev/null
+++ b/net/arts++/pkg-plist
@@ -0,0 +1,97 @@
+bin/artsagg
+bin/artsasagg
+bin/artsases
+bin/artsdump
+bin/artsintfmagg
+bin/artsintfms
+bin/artsnetagg
+bin/artsnets
+bin/artsnexthopagg
+bin/artsnexthops
+bin/artsportagg
+bin/artsportmagg
+bin/artsportms
+bin/artsports
+bin/artsprotoagg
+bin/artsprotos
+bin/artstoc
+bin/artstos
+include/Arts.hh
+include/ArtsAggregatorMapKey.hh
+include/ArtsAsMatrix.hh
+include/ArtsAsMatrixAggregator.hh
+include/ArtsAsMatrixAggregatorMap.hh
+include/ArtsAsMatrixData.hh
+include/ArtsAsMatrixEntry.hh
+include/ArtsAttribute.hh
+include/ArtsAttributeVector.hh
+include/ArtsBgp4AggregatorAttribute.hh
+include/ArtsBgp4AsPathAttribute.hh
+include/ArtsBgp4AsPathSegment.hh
+include/ArtsBgp4Attribute.hh
+include/ArtsBgp4DPAttribute.hh
+include/ArtsBgp4Prefix.hh
+include/ArtsBgp4RouteEntry.hh
+include/ArtsBgp4RouteTable.hh
+include/ArtsBgp4RouteTableData.hh
+include/ArtsBitString.hh
+include/ArtsDebug.hh
+include/ArtsFileUtil.hh
+include/ArtsHeader.hh
+include/ArtsIfIndexSelectionSet.hh
+include/ArtsInterfaceMatrix.hh
+include/ArtsInterfaceMatrixAggregator.hh
+include/ArtsInterfaceMatrixAggregatorMap.hh
+include/ArtsInterfaceMatrixData.hh
+include/ArtsInterfaceMatrixEntry.hh
+include/ArtsIpPath.hh
+include/ArtsIpPathData.hh
+include/ArtsIpPathEntry.hh
+include/ArtsNetMatrix.hh
+include/ArtsNetMatrixAggregator.hh
+include/ArtsNetMatrixAggregatorMap.hh
+include/ArtsNetMatrixData.hh
+include/ArtsNetMatrixEntry.hh
+include/ArtsNextHopTable.hh
+include/ArtsNextHopTableAggregator.hh
+include/ArtsNextHopTableAggregatorMap.hh
+include/ArtsNextHopTableData.hh
+include/ArtsNextHopTableEntry.hh
+include/ArtsObjectTypeSelectionSet.hh
+include/ArtsPackageVersion.hh
+include/ArtsPortChoice.hh
+include/ArtsPortChooser.hh
+include/ArtsPortMatrix.hh
+include/ArtsPortMatrixAggregator.hh
+include/ArtsPortMatrixAggregatorMap.hh
+include/ArtsPortMatrixData.hh
+include/ArtsPortMatrixEntry.hh
+include/ArtsPortTable.hh
+include/ArtsPortTableAggregator.hh
+include/ArtsPortTableData.hh
+include/ArtsPortTableEntry.hh
+include/ArtsPrimitive.hh
+include/ArtsProtocolTable.hh
+include/ArtsProtocolTableAggregator.hh
+include/ArtsProtocolTableAggregatorMap.hh
+include/ArtsProtocolTableData.hh
+include/ArtsProtocolTableEntry.hh
+include/ArtsRttTimeSeriesTable.hh
+include/ArtsRttTimeSeriesTableData.hh
+include/ArtsSelectedPortTable.hh
+include/ArtsSelectedPortTableData.hh
+include/ArtsTimeIntervalSelectionSet.hh
+include/ArtsTosTable.hh
+include/ArtsTosTableAggregator.hh
+include/ArtsTosTableAggregatorMap.hh
+include/ArtsTosTableData.hh
+include/ArtsTosTableEntry.hh
+include/Ipv4Network.hh
+include/Ipv4PrefixPatricia.hh
+include/artslocal.h
+include/caida_t.h
+lib/libArts.a
+lib/libArts.la
+lib/libArts.so.0
+@unexec /usr/bin/env /sbin/ldconfig -R
+@exec /usr/bin/env /sbin/ldconfig -m %B