aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk10/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2005-08-14 18:44:06 +0000
committerMax Khon <fjoe@FreeBSD.org>2005-08-14 18:44:06 +0000
commitde04276318391b249cfe2b823c5dd0caaf14d99d (patch)
tree405d8f4085da4115b152e5e73a366191f477336b /net/asterisk10/Makefile
parent77414578dfcaf2b0b8b9035e58309f15925a4112 (diff)
downloadports-de04276318391b249cfe2b823c5dd0caaf14d99d.tar.gz
ports-de04276318391b249cfe2b823c5dd0caaf14d99d.zip
- Add dependency on unixODBC (and WITHOUT_ODBC knob).
- Unify WITH_FOO knobs. - Bump PORTREVISION. Approved by: portmgr, MAINTAINER
Notes
Notes: svn path=/head/; revision=140876
Diffstat (limited to 'net/asterisk10/Makefile')
-rw-r--r--net/asterisk10/Makefile25
1 files changed, 19 insertions, 6 deletions
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index c422a6454243..60a8230c08cd 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -52,34 +52,47 @@ WITHOUT_ZAPTEL= 1
.endif
.if defined(WITHOUT_H323)
-MAKE_ENV+= WITHOUT_H323=1
PLIST_SUB+= WITH_H323="@comment "
.else
BUILD_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/devel/pwlib:build \
${NONEXISTENT}:${PORTSDIR}/net/openh323:build
PLIST_SUB+= WITH_H323=""
+MAKE_ENV+= WITH_H323=1
.endif
.if defined(WITHOUT_ZAPTEL)
-MAKE_ENV+= WITHOUT_ZAPTEL=1
PLIST_SUB+= WITH_ZAPTEL="@comment "
.else
LIB_DEPENDS+= pri.1:${PORTSDIR}/misc/libpri
BUILD_DEPENDS+= ${LOCALBASE}/include/zaptel.h:${PORTSDIR}/misc/zaptel
RUN_DEPENDS+= ${LOCALBASE}/include/zaptel.h:${PORTSDIR}/misc/zaptel
PLIST_SUB+= WITH_ZAPTEL=""
+MAKE_ENV+= WITH_ZAPTEL=1
+.endif
+
+#
+# WITH_FREETDS, WITH_PGSQL and WITH_SQLITE can also be added to MAKE_ENV
+# similarly
+.if defined(WITHOUT_ODBC)
+PLIST_SUB+= WITH_ODBC="@comment "
+.else
+LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+PLIST_SUB+= WITH_ODBC=""
+MAKE_ENV+= WITH_ODBC=1
.endif
.if !defined(WITHOUT_MYSQL)
USE_MYSQL= yes
.endif
-.if !defined(WITHOUT_FAX) && ${OSVERSION} >= 500000
+#
+# FAX apps can't be compiled on RELENG_4 at the moment
+.if defined(WITHOUT_FAX) || ${OSVERSION} < 500000
+PLIST_SUB+= WITH_FAX="@comment "
+.else
MAKE_ENV+= WITH_FAX=1
LIB_DEPENDS+= spandsp.0:${PORTSDIR}/comms/spandsp
PLIST_SUB+= WITH_FAX=""
-.else
-PLIST_SUB+= WITH_FAX="@comment "
.endif
post-patch: