aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk14-addons/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2011-11-09 01:28:30 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2011-11-09 01:28:30 +0000
commit42a521c1c4b5310567aa694f79ae814b6fd764e7 (patch)
tree02ca65f51028cc06f80068c668dcc81596b47ea7 /net/asterisk14-addons/Makefile
parent983186f3671ca5bea65c5f494b416ce9d91b43ed (diff)
downloadports-42a521c1c4b5310567aa694f79ae814b6fd764e7.tar.gz
ports-42a521c1c4b5310567aa694f79ae814b6fd764e7.zip
Resurrect net/asterisk14-addons and upgrade to latest 1.4.13. Assign
maintainership to bamby@sippysoft.com, apparently old maintainer has no interest in maintaining this.
Notes
Notes: svn path=/head/; revision=285317
Diffstat (limited to 'net/asterisk14-addons/Makefile')
-rw-r--r--net/asterisk14-addons/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/net/asterisk14-addons/Makefile b/net/asterisk14-addons/Makefile
new file mode 100644
index 000000000000..4df9fdc3e057
--- /dev/null
+++ b/net/asterisk14-addons/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: asterisk-addons
+# Date created: 23 March 2006
+# Whom: Fabian Gast <fgast@only640k.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= asterisk14
+PORTVERSION= 1.4.13
+CATEGORIES= net
+MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
+ http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
+PKGNAMESUFFIX= -addons
+DISTNAME= asterisk${PKGNAMESUFFIX}-${DISTVERSION}
+
+MAINTAINER= bamby@sippysoft.com
+COMMENT= GPL modules for the Asterisk Open Source PBX
+
+BUILD_DEPENDS= asterisk:${PORTSDIR}/net/asterisk14
+RUN_DEPENDS= asterisk:${PORTSDIR}/net/asterisk14
+
+OPTIONS= SAMPLE_CONFIG "Install sample configuration files" off
+
+ONLY_FOR_ARCHS= i386 amd64 powerpc
+USE_AUTOTOOLS= libtool
+USE_MYSQL= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SAMPLE_CONFIG)
+PLIST_SUB+= SAMPLE_CONFIG=""
+.else
+PLIST_SUB+= SAMPLE_CONFIG="@comment "
+.endif
+
+pre-configure:
+ if ${GREP} -sq fixup_codecs ${LOCALBASE}/include/asterisk/channel.h; \
+ then \
+ ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/codecnego.diff; \
+ fi
+
+post-install:
+.if defined(WITH_SAMPLE_CONFIG)
+ @cd ${WRKSRC} && ${GMAKE} samples
+.endif
+
+.include <bsd.port.post.mk>