aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk16/files
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2006-06-16 23:34:44 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2006-06-16 23:34:44 +0000
commitaed675aa760db17169de3050c425cb1e8cb8e55f (patch)
tree104ce6d6a702c654126a1488aff1ae348d384804 /net/asterisk16/files
parentf121cfd31f4fb5774f42f1d89705938b0d6aa583 (diff)
downloadports-aed675aa760db17169de3050c425cb1e8cb8e55f.tar.gz
ports-aed675aa760db17169de3050c425cb1e8cb8e55f.zip
Update to 1.2.9.1.
Notes
Notes: svn path=/head/; revision=165611
Diffstat (limited to 'net/asterisk16/files')
-rw-r--r--net/asterisk16/files/patch-Makefile76
-rw-r--r--net/asterisk16/files/patch-apps::Makefile16
-rw-r--r--net/asterisk16/files/patch-apps::app_rxfax.c90
-rw-r--r--net/asterisk16/files/patch-apps::app_txfax.c75
-rw-r--r--net/asterisk16/files/patch-codecs::gsm::Makefile23
5 files changed, 151 insertions, 129 deletions
diff --git a/net/asterisk16/files/patch-Makefile b/net/asterisk16/files/patch-Makefile
index 61a2c51190b5..879d944fd9e4 100644
--- a/net/asterisk16/files/patch-Makefile
+++ b/net/asterisk16/files/patch-Makefile
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- Makefile.orig
-+++ Makefile
+--- Makefile.orig Wed Jun 14 11:59:17 2006
++++ Makefile Wed Jun 14 13:54:57 2006
@@ -19,8 +19,8 @@
# CROSS_COMPILE=/opt/montavista/pro/devkit/arm/xscale_be/bin/xscale_be-
# CROSS_COMPILE_BIN=/opt/montavista/pro/devkit/arm/xscale_be/bin/
@@ -14,7 +11,7 @@ $FreeBSD$
# CROSS_ARCH=Linux
# CROSS_PROC=arm
# SUB_PROC=xscale # or maverick
-@@ -44,14 +44,14 @@
+@@ -46,14 +46,14 @@
#K6OPT = -DK6OPT
#Tell gcc to optimize the code
@@ -32,7 +29,7 @@ $FreeBSD$
#Set NOCRYPTO to yes if you do not want to have crypto support or
#dependencies
-@@ -83,7 +83,7 @@
+@@ -85,7 +85,7 @@
# Where to install asterisk after compiling
# Default -> leave empty
@@ -41,7 +38,7 @@ $FreeBSD$
# Staging directory
# Files are copied here temporarily during the install process
-@@ -106,17 +106,17 @@
+@@ -108,17 +108,17 @@
BUSYDETECT+= #-DBUSYDETECT_COMPARE_TONE_AND_SILENCE
ifneq ($(OSARCH),SunOS)
@@ -68,7 +65,7 @@ $FreeBSD$
MODULES_DIR=$(ASTLIBDIR)/modules
AGI_DIR=$(ASTVARLIBDIR)/agi-bin
else
-@@ -218,25 +218,25 @@
+@@ -220,25 +220,25 @@
endif
INCLUDE+=-Iinclude -I../include
@@ -100,7 +97,7 @@ $FreeBSD$
else
ifneq ($(wildcard $(CROSS_COMPILE_TARGET)/usr/include/osp/osp.h),)
ASTCFLAGS+=-DOSP_SUPPORT -I$(CROSS_COMPILE_TARGET)/usr/include/osp
-@@ -245,27 +245,24 @@
+@@ -247,27 +247,24 @@
ifeq ($(OSARCH),FreeBSD)
BSDVERSION=$(shell make -V OSVERSION -f $(CROSS_COMPILE_TARGET)/usr/share/mk/bsd.port.subdir.mk)
@@ -142,7 +139,7 @@ $FreeBSD$
endif # FreeBSD
-@@ -281,7 +278,7 @@
+@@ -283,7 +280,7 @@
ifeq ($(OSARCH),SunOS)
ASTCFLAGS+=-Wcast-align -DSOLARIS
@@ -151,7 +148,7 @@ $FreeBSD$
endif
ifeq ($(findstring CYGWIN,$(OSARCH)),CYGWIN)
-@@ -296,7 +293,7 @@
+@@ -298,7 +295,7 @@
ifndef WITHOUT_ZAPTEL
@@ -160,7 +157,7 @@ $FreeBSD$
ASTCFLAGS+=-DZAPTEL_OPTIMIZATIONS
endif
-@@ -388,10 +385,10 @@
+@@ -390,10 +387,10 @@
endif
ifeq ($(OSARCH),SunOS)
@@ -173,7 +170,7 @@ $FreeBSD$
endif
ifeq ($(MAKETOPLEVEL),$(MAKELEVEL))
-@@ -399,7 +396,7 @@
+@@ -401,7 +398,7 @@
endif
# This is used when generating the doxygen documentation
@@ -182,7 +179,7 @@ $FreeBSD$
HAVEDOT=yes
else
HAVEDOT=no
-@@ -418,7 +415,7 @@
+@@ -420,7 +417,7 @@
@echo " + $(MAKE) install +"
@echo " +-------------------------------------------+"
@@ -191,8 +188,8 @@ $FreeBSD$
#ifneq ($(wildcard tags),)
ctags: tags
-@@ -437,13 +434,13 @@
- cd editline && unset CFLAGS LIBS && test -f config.h || ./configure
+@@ -439,13 +436,13 @@
+ cd editline && unset CFLAGS LIBS && test -f config.h || CFLAGS="$(OPTIMIZE)" ./configure
$(MAKE) -C editline libedit.a
-db1-ast/libdb1.a: FORCE
@@ -212,7 +209,7 @@ $FreeBSD$
ifneq ($(wildcard .depend),)
include .depend
-@@ -470,10 +467,10 @@
+@@ -469,10 +466,10 @@
manpage: asterisk.8
@@ -227,7 +224,7 @@ $FreeBSD$
asterisk.pdf: asterisk.sgml
docbook2pdf asterisk.sgml
-@@ -510,14 +507,14 @@
+@@ -512,14 +509,14 @@
cygwin_a:
$(MAKE) -C cygwin all
@@ -244,7 +241,7 @@ $FreeBSD$
muted: muted.o
$(CC) $(AUDIO_LIBS) -o muted muted.o
-@@ -539,38 +536,38 @@
+@@ -541,38 +538,38 @@
datafiles: all
if [ x`$(ID) -un` = xroot ]; then sh mkpkgconfig $(DESTDIR)/usr/lib/pkgconfig; fi
@@ -292,7 +289,7 @@ $FreeBSD$
else \
echo "No description for $$x"; \
exit 1; \
-@@ -578,18 +575,18 @@
+@@ -580,18 +577,18 @@
done
for x in sounds/demo-* sounds/vm-* sounds/transfer* sounds/pbx-* sounds/ss-* sounds/beep* sounds/dir-* sounds/conf-* sounds/agent-* sounds/invalid* sounds/tt-* sounds/auth-* sounds/privacy-* sounds/queue-* sounds/spy-* sounds/priv-* sounds/screen-* sounds/hello-*; do \
if $(GREP) -q "^%`basename $$x`%" sounds.txt; then \
@@ -316,7 +313,7 @@ $FreeBSD$
update:
@if [ -d .svn ]; then \
-@@ -618,73 +615,51 @@
+@@ -620,47 +617,47 @@
OLDHEADERS=$(filter-out $(NEWHEADERS),$(notdir $(wildcard $(DESTDIR)$(ASTHEADERDIR)/*.h)))
bininstall: all
@@ -357,7 +354,6 @@ $FreeBSD$
cat contrib/scripts/safe_asterisk | sed 's|__ASTERISK_SBIN_DIR__|$(ASTSBINDIR)|;' > $(DESTDIR)$(ASTSBINDIR)/safe_asterisk ;\
chmod 755 $(DESTDIR)$(ASTSBINDIR)/safe_asterisk;\
fi
- for x in $(SUBDIRS); do $(MAKE) -C $$x install || exit 1 ; done
- $(INSTALL) -d $(DESTDIR)$(ASTHEADERDIR)
- $(INSTALL) -m 644 include/asterisk/*.h $(DESTDIR)$(ASTHEADERDIR)
+ $(MKDIR) $(DESTDIR)$(ASTHEADERDIR)
@@ -397,7 +393,15 @@ $FreeBSD$
else \
echo "You need to do cvs update -d not just cvs update" ; \
fi
-- if [ -f mpg123-0.59r/mpg123 ]; then $(MAKE) -C mpg123-0.59r install; fi
+@@ -690,46 +687,28 @@
+ echo " WARNING WARNING WARNING" ;\
+ fi
+
+-install: all datafiles bininstall install-subdirs
++install: all datafiles bininstall install-subdirs samples
+ @if [ -x /usr/sbin/asterisk-post-install ]; then \
+ /usr/sbin/asterisk-post-install $(DESTDIR) . ; \
+ fi
- @echo " +---- Asterisk Installation Complete -------+"
- @echo " + +"
- @echo " + YOU MUST READ THE SECURITY DOCUMENT +"
@@ -421,17 +425,6 @@ $FreeBSD$
- @echo " +-------------------------------------------+"
@$(MAKE) -s oldmodcheck
- NEWMODS=$(notdir $(wildcard */*.so))
-@@ -710,7 +685,7 @@
- echo " WARNING WARNING WARNING" ;\
- fi
-
--install: all datafiles bininstall
-+install: all datafiles bininstall samples
- @if [ -x /usr/sbin/asterisk-post-install ]; then \
- /usr/sbin/asterisk-post-install $(DESTDIR) . ; \
- fi
-@@ -718,16 +693,19 @@
upgrade: all bininstall
adsi:
@@ -454,7 +447,7 @@ $FreeBSD$
if [ -f $(DESTDIR)$(ASTETCDIR)/`basename $$x .sample` ]; then \
if [ "$(OVERWRITE)" = "y" ]; then \
if cmp -s $(DESTDIR)$(ASTETCDIR)/`basename $$x .sample` $$x ; then \
-@@ -740,7 +718,7 @@
+@@ -742,7 +721,7 @@
continue; \
fi ;\
fi ; \
@@ -463,7 +456,7 @@ $FreeBSD$
done
if [ "$(OVERWRITE)" = "y" ] || [ ! -f $(DESTDIR)$(ASTCONFPATH) ]; then \
( \
-@@ -800,25 +778,25 @@
+@@ -802,25 +781,25 @@
echo "; Default: strict"; \
echo ";"; \
echo ";translation_algorithm = strict"; \
@@ -495,16 +488,19 @@ $FreeBSD$
:> $(DESTDIR)$(ASTSPOOLDIR)/voicemail/default/1234/unavail.gsm
for x in vm-theperson digits/1 digits/2 digits/3 digits/4 vm-isunavail; do \
cat $(DESTDIR)$(ASTVARLIBDIR)/sounds/$$x.gsm >> $(DESTDIR)$(ASTSPOOLDIR)/voicemail/default/1234/unavail.gsm ; \
-@@ -832,7 +810,7 @@
+@@ -834,9 +813,9 @@
@[ -d $(DESTDIR)$(HTTP_DOCSDIR)/ ] || ( printf "http docs directory not found.\nUpdate assignment of variable HTTP_DOCSDIR in Makefile!\n" && exit 1 )
@[ -d $(DESTDIR)$(HTTP_CGIDIR) ] || ( printf "cgi-bin directory not found.\nUpdate assignment of variable HTTP_CGIDIR in Makefile!\n" && exit 1 )
$(INSTALL) -m 4755 -o root -g root contrib/scripts/vmail.cgi $(DESTDIR)$(HTTP_CGIDIR)/vmail.cgi
- mkdir -p $(DESTDIR)$(HTTP_DOCSDIR)/_asterisk
+ $(MKDIR) $(DESTDIR)$(HTTP_DOCSDIR)/_asterisk
for x in images/*.gif; do \
- $(INSTALL) -m 644 $$x $(DESTDIR)$(HTTP_DOCSDIR)/_asterisk/; \
+- $(INSTALL) -m 644 $$x $(DESTDIR)$(HTTP_DOCSDIR)/_asterisk/; \
++ $(BSD_INSTALL_DATA) $$x $(DESTDIR)$(HTTP_DOCSDIR)/_asterisk/; \
done
-@@ -861,10 +839,10 @@
+ @echo " +--------- Asterisk Web Voicemail ----------+"
+ @echo " + +"
+@@ -863,10 +842,10 @@
__rpm: include/asterisk/version.h spec
rm -rf /tmp/asterisk ; \
diff --git a/net/asterisk16/files/patch-apps::Makefile b/net/asterisk16/files/patch-apps::Makefile
index 2b0de4d3381c..9881ae1f3831 100644
--- a/net/asterisk16/files/patch-apps::Makefile
+++ b/net/asterisk16/files/patch-apps::Makefile
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- apps/Makefile.orig
-+++ apps/Makefile
+--- apps/Makefile.orig Sun Apr 30 16:38:22 2006
++++ apps/Makefile Wed Jun 14 14:03:42 2006
@@ -45,25 +45,27 @@
#APPS+=app_rpt.so
@@ -40,7 +37,7 @@ $FreeBSD$
ifeq (${OSARCH},CYGWIN)
CYGSOLINK=-Wl,--out-implib=lib$@.a -Wl,--export-all-symbols
-@@ -95,24 +97,32 @@
+@@ -95,18 +97,26 @@
$(CC) $(SOLINK) -o $@ ${CYGSOLINK} $< ${CYGSOLIB} -ltonezone
install: all
@@ -70,10 +67,3 @@ $FreeBSD$
app_sql_odbc.so: app_sql_odbc.o
$(CC) $(SOLINK) -o $@ ${CYGSOLINK} $< ${CYGSOLIB} -lodbc
-
- look: look.c
-- $(CC) -pipe -O6 -g look.c -o look -lncurses
-+ $(CC) look.c -o look -lncurses
-
- ifeq (SunOS,$(shell uname))
- app_chanspy.so: app_chanspy.o
diff --git a/net/asterisk16/files/patch-apps::app_rxfax.c b/net/asterisk16/files/patch-apps::app_rxfax.c
index 820208e1943d..d294ecdfd5e2 100644
--- a/net/asterisk16/files/patch-apps::app_rxfax.c
+++ b/net/asterisk16/files/patch-apps::app_rxfax.c
@@ -1,9 +1,9 @@
$FreeBSD$
---- /dev/null Thu Jan 12 17:44:40 2006
-+++ apps/app_rxfax.c Thu Jan 12 17:41:53 2006
-@@ -0,0 +1,373 @@
+--- apps/app_rxfax.c.orig
++++ apps/app_rxfax.c
+@@ -0,0 +1,391 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -17,31 +17,35 @@ $FreeBSD$
+ * the GNU General Public License
+ */
+
-+#include <stdio.h>
-+#include <asterisk/lock.h>
-+#include <asterisk/file.h>
-+#include <asterisk/logger.h>
-+#include <asterisk/channel.h>
-+#include <asterisk/pbx.h>
-+#include <asterisk/module.h>
-+#include <asterisk/translate.h>
-+#include <asterisk/dsp.h>
-+#include <asterisk/manager.h>
-+#include <asterisk/version.h>
+#include <string.h>
+#include <stdlib.h>
-+#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <stdio.h>
++#if !defined(__FreeBSD__) || __FreeBSD_version < 500028
+#include <inttypes.h>
+#else
+#include <stdint.h>
+#endif
+#include <pthread.h>
+#include <errno.h>
-+#include <math.h>
++#include <tgmath.h>
+#include <tiffio.h>
+
+#include <spandsp.h>
+
++#include "asterisk.h"
++
++ASTERISK_FILE_VERSION(__FILE__, "$Revision:$")
++
++#include "asterisk/lock.h"
++#include "asterisk/file.h"
++#include "asterisk/logger.h"
++#include "asterisk/channel.h"
++#include "asterisk/pbx.h"
++#include "asterisk/module.h"
++#include "asterisk/translate.h"
++#include "asterisk/dsp.h"
++#include "asterisk/manager.h"
++
+static char *tdesc = "Trivial FAX Receive Application";
+
+static char *app = "RxFAX";
@@ -70,6 +74,20 @@ $FreeBSD$
+
+#define MAX_BLOCK_SIZE 240
+
++static void span_message(int level, const char *msg)
++{
++ int ast_level;
++
++ if (level == SPAN_LOG_WARNING)
++ ast_level = __LOG_WARNING;
++ else if (level == SPAN_LOG_WARNING)
++ ast_level = __LOG_WARNING;
++ else
++ ast_level = __LOG_DEBUG;
++ ast_log(ast_level, __FILE__, __LINE__, __PRETTY_FUNCTION__, msg);
++}
++/*- End of function --------------------------------------------------------*/
++
+static void t30_flush(t30_state_t *s, int which)
+{
+ //TODO:
@@ -85,11 +103,11 @@ $FreeBSD$
+ char buf[11];
+
+ chan = (struct ast_channel *) user_data;
-+ if (result)
++ if (result == T30_ERR_OK)
+ {
-+ fax_get_transfer_statistics(s, &t);
-+ fax_get_far_ident(s, far_ident);
-+ fax_get_local_ident(s, local_ident);
++ t30_get_transfer_statistics(s, &t);
++ t30_get_far_ident(s, far_ident);
++ t30_get_local_ident(s, local_ident);
+ ast_log(LOG_DEBUG, "==============================================================================\n");
+ ast_log(LOG_DEBUG, "Fax successfully received.\n");
+ ast_log(LOG_DEBUG, "Remote station id: %s\n", far_ident);
@@ -102,11 +120,7 @@ $FreeBSD$
+ "FaxReceived", "Channel: %s\nExten: %s\nCallerID: %s\nRemoteStationID: %s\nLocalStationID: %s\nPagesTransferred: %i\nResolution: %i\nTransferRate: %i\nFileName: %s\n",
+ chan->name,
+ chan->exten,
-+#if ASTERISK_VERSION_NUM <= 010010
-+ chan->callerid,
-+#else
+ (chan->cid.cid_num) ? chan->cid.cid_num : "",
-+#endif
+ far_ident,
+ local_ident,
+ t.pages_transferred,
@@ -124,7 +138,7 @@ $FreeBSD$
+ else
+ {
+ ast_log(LOG_DEBUG, "==============================================================================\n");
-+ ast_log(LOG_DEBUG, "Fax receive not successful.\n");
++ ast_log(LOG_DEBUG, "Fax receive not successful - result (%d) %s.\n", result, t30_completion_code_to_str(result));
+ ast_log(LOG_DEBUG, "==============================================================================\n");
+ }
+}
@@ -138,7 +152,7 @@ $FreeBSD$
+ chan = (struct ast_channel *) user_data;
+ if (result)
+ {
-+ fax_get_transfer_statistics(s, &t);
++ t30_get_transfer_statistics(s, &t);
+ ast_log(LOG_DEBUG, "==============================================================================\n");
+ ast_log(LOG_DEBUG, "Pages transferred: %i\n", t.pages_transferred);
+ ast_log(LOG_DEBUG, "Image size: %i x %i\n", t.columns, t.rows);
@@ -186,6 +200,8 @@ $FreeBSD$
+ return -1;
+ }
+
++ span_set_message_handler(span_message);
++
+ /* The next few lines of code parse out the filename and header from the input string */
+ if (data == NULL)
+ {
@@ -203,7 +219,7 @@ $FreeBSD$
+ t = s;
+ v = strchr(s, '|');
+ s = (v) ? v : s + strlen(s);
-+ strncpy(buf, t, s - t);
++ strncpy((char *) buf, t, s - t);
+ buf[s - t] = '\0';
+ if (option == 0)
+ {
@@ -274,17 +290,18 @@ $FreeBSD$
+ }
+ }
+ fax_init(&fax, calling_party, NULL);
-+ fax.verbose = verbose;
++ if (verbose)
++ fax.logging.level = SPAN_LOG_SHOW_SEVERITY | SPAN_LOG_SHOW_PROTOCOL | SPAN_LOG_FLOW;
+ x = pbx_builtin_getvar_helper(chan, "LOCALSTATIONID");
+ if (x && x[0])
-+ fax_set_local_ident(&fax, x);
++ t30_set_local_ident(&fax, x);
+ x = pbx_builtin_getvar_helper(chan, "LOCALHEADERINFO");
+ if (x && x[0])
-+ fax_set_header_info(&fax, x);
-+ fax_set_rx_file(&fax, target_file);
-+ //fax_set_phase_b_handler(&fax, phase_b_handler, chan);
-+ fax_set_phase_d_handler(&fax, phase_d_handler, chan);
-+ fax_set_phase_e_handler(&fax, phase_e_handler, chan);
++ t30_set_header_info(&fax, x);
++ t30_set_rx_file(&fax, target_file, -1);
++ //t30_set_phase_b_handler(&fax, phase_b_handler, chan);
++ t30_set_phase_d_handler(&fax, phase_d_handler, chan);
++ t30_set_phase_e_handler(&fax, phase_e_handler, chan);
+ while (ast_waitfor(chan, -1) > -1)
+ {
+ inf = ast_read(chan);
@@ -295,10 +312,10 @@ $FreeBSD$
+ }
+ if (inf->frametype == AST_FRAME_VOICE)
+ {
-+ if (fax_rx_process(&fax, inf->data, inf->samples))
++ if (fax_rx(&fax, inf->data, inf->samples))
+ break;
+ samples = (inf->samples <= MAX_BLOCK_SIZE) ? inf->samples : MAX_BLOCK_SIZE;
-+ len = fax_tx_process(&fax, (int16_t *) &buf[AST_FRIENDLY_OFFSET], samples);
++ len = fax_tx(&fax, (int16_t *) &buf[AST_FRIENDLY_OFFSET], samples);
+ if (len)
+ {
+ memset(&outf, 0, sizeof(outf));
@@ -335,6 +352,7 @@ $FreeBSD$
+ if (res)
+ ast_log(LOG_WARNING, "Unable to restore write format on '%s'\n", chan->name);
+ }
++ fax_release(&fax);
+ }
+ else
+ {
diff --git a/net/asterisk16/files/patch-apps::app_txfax.c b/net/asterisk16/files/patch-apps::app_txfax.c
index 15ad6674788e..0a3a1d5d52ac 100644
--- a/net/asterisk16/files/patch-apps::app_txfax.c
+++ b/net/asterisk16/files/patch-apps::app_txfax.c
@@ -1,9 +1,9 @@
$FreeBSD$
---- /dev/null Thu Jan 12 17:48:54 2006
-+++ apps/app_txfax.c Thu Jan 12 17:48:36 2006
-@@ -0,0 +1,295 @@
+--- apps/app_txfax.c.orig
++++ apps/app_txfax.c
+@@ -0,0 +1,318 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -17,28 +17,33 @@ $FreeBSD$
+ * the GNU General Public License
+ */
+
-+#include <stdio.h>
-+#include <asterisk/lock.h>
-+#include <asterisk/file.h>
-+#include <asterisk/logger.h>
-+#include <asterisk/channel.h>
-+#include <asterisk/pbx.h>
-+#include <asterisk/module.h>
-+#include <asterisk/translate.h>
+#include <string.h>
+#include <stdlib.h>
-+#include <math.h>
-+#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <stdio.h>
++#if !defined(__FreeBSD__) || __FreeBSD_version < 500028
+#include <inttypes.h>
+#else
+#include <stdint.h>
+#endif
+#include <pthread.h>
+#include <errno.h>
++#include <tgmath.h>
+#include <tiffio.h>
+
+#include <spandsp.h>
+
++#include "asterisk.h"
++
++ASTERISK_FILE_VERSION(__FILE__, "$Revision:$")
++
++#include "asterisk/lock.h"
++#include "asterisk/file.h"
++#include "asterisk/logger.h"
++#include "asterisk/channel.h"
++#include "asterisk/pbx.h"
++#include "asterisk/module.h"
++#include "asterisk/translate.h"
++
+static char *tdesc = "Trivial FAX Transmit Application";
+
+static char *app = "TxFAX";
@@ -62,6 +67,20 @@ $FreeBSD$
+
+#define MAX_BLOCK_SIZE 240
+
++static void span_message(int level, const char *msg)
++{
++ int ast_level;
++
++ if (level == SPAN_LOG_WARNING)
++ ast_level = __LOG_WARNING;
++ else if (level == SPAN_LOG_WARNING)
++ ast_level = __LOG_WARNING;
++ else
++ ast_level = __LOG_DEBUG;
++ ast_log(ast_level, __FILE__, __LINE__, __PRETTY_FUNCTION__, msg);
++}
++/*- End of function --------------------------------------------------------*/
++
+static void t30_flush(t30_state_t *s, int which)
+{
+ //TODO:
@@ -74,15 +93,15 @@ $FreeBSD$
+ char far_ident[21];
+
+ chan = (struct ast_channel *) user_data;
-+ if (result)
++ if (result == T30_ERR_OK)
+ {
-+ fax_get_far_ident(s, far_ident);
++ t30_get_far_ident(s, far_ident);
+ pbx_builtin_setvar_helper(chan, "REMOTESTATIONID", far_ident);
+ }
+ else
+ {
+ ast_log(LOG_DEBUG, "==============================================================================\n");
-+ ast_log(LOG_DEBUG, "Fax send not successful.\n");
++ ast_log(LOG_DEBUG, "Fax send not successful - result (%d) %s.\n", result, t30_completion_code_to_str(result));
+ ast_log(LOG_DEBUG, "==============================================================================\n");
+ }
+}
@@ -119,6 +138,8 @@ $FreeBSD$
+ return -1;
+ }
+
++ span_set_message_handler(span_message);
++
+ /* The next few lines of code parse out the filename and header from the input string */
+ if (data == NULL)
+ {
@@ -136,7 +157,7 @@ $FreeBSD$
+ t = s;
+ v = strchr(s, '|');
+ s = (v) ? v : s + strlen(s);
-+ strncpy(buf, t, s - t);
++ strncpy((char *) buf, t, s - t);
+ buf[s - t] = '\0';
+ if (option == 0)
+ {
@@ -194,18 +215,19 @@ $FreeBSD$
+ }
+ }
+ fax_init(&fax, calling_party, NULL);
-+ fax.verbose = verbose;
++ if (verbose)
++ fax.logging.level = SPAN_LOG_SHOW_SEVERITY | SPAN_LOG_SHOW_PROTOCOL | SPAN_LOG_FLOW;
+
+ x = pbx_builtin_getvar_helper(chan, "LOCALSTATIONID");
+ if (x && x[0])
-+ fax_set_local_ident(&fax, x);
++ t30_set_local_ident(&fax, x);
+ x = pbx_builtin_getvar_helper(chan, "LOCALHEADERINFO");
+ if (x && x[0])
-+ fax_set_header_info(&fax, x);
-+ fax_set_tx_file(&fax, source_file);
-+ //fax_set_phase_b_handler(&fax, phase_b_handler, chan);
-+ //fax_set_phase_d_handler(&fax, phase_d_handler, chan);
-+ fax_set_phase_e_handler(&fax, phase_e_handler, chan);
++ t30_set_header_info(&fax, x);
++ t30_set_tx_file(&fax, source_file, -1, -1);
++ //t30_set_phase_b_handler(&fax, phase_b_handler, chan);
++ //t30_set_phase_d_handler(&fax, phase_d_handler, chan);
++ t30_set_phase_e_handler(&fax, phase_e_handler, chan);
+ while (ast_waitfor(chan, -1) > -1)
+ {
+ inf = ast_read(chan);
@@ -216,10 +238,10 @@ $FreeBSD$
+ }
+ if (inf->frametype == AST_FRAME_VOICE)
+ {
-+ if (fax_rx_process(&fax, inf->data, inf->samples))
++ if (fax_rx(&fax, inf->data, inf->samples))
+ break;
+ samples = (inf->samples <= MAX_BLOCK_SIZE) ? inf->samples : MAX_BLOCK_SIZE;
-+ len = fax_tx_process(&fax, (int16_t *) &buf[AST_FRIENDLY_OFFSET], samples);
++ len = fax_tx(&fax, (int16_t *) &buf[AST_FRIENDLY_OFFSET], samples);
+ if (len)
+ {
+ memset(&outf, 0, sizeof(outf));
@@ -255,6 +277,7 @@ $FreeBSD$
+ if (res)
+ ast_log(LOG_WARNING, "Unable to restore write format on '%s'\n", chan->name);
+ }
++ fax_release(&fax);
+ }
+ else
+ {
diff --git a/net/asterisk16/files/patch-codecs::gsm::Makefile b/net/asterisk16/files/patch-codecs::gsm::Makefile
index 7256eeae5692..756d43ca6fcd 100644
--- a/net/asterisk16/files/patch-codecs::gsm::Makefile
+++ b/net/asterisk16/files/patch-codecs::gsm::Makefile
@@ -1,16 +1,11 @@
-
-$FreeBSD$
-
---- codecs/gsm/Makefile.orig
-+++ codecs/gsm/Makefile
-@@ -49,7 +49,9 @@
- ifneq (${PROC},arm)
- ifneq (${PROC},ppc)
- ifneq (${PROC},ppc64)
+--- codecs/gsm/Makefile.orig Tue May 30 22:18:30 2006
++++ codecs/gsm/Makefile Wed Jun 14 14:07:42 2006
+@@ -51,7 +51,7 @@
+ ifneq (${PROC},ppc)
+ ifneq (${PROC},ppc64)
+ ifneq (${PROC},s390)
-OPTIMIZE+=-march=$(PROC)
-+ifneq (${PROC},amd64)
+#OPTIMIZE+=-march=$(PROC)
-+endif
- endif
- endif
- endif
+ endif
+ endif
+ endif