aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk16/files
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2006-01-27 00:15:33 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2006-01-27 00:15:33 +0000
commitf644d74fb3dbea51b869dd1ec436891b806d25ad (patch)
treec226d45b14ae604a0808be443a4ff3ee02252a14 /net/asterisk16/files
parent5a7bdcd5bada33a19827970ef378f5e8c45ffadd (diff)
downloadports-f644d74fb3dbea51b869dd1ec436891b806d25ad.tar.gz
ports-f644d74fb3dbea51b869dd1ec436891b806d25ad.zip
Update to 1.2.3.
Notes
Notes: svn path=/head/; revision=154549
Diffstat (limited to 'net/asterisk16/files')
-rw-r--r--net/asterisk16/files/patch-Makefile20
-rw-r--r--net/asterisk16/files/patch-channels::chan_h323.c14
-rw-r--r--net/asterisk16/files/patch-channels::chan_sip.c20
-rw-r--r--net/asterisk16/files/patch-codecs::gsm::Makefile5
-rw-r--r--net/asterisk16/files/patch-frame.c14
5 files changed, 39 insertions, 34 deletions
diff --git a/net/asterisk16/files/patch-Makefile b/net/asterisk16/files/patch-Makefile
index 16f6b03edab1..708a356041a3 100644
--- a/net/asterisk16/files/patch-Makefile
+++ b/net/asterisk16/files/patch-Makefile
@@ -68,7 +68,7 @@ $FreeBSD$
MODULES_DIR=$(ASTLIBDIR)/modules
AGI_DIR=$(ASTVARLIBDIR)/agi-bin
else
-@@ -218,13 +218,13 @@
+@@ -218,25 +218,25 @@
endif
INCLUDE+=-Iinclude -I../include
@@ -85,7 +85,11 @@ $FreeBSD$
endif
ifneq ($(PROC),ultrasparc)
-@@ -235,8 +235,8 @@
+- ASTCFLAGS+=$(shell if $(CC) -march=$(PROC) -S -o /dev/null -xc /dev/null >/dev/null 2>&1; then echo "-march=$(PROC)"; fi)
++# ASTCFLAGS+=$(shell if $(CC) -march=$(PROC) -S -o /dev/null -xc /dev/null >/dev/null 2>&1; then echo "-march=$(PROC)"; fi)
+ endif
+
+ ifeq ($(PROC),ppc)
ASTCFLAGS+=-fsigned-char
endif
@@ -455,10 +459,10 @@ $FreeBSD$
done
if [ "$(OVERWRITE)" = "y" ] || [ ! -f $(DESTDIR)$(ASTCONFPATH) ]; then \
( \
-@@ -759,25 +737,25 @@
- echo ";astctlowner = root" ; \
- echo ";astctlgroup = apache" ; \
- echo ";astctl = asterisk.ctl" ; \
+@@ -800,25 +778,25 @@
+ echo "; Default: strict"; \
+ echo ";"; \
+ echo ";translation_algorithm = strict"; \
- ) > $(DESTDIR)$(ASTCONFPATH) ; \
+ ) > $(DESTDIR)$(ASTCONFPATH)-dist ; \
else \
@@ -487,7 +491,7 @@ $FreeBSD$
:> $(DESTDIR)$(ASTSPOOLDIR)/voicemail/default/1234/unavail.gsm
for x in vm-theperson digits/1 digits/2 digits/3 digits/4 vm-isunavail; do \
cat $(DESTDIR)$(ASTVARLIBDIR)/sounds/$$x.gsm >> $(DESTDIR)$(ASTSPOOLDIR)/voicemail/default/1234/unavail.gsm ; \
-@@ -791,7 +769,7 @@
+@@ -832,7 +810,7 @@
@[ -d $(DESTDIR)$(HTTP_DOCSDIR)/ ] || ( printf "http docs directory not found.\nUpdate assignment of variable HTTP_DOCSDIR in Makefile!\n" && exit 1 )
@[ -d $(DESTDIR)$(HTTP_CGIDIR) ] || ( printf "cgi-bin directory not found.\nUpdate assignment of variable HTTP_CGIDIR in Makefile!\n" && exit 1 )
$(INSTALL) -m 4755 -o root -g root contrib/scripts/vmail.cgi $(DESTDIR)$(HTTP_CGIDIR)/vmail.cgi
@@ -496,7 +500,7 @@ $FreeBSD$
for x in images/*.gif; do \
$(INSTALL) -m 644 $$x $(DESTDIR)$(HTTP_DOCSDIR)/_asterisk/; \
done
-@@ -820,10 +798,10 @@
+@@ -861,10 +839,10 @@
__rpm: include/asterisk/version.h spec
rm -rf /tmp/asterisk ; \
diff --git a/net/asterisk16/files/patch-channels::chan_h323.c b/net/asterisk16/files/patch-channels::chan_h323.c
deleted file mode 100644
index 6498b9721fdc..000000000000
--- a/net/asterisk16/files/patch-channels::chan_h323.c
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- channels/chan_h323.c.orig Tue Nov 29 20:24:39 2005
-+++ channels/chan_h323.c Thu Jan 12 18:29:50 2006
-@@ -2281,7 +2281,7 @@ static char *convertcap(int cap)
- }
- }
-
--static int oh323_set_rtp_peer(struct ast_channel *chan, struct ast_rtp *rtp, struct ast_rtp *vrtp, int codecs)
-+static int oh323_set_rtp_peer(struct ast_channel *chan, struct ast_rtp *rtp, struct ast_rtp *vrtp, int codecs, int nat_active)
- {
- /* XXX Deal with Video */
- struct oh323_pvt *pvt;
diff --git a/net/asterisk16/files/patch-channels::chan_sip.c b/net/asterisk16/files/patch-channels::chan_sip.c
index 355c558c2ab1..2b2fae7a311f 100644
--- a/net/asterisk16/files/patch-channels::chan_sip.c
+++ b/net/asterisk16/files/patch-channels::chan_sip.c
@@ -1,9 +1,9 @@
$FreeBSD$
---- channels/chan_sip.c.orig Thu Jan 12 18:43:37 2006
-+++ channels/chan_sip.c Thu Jan 12 18:50:11 2006
-@@ -336,7 +336,7 @@ static char global_vmexten[AST_MAX_EXTEN
+--- channels/chan_sip.c.orig Tue Jan 24 16:25:53 2006
++++ channels/chan_sip.c Tue Jan 24 16:30:44 2006
+@@ -337,7 +337,7 @@ static char global_vmexten[AST_MAX_EXTEN
static char default_language[MAX_LANGUAGE] = "";
@@ -12,7 +12,7 @@ $FreeBSD$
static char default_callerid[AST_MAX_EXTENSION] = DEFAULT_CALLERID;
static char default_fromdomain[AST_MAX_EXTENSION] = "";
-@@ -474,6 +474,7 @@ struct sip_invite_param {
+@@ -475,6 +475,7 @@ struct sip_invite_param {
struct sip_route {
struct sip_route *next;
@@ -20,7 +20,7 @@ $FreeBSD$
char hop[0];
};
-@@ -5993,6 +5994,7 @@ static void build_route(struct sip_pvt *
+@@ -6015,6 +6016,7 @@ static void build_route(struct sip_pvt *
/* Make a struct route */
thishop = malloc(sizeof(*thishop) + len);
if (thishop) {
@@ -28,7 +28,7 @@ $FreeBSD$
ast_copy_string(thishop->hop, rr, len);
ast_log(LOG_DEBUG, "build_route: Record-Route hop: <%s>\n", thishop->hop);
/* Link in */
-@@ -6018,31 +6020,41 @@ static void build_route(struct sip_pvt *
+@@ -6040,31 +6042,41 @@ static void build_route(struct sip_pvt *
/* Only append the contact if we are dealing with a strict router */
if (!head || (!ast_strlen_zero(head->hop) && strstr(head->hop,";lr") == NULL) ) {
@@ -94,7 +94,7 @@ $FreeBSD$
}
}
}
-@@ -10336,7 +10348,11 @@ static int handle_request_invite(struct
+@@ -10352,7 +10364,11 @@ static int handle_request_invite(struct
gotdest = get_destination(p, NULL);
get_rdnis(p, NULL);
@@ -107,7 +107,7 @@ $FreeBSD$
build_contact(p);
if (gotdest) {
-@@ -10364,7 +10380,6 @@ static int handle_request_invite(struct
+@@ -10380,7 +10396,6 @@ static int handle_request_invite(struct
c = sip_new(p, AST_STATE_DOWN, ast_strlen_zero(p->username) ? NULL : p->username );
*recount = 1;
/* Save Record-Route for any later requests we make on this dialogue */
@@ -115,15 +115,15 @@ $FreeBSD$
if (c) {
/* Pre-lock the call */
ast_mutex_lock(&c->lock);
-@@ -10450,6 +10465,13 @@ static int handle_request_invite(struct
+@@ -10466,7 +10481,12 @@ static int handle_request_invite(struct
transmit_response(p, "180 Ringing", req);
break;
case AST_STATE_UP:
+- /* Here we have reINVITE request - try to renegotiate codecs with */
+ /* Assuming this to be reinvite, process new SDP portion */
+ if (!ast_strlen_zero(get_header(req, "Content-Type"))) {
+ process_sdp(p, req);
+ } else {
-+ p->jointcapability = p->capability;
+ ast_log(LOG_DEBUG, "Hm.... No sdp for the moment\n");
+ }
transmit_response_with_sdp(p, "200 OK", req, 1);
diff --git a/net/asterisk16/files/patch-codecs::gsm::Makefile b/net/asterisk16/files/patch-codecs::gsm::Makefile
index 35ca91877553..7256eeae5692 100644
--- a/net/asterisk16/files/patch-codecs::gsm::Makefile
+++ b/net/asterisk16/files/patch-codecs::gsm::Makefile
@@ -1,14 +1,15 @@
$FreeBSD$
---- codecs/gsm/Makefile
+--- codecs/gsm/Makefile.orig
+++ codecs/gsm/Makefile
@@ -49,7 +49,9 @@
ifneq (${PROC},arm)
ifneq (${PROC},ppc)
ifneq (${PROC},ppc64)
+-OPTIMIZE+=-march=$(PROC)
+ifneq (${PROC},amd64)
- OPTIMIZE+=-march=$(PROC)
++#OPTIMIZE+=-march=$(PROC)
+endif
endif
endif
diff --git a/net/asterisk16/files/patch-frame.c b/net/asterisk16/files/patch-frame.c
new file mode 100644
index 000000000000..753253c7af0d
--- /dev/null
+++ b/net/asterisk16/files/patch-frame.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- frame.c.orig Wed Jan 25 13:22:43 2006
++++ frame.c Wed Jan 25 13:21:25 2006
+@@ -1170,7 +1170,7 @@ static int g723_len(unsigned char buf)
+ {
+ switch(buf & TYPE_MASK) {
+ case TYPE_DONTSEND:
+- return 0;
++ return 2;
+ break;
+ case TYPE_SILENCE:
+ return 4;