aboutsummaryrefslogtreecommitdiff
path: root/net/avahi
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-06-10 19:14:04 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-06-10 19:14:04 +0000
commite4292daeb9cefcc391a2fba5f5348b191fcda7bf (patch)
treef750af0429592d367938221901bd6a4476e39ad7 /net/avahi
parent7ca10f0fe04fd4ca8f0a82f037bc03c8a2bf36d6 (diff)
downloadports-e4292daeb9cefcc391a2fba5f5348b191fcda7bf.tar.gz
ports-e4292daeb9cefcc391a2fba5f5348b191fcda7bf.zip
Make libdns (aka mDNSResponder) support optional (defaulting to off).
Note: enabling this will add a conflict to mDNSResponder which may interfere with KDE applications. PR: 98566 Submitted by: Kirk Strauser <kirk@strauser.com> (with modifications)
Notes
Notes: svn path=/head/; revision=165043
Diffstat (limited to 'net/avahi')
-rw-r--r--net/avahi/Makefile12
-rw-r--r--net/avahi/pkg-plist7
2 files changed, 18 insertions, 1 deletions
diff --git a/net/avahi/Makefile b/net/avahi/Makefile
index 192e76fe7200..3e6018853ff5 100644
--- a/net/avahi/Makefile
+++ b/net/avahi/Makefile
@@ -48,7 +48,8 @@ MAN1= avahi-browse-domains.1 avahi-browse.1 avahi-publish-address.1 \
MAN5= avahi-daemon.conf.5 avahi.service.5 avahi.hosts.5
MAN8= avahi-daemon.8 avahi-dnsconfd.8 avahi-dnsconfd.action.8
-OPTIONS= GTK2 "Build a GTK+ 2 browser utility" off
+OPTIONS= GTK2 "Build a GTK+ 2 browser utility" off \
+ LIBDNS "Enable mDNSResponder compatibility" off
.endif
.include <bsd.port.pre.mk>
@@ -58,6 +59,15 @@ OPTIONS= GTK2 "Build a GTK+ 2 browser utility" off
IGNORE= does not work on FreeBSD 4.X
.endif
+.if defined(WITH_LIBDNS)
+CONFIGURE_ARGS+=--enable-compat-libdns_sd
+PLIST_SUB+= LIBDNS=""
+CONFLICTS+= mDNSResponder-[0-9]*
+.else
+CONFIGURE_ARGS+=--disable-compat-libdns_sd
+PLIST_SUB+= LIBDNS="@comment "
+.endif
+
.if defined(WITH_GTK2)
USE_GNOME+= libglade2
PLIST_SUB+= GTK=""
diff --git a/net/avahi/pkg-plist b/net/avahi/pkg-plist
index e915b774b247..386904b8f0c5 100644
--- a/net/avahi/pkg-plist
+++ b/net/avahi/pkg-plist
@@ -51,6 +51,7 @@ include/avahi-compat-howl/salt/salt.h
include/avahi-compat-howl/salt/signal.h
include/avahi-compat-howl/salt/socket.h
include/avahi-compat-howl/salt/time.h
+%%LIBDNS%%include/avahi-compat-libdns_sd/dns_sd.h
include/avahi-core/core.h
include/avahi-core/log.h
include/avahi-core/lookup.h
@@ -74,12 +75,17 @@ lib/libavahi-glib.a
lib/libavahi-glib.la
lib/libavahi-glib.so
lib/libavahi-glib.so.1
+%%LIBDNS%%lib/libdns_sd.a
+%%LIBDNS%%lib/libdns_sd.la
+%%LIBDNS%%lib/libdns_sd.so
+%%LIBDNS%%lib/libdns_sd.so.1
lib/libhowl.a
lib/libhowl.la
lib/libhowl.so
lib/libhowl.so.0
libdata/pkgconfig/avahi-client.pc
libdata/pkgconfig/avahi-compat-howl.pc
+%%LIBDNS%%libdata/pkgconfig/avahi-compat-libdns_sd.pc
libdata/pkgconfig/avahi-core.pc
libdata/pkgconfig/avahi-glib.pc
sbin/avahi-daemon
@@ -101,6 +107,7 @@ sbin/avahi-dnsconfd
@dirrm %%DATADIR%%
@dirrm include/avahi-glib
@dirrm include/avahi-core
+%%LIBDNS%%@dirrm include/avahi-compat-libdns_sd
@dirrm include/avahi-compat-howl/salt
@dirrm include/avahi-compat-howl/rendezvous
@dirrm include/avahi-compat-howl/discovery