aboutsummaryrefslogtreecommitdiff
path: root/net/balance
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-06-16 07:05:56 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-06-16 07:05:56 +0000
commitdfdc9f71ed1243d3ce7dd334f38260c0baf813b1 (patch)
tree38f08bf40f4445bed3281fd68455f06fa672a4d5 /net/balance
parent7529b972a25fda0ca713dfe71b6df7a9c1efae3f (diff)
downloadports-dfdc9f71ed1243d3ce7dd334f38260c0baf813b1.tar.gz
ports-dfdc9f71ed1243d3ce7dd334f38260c0baf813b1.zip
update to version 3.15
PR: 66939 Submitted by: Marc Silver <marcs@draenor.org> Approved by: maintainer timeout (4 weeks)
Notes
Notes: svn path=/head/; revision=111571
Diffstat (limited to 'net/balance')
-rw-r--r--net/balance/Makefile13
-rw-r--r--net/balance/distinfo4
-rw-r--r--net/balance/files/patch-Makefile20
-rw-r--r--net/balance/pkg-plist2
4 files changed, 29 insertions, 10 deletions
diff --git a/net/balance/Makefile b/net/balance/Makefile
index 43bea1a767ba..893d97d0def0 100644
--- a/net/balance/Makefile
+++ b/net/balance/Makefile
@@ -6,24 +6,20 @@
#
PORTNAME= balance
-PORTVERSION= 3.11
+PORTVERSION= 3.15
CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED} \
+ http://www.inlab.de/
MASTER_SITE_SUBDIR= balance
MAINTAINER= joseph@randomnetworks.com
COMMENT= Simple but powerful generic tcp proxy with round robin features
ALL_TARGET= balance
-USE_REINPLACE= yes
USE_RC_SUBR= yes
-MAN1= balance.1
-
-post-patch:
- ${REINPLACE_CMD} -e 's|^CFLAGS|#CFLAGS|g ; \
- s|^CC|#CC|g' ${WRKSRC}/Makefile
+MAN1= balance.1
post-build:
@${SED} -e 's,%%RC_SUBR%%,${RC_SUBR},g' -e 's,%%PREFIX%%,${PREFIX},g' \
@@ -33,5 +29,6 @@ do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/balance ${PREFIX}/bin
@${INSTALL_MAN} ${WRKSRC}/balance.1 ${PREFIX}/man/man1
@${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/etc/rc.d/${PORTNAME}.sh
+ @${MKDIR} /var/run/balance
.include <bsd.port.mk>
diff --git a/net/balance/distinfo b/net/balance/distinfo
index a35186071273..c8a6f4bcb7c3 100644
--- a/net/balance/distinfo
+++ b/net/balance/distinfo
@@ -1,2 +1,2 @@
-MD5 (balance-3.11.tar.gz) = 69e72ccbcb3d397d569487e85663c01a
-SIZE (balance-3.11.tar.gz) = 20917
+MD5 (balance-3.15.tar.gz) = c13392db7fdab2e80e1da6b469abf2a0
+SIZE (balance-3.15.tar.gz) = 21022
diff --git a/net/balance/files/patch-Makefile b/net/balance/files/patch-Makefile
new file mode 100644
index 000000000000..1a56763ec1df
--- /dev/null
+++ b/net/balance/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig Wed Jun 16 08:50:09 2004
++++ Makefile Wed Jun 16 08:50:44 2004
+@@ -1,7 +1,7 @@
+ # $Id: Makefile,v 1.13 2004/05/27 12:23:05 tommy Exp tommy $
+
+ #CFLAGS=-g -I.
+-CFLAGS=-O2 -Wall
++CFLAGS+=-Wall
+
+ # uncomment for Solaris:
+ # LIBRARIES=-lsocket -lnsl
+@@ -15,7 +15,7 @@
+ # BALANCE=balance.exe
+ # ROOT=Administrators
+
+-CC=gcc
++CC?=gcc
+ RELEASE=3.15
+
+ balance: balance.c butils.o balance.h
diff --git a/net/balance/pkg-plist b/net/balance/pkg-plist
index aae93de48847..23c18c8b3c9f 100644
--- a/net/balance/pkg-plist
+++ b/net/balance/pkg-plist
@@ -1,2 +1,4 @@
bin/balance
etc/rc.d/balance.sh
+@exec mkdir /var/run/balance
+@unexec rmdir /var/run/balance 2>/dev/null || true