aboutsummaryrefslogtreecommitdiff
path: root/net/bird
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-06-28 07:58:08 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-06-28 07:58:08 +0000
commitcd7fd17a20deb6d12bbe270b443baa2294f8d4ad (patch)
tree992ac13747bb3a32a03d5c849b779f1b681d4259 /net/bird
parent9931f0fc7e3f06a90c89b23f529b7b8201f846db (diff)
downloadports-cd7fd17a20deb6d12bbe270b443baa2294f8d4ad.tar.gz
ports-cd7fd17a20deb6d12bbe270b443baa2294f8d4ad.zip
- Update to 1.2.3
- Provide ports for both ipv4 and ipv6 reincarnation Submitted by: Jiri Kubicek <jiri.kubicek@kraxnet.cz> Feature safe: yes
Notes
Notes: svn path=/head/; revision=257096
Diffstat (limited to 'net/bird')
-rw-r--r--net/bird/Makefile11
-rw-r--r--net/bird/distinfo6
-rw-r--r--net/bird/files/bird.in32
-rw-r--r--net/bird/files/patch-sysdep-unix-krt.c10
-rw-r--r--net/bird/pkg-descr5
-rw-r--r--net/bird/pkg-plist10
6 files changed, 50 insertions, 24 deletions
diff --git a/net/bird/Makefile b/net/bird/Makefile
index 6f5bd444bfb0..b50fddeec53f 100644
--- a/net/bird/Makefile
+++ b/net/bird/Makefile
@@ -6,23 +6,24 @@
#
PORTNAME= bird
-PORTVERSION= 1.2.1
+PORTVERSION= 1.2.3
CATEGORIES= net
MASTER_SITES= ftp://bird.network.cz/pub/bird/
MAINTAINER= pav@FreeBSD.org
-COMMENT= Dynamic IP routing daemon
+COMMENT= Dynamic IP routing daemon (IPv4 version)
USE_BISON= build
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-ipv6
MAKE_JOBS_UNSAFE= yes
+USE_RC_SUBR= bird
+
post-install:
- @if [ ! -f ${PREFIX}/etc/bird6.conf ]; then \
- ${CP} -p ${PREFIX}/etc/bird6.conf.example ${PREFIX}/etc/bird6.conf ; \
+ @if [ ! -f ${PREFIX}/etc/bird.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/bird.conf.example ${PREFIX}/etc/bird.conf ; \
fi
.include <bsd.port.mk>
diff --git a/net/bird/distinfo b/net/bird/distinfo
index be6bec3115f3..85f04f302afc 100644
--- a/net/bird/distinfo
+++ b/net/bird/distinfo
@@ -1,3 +1,3 @@
-MD5 (bird-1.2.1.tar.gz) = e158bd0a72e345841e39764975ee1d21
-SHA256 (bird-1.2.1.tar.gz) = 72d07e28a997b59136b6ccc084c82ad86c0572a8fca709bdeb1acc922f768fe9
-SIZE (bird-1.2.1.tar.gz) = 760026
+MD5 (bird-1.2.3.tar.gz) = bf1f4b24627050eead1dceb8c1fd24c3
+SHA256 (bird-1.2.3.tar.gz) = 503f25ef676c320be3db90b69b8a78da8fda4dc2d640d3aa9dbfae0cb4e66273
+SIZE (bird-1.2.3.tar.gz) = 865144
diff --git a/net/bird/files/bird.in b/net/bird/files/bird.in
new file mode 100644
index 000000000000..68dc9bd27141
--- /dev/null
+++ b/net/bird/files/bird.in
@@ -0,0 +1,32 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: bird
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# bird_enable (bool): Set to NO by default.
+# Set it to YES to enable bird.
+# bird_config (path): Set to %%PREFIX%%/etc/bird.conf
+# by default.
+#
+
+. /etc/rc.subr
+
+name="bird"
+rcvar=${name}_enable
+
+command=%%PREFIX%%/sbin/${name}
+
+load_rc_config $name
+
+: ${bird_enable="NO"}
+: ${bird_config="%%PREFIX%%/etc/bird.conf"}
+
+command_args="-c $bird_config"
+
+run_rc_command "$1"
diff --git a/net/bird/files/patch-sysdep-unix-krt.c b/net/bird/files/patch-sysdep-unix-krt.c
deleted file mode 100644
index 94e0a966353e..000000000000
--- a/net/bird/files/patch-sysdep-unix-krt.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- sysdep/unix/krt.c.orig Mon Jun 7 18:51:23 2004
-+++ sysdep/unix/krt.c Thu May 12 20:41:53 2005
-@@ -639,6 +639,7 @@
- return;
- }
- #endif
-+ ;
- }
- rte_free(e);
- }
diff --git a/net/bird/pkg-descr b/net/bird/pkg-descr
index 5ae9826f66b5..04fcd78e58ca 100644
--- a/net/bird/pkg-descr
+++ b/net/bird/pkg-descr
@@ -4,8 +4,11 @@ The BIRD project aims to develop a fully functional dynamic IP routing daemon.
- Multiple routing tables
- BGP
- RIP
-- OSPF (IPv4 only)
+- OSPF
- Static routes
- Inter-table protocol
+- Command-line interface
+- Soft reconfiguration
+- Powerful language for route filtering
WWW: http://bird.network.cz/
diff --git a/net/bird/pkg-plist b/net/bird/pkg-plist
index 197fad3d7053..ec18be838b66 100644
--- a/net/bird/pkg-plist
+++ b/net/bird/pkg-plist
@@ -1,5 +1,5 @@
-@unexec if cmp -s %D/etc/bird6.conf.example %D/etc/bird6.conf; then rm -f %D/etc/bird6.conf; fi
-etc/bird6.conf.example
-@exec if [ ! -f %D/etc/bird6.conf ] ; then cp -p %D/%F %B/bird6.conf; fi
-sbin/bird6
-sbin/birdc6
+@unexec if cmp -s %D/etc/bird.conf.example %D/etc/bird.conf; then rm -f %D/etc/bird.conf; fi
+etc/bird.conf.example
+@exec if [ ! -f %D/etc/bird.conf ] ; then cp -p %D/%F %B/bird.conf; fi
+sbin/bird
+sbin/birdc