aboutsummaryrefslogtreecommitdiff
path: root/net/coda6_server
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2004-08-10 17:06:15 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2004-08-10 17:06:15 +0000
commite662720ff2e26fb4caa09dba2d795ede7a7f06bc (patch)
tree55e09ee18ae36b4a79581d85b8e0e8cabc9e7edd /net/coda6_server
parent39fd96c88a2ac3d8b287333e0c9cb22e13a6cbeb (diff)
downloadports-e662720ff2e26fb4caa09dba2d795ede7a7f06bc.tar.gz
ports-e662720ff2e26fb4caa09dba2d795ede7a7f06bc.zip
Update coda5*- and coda6*-affiliated software.
Fix build under fresh -CURRENT (gcc 3.4.2). Bump or remove PORTREVISION where it needed.
Notes
Notes: svn path=/head/; revision=115848
Diffstat (limited to 'net/coda6_server')
-rw-r--r--net/coda6_server/Makefile5
-rw-r--r--net/coda6_server/distinfo4
-rw-r--r--net/coda6_server/files/patch-coda-src-venus-comm.cc11
-rw-r--r--net/coda6_server/files/patch-coda-src-venus-fso.h32
-rw-r--r--net/coda6_server/pkg-plist1
5 files changed, 48 insertions, 5 deletions
diff --git a/net/coda6_server/Makefile b/net/coda6_server/Makefile
index e63e46d3b778..7523b4ac47d0 100644
--- a/net/coda6_server/Makefile
+++ b/net/coda6_server/Makefile
@@ -6,7 +6,6 @@
PORTNAME= coda
PORTVERSION= ${CODA_VERSION}
-PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ftp://ftp.coda.cs.cmu.edu/pub/coda/src/
PKGNAMESUFFIX= -${CODA_SUITE}
@@ -17,7 +16,7 @@ COMMENT= Server programs for a replicated high-performance network file system
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
lwp.2:${PORTSDIR}/devel/lwp \
- rpc2.4:${PORTSDIR}/devel/rpc2 \
+ rpc2.6:${PORTSDIR}/devel/rpc2 \
rvm.2:${PORTSDIR}/devel/rvm
CONFLICTS= coda-server-5.*
@@ -30,7 +29,7 @@ USE_GMAKE= yes
CONFIGURE_ARGS?= --sysconfdir=${PREFIX}/etc/rc.d
CODA_SUITE?= server
-CODA_VERSION?= 6.0.2
+CODA_VERSION?= 6.0.6
.include <bsd.port.pre.mk>
diff --git a/net/coda6_server/distinfo b/net/coda6_server/distinfo
index 67c1f5b9e06a..63a6c7c77daf 100644
--- a/net/coda6_server/distinfo
+++ b/net/coda6_server/distinfo
@@ -1,2 +1,2 @@
-MD5 (coda-6.0.2.tar.gz) = bb3b98c3302e0d5a2a9d16e88055838c
-SIZE (coda-6.0.2.tar.gz) = 1487309
+MD5 (coda-6.0.6.tar.gz) = 1feb4b431b72f725b568cc57a759714f
+SIZE (coda-6.0.6.tar.gz) = 1497287
diff --git a/net/coda6_server/files/patch-coda-src-venus-comm.cc b/net/coda6_server/files/patch-coda-src-venus-comm.cc
new file mode 100644
index 000000000000..08745c321fee
--- /dev/null
+++ b/net/coda6_server/files/patch-coda-src-venus-comm.cc
@@ -0,0 +1,11 @@
+--- coda-src/venus/comm.cc.orig Fri Aug 6 23:01:08 2004
++++ coda-src/venus/comm.cc Fri Aug 6 23:02:04 2004
+@@ -173,7 +173,7 @@
+ sei.AckPoint = sftp_ackpoint;
+ sei.PacketSize = sftp_packetsize;
+ sei.EnforceQuota = 1;
+- sei.Port.Tag = (enum PortTag)0;
++ sei.Port.Tag = (PortTag)0;
+ SFTP_Activate(&sei);
+
+ /* RPC2 initialization. */
diff --git a/net/coda6_server/files/patch-coda-src-venus-fso.h b/net/coda6_server/files/patch-coda-src-venus-fso.h
new file mode 100644
index 000000000000..e416579b5a96
--- /dev/null
+++ b/net/coda6_server/files/patch-coda-src-venus-fso.h
@@ -0,0 +1,32 @@
+--- coda-src/venus/fso.h.orig Fri Aug 6 22:52:18 2004
++++ coda-src/venus/fso.h Fri Aug 6 22:54:34 2004
+@@ -539,7 +539,7 @@
+ void DetachHdbBindings();
+ void DetachHdbBinding(binding *, int =0);
+ int PredetermineFetchState(int, int);
+- void SetFetchAllowed(enum HoardFetchState new_state)
++ void SetFetchAllowed(HoardFetchState new_state)
+ { FetchAllowed = new_state; }
+ int IsFetchAllowed()
+ { if (FetchAllowed == HF_Fetch)
+@@ -547,7 +547,7 @@
+ else
+ return 0;
+ }
+- void SetAskingAllowed(enum HoardAskState new_state)
++ void SetAskingAllowed(HoardAskState new_state)
+ { AskingAllowed = new_state; }
+ int IsAskingAllowed()
+ { if (AskingAllowed == HA_Ask)
+@@ -820,9 +820,8 @@
+ #define CFSOP_PRELUDE(str, comp, fid)\
+ {\
+ char buf[256];\
+- strcpy(buf, (comp));\
+- if (buf[0] == '\0')\
+- sprintf(buf, "%s", FID_(&(fid)));\
++ if (comp) strcpy(buf, (comp));\
++ else sprintf(buf, "%s", FID_(&(fid)));\
+ MarinerLog((str), buf);\
+ }
+ #define CFSOP_POSTLUDE(str)\
diff --git a/net/coda6_server/pkg-plist b/net/coda6_server/pkg-plist
index e7866bdd655c..e9aa2405b6d8 100644
--- a/net/coda6_server/pkg-plist
+++ b/net/coda6_server/pkg-plist
@@ -3,6 +3,7 @@ bin/norton-reinit
bin/reinit
bin/getvolinfo
bin/rpc2ping
+bin/rvmsizer
bin/smon2
etc/coda/server.conf.ex
@dirrm etc/coda