aboutsummaryrefslogtreecommitdiff
path: root/net/dante
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /net/dante
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'net/dante')
-rw-r--r--net/dante/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/dante/Makefile b/net/dante/Makefile
index b2c6414fd304..dd5539763bad 100644
--- a/net/dante/Makefile
+++ b/net/dante/Makefile
@@ -21,8 +21,8 @@ CONFLICTS= socks5-[0-9]*
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-socks-conf=${PREFIX}/etc/socks.conf \
--with-sockd-conf=${PREFIX}/etc/sockd.conf
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
USE_LDCONFIG= yes