aboutsummaryrefslogtreecommitdiff
path: root/net/dctc
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-10-05 17:20:14 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-10-05 17:20:14 +0000
commita71a8936a009799ec34cdc84ce34b472c7ecd1b3 (patch)
tree7ec13d377b16bfd476dd544ac2258d5b2d5a0437 /net/dctc
parent5ce8631e75dcca0355bfddb52cd6958f7edd43f0 (diff)
downloadports-a71a8936a009799ec34cdc84ce34b472c7ecd1b3.tar.gz
ports-a71a8936a009799ec34cdc84ce34b472c7ecd1b3.zip
o Update to 0.83.5
o Add hack to disable use of GNU auto* tools Reviewed by: Munish Chopra <mchopra@engmail.uwaterloo.ca>
Notes
Notes: svn path=/head/; revision=67343
Diffstat (limited to 'net/dctc')
-rw-r--r--net/dctc/Makefile10
-rw-r--r--net/dctc/distinfo2
-rw-r--r--net/dctc/files/patch-src::main.c19
3 files changed, 10 insertions, 21 deletions
diff --git a/net/dctc/Makefile b/net/dctc/Makefile
index 7b25b58dd133..5081ed99d040 100644
--- a/net/dctc/Makefile
+++ b/net/dctc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dctc
-PORTVERSION= 0.83.3
+PORTVERSION= 0.83.5
CATEGORIES= net
MASTER_SITES= http://unixpages.org/distfiles/ \
http://ac2i.tzo.com/dctc/
@@ -62,11 +62,9 @@ post-patch:
.for file in ${DOC_FILES}
@${PERL} -pi -e 's|(hublist)|dc_\1|' ${WRKSRC}/${file}
.endfor
- @${PERL} -pi -e 's/(CK?\(std)(out\))/\1_\2/' ${WRKSRC}/src/*
@${PERL} -pi -e 's/(CK?\()inet_ntoa(\))/\1shared_info\2/' ${WRKSRC}/src/*
@${FIND} ${WRKSRC} -type f | ${XARGS} -n 10 ${PERL} -pi -e \
- 's|include.+<linux/sem.h>|include <sys/ipc.h>\n#include <sys/sem.h>|; \
- s|<(db.h>)|<db4/\1|'
+ 's|<(db.h>)|<db4/\1|'
@${PERL} -pi -e 's|(db)-|\1|g;s|db4.0|db4|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
@${PERL} -pi -e 's|/usr/bin/env perl|${PERL}|' \
@@ -83,6 +81,10 @@ pre-build:
@${ECHO_CMD} '# define ENODATA ENOMSG' >> ${CONFIGURE_WRKSRC}/config.h
@${ECHO_CMD} '#endif' >> ${CONFIGURE_WRKSRC}/config.h
@${ECHO_CMD} '#define HAVE_SYS_PARAM_H 1' >> ${CONFIGURE_WRKSRC}/config.h
+# disable GNU auto* tools
+ @${FIND} ${WRKSRC} -type f -name "Makefile" | ${XARGS} \
+ -n 10 ${REINPLACE_CMD} -E -e \
+ 's! (autoconf|autoheader|automake|aclocal)$$! ${TRUE}!'
do-install:
.ifndef(NOPORTDOCS)
diff --git a/net/dctc/distinfo b/net/dctc/distinfo
index d2570117af55..b77bc434114d 100644
--- a/net/dctc/distinfo
+++ b/net/dctc/distinfo
@@ -1 +1 @@
-MD5 (dctc-0.83.3.tar.gz) = 21faecebda5a19a62859bbf82ef89ee9
+MD5 (dctc-0.83.5.tar.gz) = 5e691001fa203e3ca0ae30a9137d56fd
diff --git a/net/dctc/files/patch-src::main.c b/net/dctc/files/patch-src::main.c
index f3dbf9fc0e51..25a38d699d89 100644
--- a/net/dctc/files/patch-src::main.c
+++ b/net/dctc/files/patch-src::main.c
@@ -1,19 +1,6 @@
---- src/main.c.orig Sun Aug 4 10:58:23 2002
-+++ src/main.c Sun Aug 4 11:00:57 2002
-@@ -34,7 +34,12 @@
- #include <sys/param.h>
- #include <sys/utsname.h>
- #include <sys/un.h>
-+#if !(defined(BSD) && (BSD >= 199103))
- #include <linux/sem.h> /* for the value of SEMVMX */
-+#else
-+#include <sys/ipc.h>
-+#include <sys/sem.h> /* for the value of SEMVMX */
-+#endif
- #include <errno.h>
- #include <getopt.h>
- #include <string.h>
-@@ -1253,6 +1258,7 @@
+--- src/main.c.orig Sun Sep 29 14:07:48 2002
++++ src/main.c Sun Sep 29 14:08:52 2002
+@@ -1269,6 +1269,7 @@
char *virtual_share_path=NULL;