aboutsummaryrefslogtreecommitdiff
path: root/net/ddup
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>2000-02-23 02:52:35 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>2000-02-23 02:52:35 +0000
commit5b7c1e126d97b2fcf3c075497b8d65d22d2f2f77 (patch)
treeec6892a05266b1e62c2282e0cff1e8d19a3ba5f0 /net/ddup
parent214f11c86538859b432e5e4d8d8e3789d4653768 (diff)
downloadports-5b7c1e126d97b2fcf3c075497b8d65d22d2f2f77.tar.gz
ports-5b7c1e126d97b2fcf3c075497b8d65d22d2f2f77.zip
Update to 2.2
PR: 16822 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=26189
Diffstat (limited to 'net/ddup')
-rw-r--r--net/ddup/Makefile33
-rw-r--r--net/ddup/distinfo2
-rw-r--r--net/ddup/pkg-descr5
-rw-r--r--net/ddup/pkg-message10
-rw-r--r--net/ddup/pkg-plist2
5 files changed, 40 insertions, 12 deletions
diff --git a/net/ddup/Makefile b/net/ddup/Makefile
index 4bca60d882c9..684c8b4b74e3 100644
--- a/net/ddup/Makefile
+++ b/net/ddup/Makefile
@@ -6,26 +6,45 @@
# $FreeBSD$
#
-DISTNAME= ddup-2.1
+DISTNAME= ddup-2.2Dm
+PKGNAME= ddup-2.2
CATEGORIES= net
-MASTER_SITES= ftp://gandy.dyndns.org/pub/ddup/ \
- http://www.phix.com/~java/
+MASTER_SITES= ftp://ddup.sourceforge.net/pub/ddup/
MAINTAINER= cjm2@altavista.net
-WRKSRC= ${WRKDIR}/ddup-nic
-
MAN1= ddup.1
MANCOMPRESSED= yes
+WRKSRC= ${WRKDIR}/ddup-2.2Dm
+
+# Uncomment this if you want to enable debugging.
+#DEBUG= -g
+
+pre-build:
+ ${ECHO} "char *file_name = \"${PREFIX}/etc/ddup.conf\";" > ${WRKSRC}/options.h
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${DEBUG} -c ddup.c
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${DEBUG} -c ddup_functions.c
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${DEBUG} -c getopt.c
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${DEBUG} -c getopt1.c
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${DEBUG} -c parse_config.c
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${DEBUG} -c parse_option.c
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${DEBUG} -c update.c
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${DEBUG} -o ddup ddup.o ddup_functions.o getopt.o getopt1.o parse_config.o parse_option.o update.o ${LIBS}
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ddup ${PREFIX}/sbin
${INSTALL_SCRIPT} ${WRKSRC}/testip ${PREFIX}/sbin
- ${INSTALL_MAN} ${WRKSRC}/ddup.1.gz ${MANPREFIX}/man/man1
- ${INSTALL_DATA} ${WRKSRC}/ddup.conf ${PREFIX}/etc/ddup.conf.default
+ ${INSTALL_MAN} ${WRKSRC}/ddup.1.gz ${PREFIX}/man/man1
${MKDIR} ${PREFIX}/share/doc/ddup
${INSTALL_MAN} ${WRKSRC}/INSTALL-C ${PREFIX}/share/doc/ddup
${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/ddup
+ ${INSTALL_MAN} ${WRKSRC}/COPYING ${PREFIX}/share/doc/ddup
+
+post-install:
strip ${PREFIX}/sbin/ddup
+ ${CAT} ${PKGDIR}/MESSAGE
.include <bsd.port.mk>
diff --git a/net/ddup/distinfo b/net/ddup/distinfo
index 6024765e6d86..d464c70fa8e1 100644
--- a/net/ddup/distinfo
+++ b/net/ddup/distinfo
@@ -1 +1 @@
-MD5 (ddup-2.1.tar.gz) = 3dd30ae02503b23b47a61e428ac9fdcb
+MD5 (ddup-2.2Dm.tar.gz) = d05ac8fda0409d8e9bb8e964aa94104c
diff --git a/net/ddup/pkg-descr b/net/ddup/pkg-descr
index f10680a619c9..55fcf3853fa2 100644
--- a/net/ddup/pkg-descr
+++ b/net/ddup/pkg-descr
@@ -4,7 +4,6 @@ DD-UP in C by Thomas Gandy (tegandy@enid.com)
DD-UP is a program that is used to update a host
provided by the Free DynDNS service of dyndns.org.
-WWW: http://www.gandy.dyndns.org/~thomas/ddup.shtml
+WWW: http://ddup.sourceforce.net/
-- Chris
-cjm2@altavista.net
+EMAIL: cjm2@altavista.net
diff --git a/net/ddup/pkg-message b/net/ddup/pkg-message
new file mode 100644
index 000000000000..06b265ecad16
--- /dev/null
+++ b/net/ddup/pkg-message
@@ -0,0 +1,10 @@
+********************************************************
+*** If you are upgrading or are a first time user ***
+*** you MUST make your configuration file by typing ***
+*** ddup --makeconf ***
+********************************************************
+********************************************************
+*** If you are upgrading or are a first time user ***
+*** you MUST make your configuration file by typing ***
+*** ddup --makeconf ***
+********************************************************
diff --git a/net/ddup/pkg-plist b/net/ddup/pkg-plist
index b4c57edd3d5f..ddba371de314 100644
--- a/net/ddup/pkg-plist
+++ b/net/ddup/pkg-plist
@@ -1,6 +1,6 @@
-etc/ddup.conf.default
sbin/ddup
sbin/testip
share/doc/ddup/README
share/doc/ddup/INSTALL-C
+share/doc/ddup/COPYING
@dirrm share/doc/ddup