aboutsummaryrefslogtreecommitdiff
path: root/net/dgd-kernel/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2010-04-04 04:43:04 +0000
committerGreg Lewis <glewis@FreeBSD.org>2010-04-04 04:43:04 +0000
commitb5b17ff2b972104f7ef3a01dba58b28e2f4ab282 (patch)
tree6a4791700d4e54c6bd3a2dff22901619fbd19a64 /net/dgd-kernel/Makefile
parentfee0b23d7f55e9e0306803c9c27f702b7469b506 (diff)
downloadports-b5b17ff2b972104f7ef3a01dba58b28e2f4ab282.tar.gz
ports-b5b17ff2b972104f7ef3a01dba58b28e2f4ab282.zip
. Split the kernel mudlib out of the main dgd port and into its own
separate port (dgd-kernel) to put it on an equal footing with the other mudlib port (dgd-lpmud). This also causes less update churn and reflects the current state of the distributions themselves.
Notes
Notes: svn path=/head/; revision=252175
Diffstat (limited to 'net/dgd-kernel/Makefile')
-rw-r--r--net/dgd-kernel/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/net/dgd-kernel/Makefile b/net/dgd-kernel/Makefile
new file mode 100644
index 000000000000..25b5d82b6256
--- /dev/null
+++ b/net/dgd-kernel/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: dgd-kernel
+# Date created: 2 April 2010
+# Whom: glewis
+#
+# $FreeBSD$
+#
+
+PORTNAME= dgd-kernel
+PORTVERSION= 1.3.3
+CATEGORIES= net games
+MASTER_SITES= http://ftp.dworkin.nl/kernellib/ \
+ http://ftp.dworkin.nl/kernellib/patches/
+DISTNAME= kernellib-${PORTVERSION:S/.3$//}
+
+PATCHFILES= ${PORTVERSION:S/.3$//}-${PORTVERSION:S/.3$//}.1.gz \
+ ${PORTVERSION:S/.3$//}.1-${PORTVERSION:S/.3$//}.2.gz \
+ ${PORTVERSION:S/.3$//}.2-${PORTVERSION:S/.3$//}.3.gz
+
+MAINTAINER= glewis@FreeBSD.org
+COMMENT= Kernel mudlib, for use with DGD
+
+RUN_DEPENDS= ${LOCALBASE}/sbin/dgd:${PORTSDIR}/net/dgd
+
+DIST_SUBDIR= dgd
+WRKSRC= ${WRKDIR}
+NO_BUILD= yes
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-patch:
+ cd ${WRKSRC} && ${FIND} . -name '*.orig' -delete
+
+do-configure:
+ ${REINPLACE_CMD} -e "s:%%DATADIR%%:${DATADIR}:" \
+ ${WRKSRC}/kernellib/doc/kernel/kernel.dgd
+
+do-install:
+ @${MKDIR} ${PREFIX}/etc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/kernellib/doc/kernel/kernel.dgd \
+ ${PREFIX}/etc/${PORTNAME}/
+ @${MKDIR} ${DATADIR}/kernel
+.for DIR in include kernel usr
+ @cd ${WRKSRC}/kernellib && ${COPYTREE_SHARE} ${DIR} ${DATADIR}/kernel
+.endfor
+ @# Install an RC script for dgd-kernel
+ @${CAT} ${FILESDIR}/dgd-kernel.sh | ${SED} -e "s:%%PREFIX%%:${PREFIX}:" \
+ -e "s:%%DATADIR%%:${DATADIR}:" > \
+ ${PREFIX}/etc/rc.d/dgd-kernel.sh.sample
+ @${CHMOD} a+x ${PREFIX}/etc/rc.d/dgd-kernel.sh.sample
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/kernellib && ${COPYTREE_SHARE} doc ${DOCSDIR}
+.endif
+
+post-install:
+ @# Need a temporary directory for certain files
+ @${MKDIR} ${DATADIR}/tmp
+ @# Set mudlib ownership
+ -@${CHOWN} -h -R mud:mud ${DATADIR}
+
+.include <bsd.port.mk>