aboutsummaryrefslogtreecommitdiff
path: root/net/dgd/files
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2009-07-04 05:39:52 +0000
committerGreg Lewis <glewis@FreeBSD.org>2009-07-04 05:39:52 +0000
commitf3085670575ea5820cc1b8852b70a3b1cca68fc0 (patch)
tree637611e9aa71f51e7beeed5aef1ceb126dfebb7b /net/dgd/files
parenta033bd2c88ab21de2698e5fbf1681f86d82ec11d (diff)
downloadports-f3085670575ea5820cc1b8852b70a3b1cca68fc0.tar.gz
ports-f3085670575ea5820cc1b8852b70a3b1cca68fc0.zip
. Update to DGD 1.3.
Notes
Notes: svn path=/head/; revision=237070
Diffstat (limited to 'net/dgd/files')
-rw-r--r--net/dgd/files/dgd.sh2
-rw-r--r--net/dgd/files/patch-comp.c75
-rw-r--r--net/dgd/files/patch-mud.dgd10
-rw-r--r--net/dgd/files/patch-src-Makefile (renamed from net/dgd/files/patch-aa)20
4 files changed, 22 insertions, 85 deletions
diff --git a/net/dgd/files/dgd.sh b/net/dgd/files/dgd.sh
index 832bd9a4f03b..941688b47a61 100644
--- a/net/dgd/files/dgd.sh
+++ b/net/dgd/files/dgd.sh
@@ -11,7 +11,7 @@ case "$1" in
start)
if [ -x "${DGD}" ]; then
su ${DGD_USER} -c "${DGD} ${DGD_CONF}" >> "${DGD_LOG}" 2>&1 &
- echo $(($!+1)) > "${DGD_PID}"
+ echo $(($!+2)) > "${DGD_PID}"
echo -n ' dgd'
fi
;;
diff --git a/net/dgd/files/patch-comp.c b/net/dgd/files/patch-comp.c
index cb23188eb861..42e2c320c7db 100644
--- a/net/dgd/files/patch-comp.c
+++ b/net/dgd/files/patch-comp.c
@@ -1,74 +1,19 @@
---- src/comp/comp.c.orig Tue Sep 2 10:58:56 2003
-+++ src/comp/comp.c Tue Sep 2 11:14:29 2003
-@@ -558,6 +558,20 @@
- return TRUE;
+$FreeBSD$
+
+--- src/comp/comp.c.orig 2009-07-03 21:10:25.000000000 -0700
++++ src/comp/comp.c 2009-07-03 21:12:26.000000000 -0700
+@@ -699,6 +699,14 @@
+ return (string *) NULL;
}
+#ifdef NETWORK_PACKAGE
-+/*
-+ * NAME: comm->openport()
-+ * DESCRIPTION: pretend to open a port
-+ */
-+void comm_openport(f, obj, protocol, portnr)
-+frame *f;
++bool comm_is_connection(obj)
+object *obj;
-+unsigned char protocol;
-+unsigned short portnr;
+{
++ return FALSE;
+}
+#endif
+
/*
- * NAME: comm->finish()
- * DESCRIPTION: pretend to terminate connections
-@@ -585,6 +599,35 @@
- return 0;
- }
-
-+#ifdef NETWORK_PACKAGE
-+/*
-+ * NAME: comm->connect()
-+ * DESCRIPTION: pretend to open a connection to a port
-+ */
-+void
-+comm_connect(f, obj, addr, protocol, port)
-+frame *f;
-+object *obj;
-+char *addr;
-+unsigned char protocol;
-+unsigned short port;
-+{
-+}
-+
-+/*
-+ * NAME: comm->senddatagram()
-+ * DESCRIPTION: pretend to send a UDP datagram
-+ */
-+int comm_senddatagram(obj, str, ip, port)
-+object * obj;
-+string * str;
-+string * ip;
-+int port;
-+{
-+ return 0;
-+}
-+#endif
-+
- /*
- * NAME: comm->udpsend()
- * DESCRIPTION: pretend to send a message on the UDP channel of a connection
-@@ -668,8 +711,14 @@
- * NAME: comm->users()
- * DESCRIPTION: pretend to return an array with all user objects
- */
-+#ifdef NETWORK_PACKAGE
-+array *comm_users(data, ports)
-+dataspace *data;
-+bool ports;
-+#else
- array *comm_users(data)
- dataspace *data;
-+#endif
- {
- return (array *) NULL;
- }
+ * NAME: comm->close()
+ * DESCRIPTION: pretend to remove a user
diff --git a/net/dgd/files/patch-mud.dgd b/net/dgd/files/patch-mud.dgd
index 27b7535880f8..8cb2e73831a3 100644
--- a/net/dgd/files/patch-mud.dgd
+++ b/net/dgd/files/patch-mud.dgd
@@ -1,12 +1,8 @@
$FreeBSD$
---- mud.dgd.orig Thu Mar 4 13:54:52 1999
-+++ mud.dgd Thu Aug 28 14:54:26 2003
-@@ -1,10 +1,10 @@
- telnet_port = 6047; /* telnet port number */
- binary_port = 6048; /* binary port number */
--directory = "/home/dworkin/dgd/mud";/* base directory (MUST be absolute) */
-+directory = "%%DATADIR%%/kernel"; /* base directory (MUST be absolute) */
+--- mud.dgd.orig 2003-12-30 18:58:57.000000000 -0800
++++ mud.dgd 2009-05-24 22:28:04.000000000 -0700
+@@ -4,7 +4,7 @@
users = 40; /* max # of users */
editors = 40; /* max # of editor sessions */
ed_tmpfile = "../tmp/ed"; /* proto editor tmpfile */
diff --git a/net/dgd/files/patch-aa b/net/dgd/files/patch-src-Makefile
index 6b66c026ea3a..d382607f0bfd 100644
--- a/net/dgd/files/patch-aa
+++ b/net/dgd/files/patch-src-Makefile
@@ -1,25 +1,21 @@
$FreeBSD$
---- src/Makefile.orig Mon Aug 26 07:21:20 2002
-+++ src/Makefile Mon Aug 26 09:24:19 2002
-@@ -3,13 +3,12 @@
- #
- HOST= NETBSD
- DEFINES=-D$(HOST) #-DDUMP_FUNCS
--DEBUG= -O2
- CCFLAGS=$(DEFINES) $(DEBUG)
--CFLAGS= -I. -Icomp -Ilex -Ied -Iparser -Ikfun $(CCFLAGS)
-+CFLAGS+= -I. -Icomp -Ilex -Ied -Iparser -Ikfun $(CCFLAGS)
+--- src/Makefile.orig 2009-07-03 17:24:28.000000000 -0700
++++ src/Makefile 2009-07-03 17:26:10.000000000 -0700
+@@ -8,9 +8,9 @@
LDFLAGS=
LIBS=
LINTFLAGS=-abcehpruz
-CC= gcc
+CC?= gcc
LD= $(CC)
- DMAKE= make
+-DMAKE= make
++DMAKE= $(MAKE)
YACC= yacc
+ BIN= ../bin
+
@@ -22,6 +21,8 @@
- COMPOBJ=alloc.o error.o hash.o path.o str.o array.o object.o data.o \
+ COMPOBJ=alloc.o error.o hash.o path.o str.o array.o object.o sdata.o data.o \
interpret.o config.o
+all: a.out comp/a.out