aboutsummaryrefslogtreecommitdiff
path: root/net/dhcp6
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-10-16 21:26:50 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-10-16 21:26:50 +0000
commitb0a6cb19d88baa289d354f95f386ed6b0297ecd8 (patch)
treed03d1ce8d3e6544a151a4594cbdd0b486e466d11 /net/dhcp6
parent9001af3ee7f15169614ebf3a61e9c07e35a53abd (diff)
downloadports-b0a6cb19d88baa289d354f95f386ed6b0297ecd8.tar.gz
ports-b0a6cb19d88baa289d354f95f386ed6b0297ecd8.zip
Add STAGEDIR support.
Notes
Notes: svn path=/head/; revision=330545
Diffstat (limited to 'net/dhcp6')
-rw-r--r--net/dhcp6/Makefile17
-rw-r--r--net/dhcp6/files/patch-Makefile.in23
-rw-r--r--net/dhcp6/pkg-plist6
3 files changed, 37 insertions, 9 deletions
diff --git a/net/dhcp6/Makefile b/net/dhcp6/Makefile
index 2d9c33c210bd..a5ce46279462 100644
--- a/net/dhcp6/Makefile
+++ b/net/dhcp6/Makefile
@@ -15,25 +15,24 @@ LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc --with-localdbdir=/var/db
+GNU_CONFIGURE_PREFIX= ${STAGEDIR}${PREFIX}
+MANPREFIX= ${STAGEDIR}${PREFIX}
+CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc \
+ --with-localdbdir=/var/db
USE_RC_SUBR= dhcp6c dhcp6relay dhcp6s
PORTDOCS= README
OPTIONS_DEFINE= DOCS
-MAN5= dhcp6c.conf.5 dhcp6s.conf.5
-MAN8= dhcp6c.8 dhcp6s.8 dhcp6relay.8 dhcp6ctl.8
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-install:
cd ${WRKSRC} && ${INSTALL_DATA} \
- dhcp6c.conf.sample dhcp6s.conf.sample \
- ${PREFIX}/etc
+ dhcp6c.conf.sample dhcp6s.conf.sample \
+ ${STAGEDIR}${PREFIX}/etc
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/net/dhcp6/files/patch-Makefile.in b/net/dhcp6/files/patch-Makefile.in
new file mode 100644
index 000000000000..dffad5476192
--- /dev/null
+++ b/net/dhcp6/files/patch-Makefile.in
@@ -0,0 +1,23 @@
+--- Makefile.in.orig 2013-10-17 05:40:19.000000000 +0900
++++ Makefile.in 2013-10-17 05:40:57.000000000 +0900
+@@ -103,13 +103,13 @@
+
+ install::
+ -mkdir -p $(sbindir) $(mandir)/man5 $(mandir)/man8
+- $(INSTALL_PROGRAM) -s -o $(user) -g $(group) $(TARGET) $(sbindir)
+- $(INSTALL_DATA) -o $(user) -g $(group) dhcp6c.8 $(mandir)/man8
+- $(INSTALL_DATA) -o $(user) -g $(group) dhcp6s.8 $(mandir)/man8
+- $(INSTALL_DATA) -o $(user) -g $(group) dhcp6relay.8 $(mandir)/man8
+- $(INSTALL_DATA) -o $(user) -g $(group) dhcp6ctl.8 $(mandir)/man8
+- $(INSTALL_DATA) -o $(user) -g $(group) dhcp6c.conf.5 $(mandir)/man5
+- $(INSTALL_DATA) -o $(user) -g $(group) dhcp6s.conf.5 $(mandir)/man5
++ $(INSTALL_PROGRAM) $(TARGET) $(sbindir)
++ $(INSTALL_DATA) dhcp6c.8 $(mandir)/man8
++ $(INSTALL_DATA) dhcp6s.8 $(mandir)/man8
++ $(INSTALL_DATA) dhcp6relay.8 $(mandir)/man8
++ $(INSTALL_DATA) dhcp6ctl.8 $(mandir)/man8
++ $(INSTALL_DATA) dhcp6c.conf.5 $(mandir)/man5
++ $(INSTALL_DATA) dhcp6s.conf.5 $(mandir)/man5
+
+ includes::
+
diff --git a/net/dhcp6/pkg-plist b/net/dhcp6/pkg-plist
index 5fe56ba8236b..b54b8a5de26f 100644
--- a/net/dhcp6/pkg-plist
+++ b/net/dhcp6/pkg-plist
@@ -11,3 +11,9 @@ sbin/dhcp6c
sbin/dhcp6relay
sbin/dhcp6s
sbin/dhcp6ctl
+man/man5/dhcp6c.conf.5
+man/man5/dhcp6s.conf.5
+man/man8/dhcp6c.8
+man/man8/dhcp6ctl.8
+man/man8/dhcp6relay.8
+man/man8/dhcp6s.8