aboutsummaryrefslogtreecommitdiff
path: root/net/easysoap
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-07-29 11:49:34 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-07-29 11:49:34 +0000
commit2c39ccb63e1888981b684dfa9a0a92c5ded35f37 (patch)
treeccd1c6f71015397acb87bcc9372917e44a634f97 /net/easysoap
parent3f8aaf4ecdd3482a64a6a711d10d99ab38d764ee (diff)
downloadports-2c39ccb63e1888981b684dfa9a0a92c5ded35f37.tar.gz
ports-2c39ccb63e1888981b684dfa9a0a92c5ded35f37.zip
Update to 0.6
Unbreak on 5.x PR: 53747 Submitted by: Sergey Matveychuk <sem@ciam.ru> Approved by: fjoe (mentor) (implicit) Maintainer timeout: 1 month
Notes
Notes: svn path=/head/; revision=85844
Diffstat (limited to 'net/easysoap')
-rw-r--r--net/easysoap/Makefile16
-rw-r--r--net/easysoap/distinfo2
-rw-r--r--net/easysoap/files/patch-include::SOAPDispatchHandler.h20
-rw-r--r--net/easysoap/files/patch-include::SOAPHashMap.h92
-rw-r--r--net/easysoap/files/patch-include::SOAPParameter.h11
-rw-r--r--net/easysoap/pkg-plist7
6 files changed, 134 insertions, 14 deletions
diff --git a/net/easysoap/Makefile b/net/easysoap/Makefile
index caa0c1fda27d..39c38eda327f 100644
--- a/net/easysoap/Makefile
+++ b/net/easysoap/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= easysoap
-PORTVERSION= 0.5
-PORTREVISION= 2
+PORTVERSION= 0.6
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,18 +20,13 @@ LIB_DEPENDS= expat.4:${PORTSDIR}/textproc/expat2
USE_OPENSSL= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CXXFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lexpat"
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500035
-BROKEN= "Does not compile on 5.0"
-.endif
-
-pre-patch:
- @${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
- ${WRKSRC}/src/abyss/src/data.c
+pre-configure:
+ @echo "CPPFLAGS=${CPPFLAGS} CXXFLAGS=${CXXFLAGS}"
.include <bsd.port.post.mk>
diff --git a/net/easysoap/distinfo b/net/easysoap/distinfo
index 6f0bee6108cd..212351c1af9a 100644
--- a/net/easysoap/distinfo
+++ b/net/easysoap/distinfo
@@ -1 +1 @@
-MD5 (EasySoap++-0.5.tar.gz) = 473e08f8a0a0b0ea598f0fe024611fe9
+MD5 (EasySoap++-0.6.tar.gz) = 9b75efcaf71f615266281ff993ae04b6
diff --git a/net/easysoap/files/patch-include::SOAPDispatchHandler.h b/net/easysoap/files/patch-include::SOAPDispatchHandler.h
new file mode 100644
index 000000000000..865f32000bf5
--- /dev/null
+++ b/net/easysoap/files/patch-include::SOAPDispatchHandler.h
@@ -0,0 +1,20 @@
+--- include/easysoap/SOAPDispatchHandler.h.orig Thu Jun 26 10:06:51 2003
++++ include/easysoap/SOAPDispatchHandler.h Thu Jun 26 10:07:35 2003
+@@ -56,7 +56,7 @@
+ bool ExecuteMethod(const SOAPEnvelope& request, SOAPMethod& response)
+ {
+ const SOAPMethod& method = request.GetBody().GetMethod();
+- DispatchMap::Iterator i = m_dispatchMap.Find(method.GetName());
++ typename DispatchMap::Iterator i = m_dispatchMap.Find(method.GetName());
+ if (i)
+ {
+ T *target= GetTarget(request);
+@@ -100,7 +100,7 @@
+
+ bool HandleHeader(const SOAPParameter& header, SOAPEnvelope& request, SOAPEnvelope& response)
+ {
+- DispatchMap::Iterator i = m_dispatchMap.Find(header.GetName());
++ typename DispatchMap::Iterator i = m_dispatchMap.Find(header.GetName());
+
+ if (i)
+ {
diff --git a/net/easysoap/files/patch-include::SOAPHashMap.h b/net/easysoap/files/patch-include::SOAPHashMap.h
new file mode 100644
index 000000000000..7a1365d1afa2
--- /dev/null
+++ b/net/easysoap/files/patch-include::SOAPHashMap.h
@@ -0,0 +1,92 @@
+--- include/easysoap/SOAPHashMap.h.orig Thu Jun 26 09:58:31 2003
++++ include/easysoap/SOAPHashMap.h Thu Jun 26 10:05:23 2003
+@@ -117,13 +117,13 @@
+ {
+ private:
+ const SOAPHashMap *m_map;
+- Elements::Iterator m_index;
++ typename Elements::Iterator m_index;
+ HashElement *m_he;
+
+ friend class SOAPHashMap<K,I,H,E>;
+
+ // private constuctor that can only be called by SOAPHashMap
+- ForwardHashMapIterator(const SOAPHashMap *map, Elements::Iterator index)
++ ForwardHashMapIterator(const SOAPHashMap *map, typename Elements::Iterator index)
+ : m_map(map), m_index(index), m_he(0)
+ {
+ if (m_map)
+@@ -134,7 +134,7 @@
+ }
+ }
+
+- ForwardHashMapIterator(const SOAPHashMap *map, Elements::Iterator index, HashElement *he)
++ ForwardHashMapIterator(const SOAPHashMap *map, typename Elements::Iterator index, HashElement *he)
+ : m_map(map), m_index(index), m_he(he)
+ {
+ }
+@@ -366,8 +366,8 @@
+ {
+ Clear();
+ Resize(r.GetNumBuckets());
+- SOAPHashMap<A,B,C,D>::Iterator e = r.End();
+- for (SOAPHashMap<A,B,C,D>::Iterator it = r.Begin(); it != e; ++it)
++ typename SOAPHashMap<A,B,C,D>::Iterator e = r.End();
++ for (typename SOAPHashMap<A,B,C,D>::Iterator it = r.Begin(); it != e; ++it)
+ Add(it.Key(), it.Item());
+ }
+ return *this;
+@@ -397,7 +397,7 @@
+ */
+ Iterator Begin() const
+ {
+- return Iterator(this, (Elements::Iterator)m_elements.Begin());
++ return Iterator(this, (typename Elements::Iterator)m_elements.Begin());
+ }
+
+ /**
+@@ -407,7 +407,7 @@
+ */
+ Iterator End() const
+ {
+- return Iterator(this, (Elements::Iterator)m_elements.End());
++ return Iterator(this, (typename Elements::Iterator)m_elements.End());
+ }
+
+
+@@ -491,7 +491,7 @@
+ */
+ void Clear()
+ {
+- for (Elements::Iterator i = m_elements.Begin(); i != m_elements.End(); ++i)
++ for (typename Elements::Iterator i = m_elements.Begin(); i != m_elements.End(); ++i)
+ {
+ HashElement *he = *i;
+ while (he)
+@@ -512,7 +512,7 @@
+ */
+ void Empty()
+ {
+- Elements::Iterator i;
++ typename Elements::Iterator i;
+ for (i = m_elements.Begin(); i != m_elements.End(); ++i)
+ {
+ HashElement *he = *i;
+@@ -588,7 +588,7 @@
+ while (he)
+ {
+ if (he->m_hash == hash && equals(he->m_key, key))
+- return Iterator(this, (Elements::Iterator)m_elements.Begin() + index, he);
++ return Iterator(this, (typename Elements::Iterator)m_elements.Begin() + index, he);
+ he = he->m_next;
+ }
+ }
+@@ -603,7 +603,7 @@
+
+ Elements newelements;
+ newelements.Resize(newsize);
+- Elements::Iterator i;
++ typename Elements::Iterator i;
+
+ for (i = newelements.Begin(); i != newelements.End(); ++i)
+ *i = 0;
diff --git a/net/easysoap/files/patch-include::SOAPParameter.h b/net/easysoap/files/patch-include::SOAPParameter.h
new file mode 100644
index 000000000000..5e504f8c51de
--- /dev/null
+++ b/net/easysoap/files/patch-include::SOAPParameter.h
@@ -0,0 +1,11 @@
+--- SOAPParameter.h.orig Thu Jun 26 09:18:02 2003
++++ include/easysoap/SOAPParameter.h Thu Jun 26 09:18:19 2003
+@@ -165,7 +165,7 @@
+ Data(const Data&);
+ };
+
+- friend Data;
++ friend class Data;
+
+ Pool m_pool;
+ SOAPParameter *m_parent;
diff --git a/net/easysoap/pkg-plist b/net/easysoap/pkg-plist
index 4e6f68e04a7f..c19dc7c8df34 100644
--- a/net/easysoap/pkg-plist
+++ b/net/easysoap/pkg-plist
@@ -3,17 +3,16 @@ include/easysoap/SOAPArray.h
include/easysoap/SOAPBase64.h
include/easysoap/SOAPBody.h
include/easysoap/SOAPCGIServer.h
+include/easysoap/SOAPCGITransport.h
include/easysoap/SOAPDebugger.h
include/easysoap/SOAPDispatchHandler.h
include/easysoap/SOAPEnvelope.h
include/easysoap/SOAPException.h
include/easysoap/SOAPFault.h
-include/easysoap/SOAPHTTPServer.h
include/easysoap/SOAPHashMap.h
include/easysoap/SOAPHeader.h
include/easysoap/SOAPMethod.h
include/easysoap/SOAPNamespaces.h
-include/easysoap/SOAPPacketWriter.h
include/easysoap/SOAPParameter.h
include/easysoap/SOAPParse.h
include/easysoap/SOAPParseEventHandler.h
@@ -21,6 +20,7 @@ include/easysoap/SOAPPool.h
include/easysoap/SOAPProxy.h
include/easysoap/SOAPQName.h
include/easysoap/SOAPResponse.h
+include/easysoap/SOAPSSLContext.h
include/easysoap/SOAPSTL.h
include/easysoap/SOAPServer.h
include/easysoap/SOAPServerDispatch.h
@@ -32,9 +32,12 @@ include/easysoap/SOAPTypeTraits.h
include/easysoap/SOAPUrl.h
include/easysoap/SOAPUtil.h
include/easysoap/SOAPonHTTP.h
+include/easysoap/XMLComposer.h
include/easysoap/XMLParser.h
+include/easysoap/es_borl.h
include/easysoap/es_comp.h
include/easysoap/es_conf.h
+include/easysoap/es_config.h
include/easysoap/es_msvc.h
include/easysoap/es_mwerks.h
lib/libeasysoap.a