aboutsummaryrefslogtreecommitdiff
path: root/net/easysoap
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-10-15 13:17:30 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-10-15 13:17:30 +0000
commit5b41e75ffbe527e89970c1a75060b73e57e0dd09 (patch)
tree8e89010255fdea448a714859071532ac34926466 /net/easysoap
parentf283135fef75122ab894ce5fab638a6b936d328c (diff)
downloadports-5b41e75ffbe527e89970c1a75060b73e57e0dd09.tar.gz
ports-5b41e75ffbe527e89970c1a75060b73e57e0dd09.zip
add easysoap
C++ SOAP Library based on expat PR: 30711 Submitted by: Gabriel Ambuehl <gabriel_ambuehl@buz.ch>
Notes
Notes: svn path=/head/; revision=48791
Diffstat (limited to 'net/easysoap')
-rw-r--r--net/easysoap/Makefile25
-rw-r--r--net/easysoap/distinfo1
-rw-r--r--net/easysoap/pkg-comment1
-rw-r--r--net/easysoap/pkg-descr3
-rw-r--r--net/easysoap/pkg-plist44
5 files changed, 74 insertions, 0 deletions
diff --git a/net/easysoap/Makefile b/net/easysoap/Makefile
new file mode 100644
index 000000000000..e80c94b50791
--- /dev/null
+++ b/net/easysoap/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: easysoap
+# Date created: 21th September 2001
+# Whom: Gabriel Ambuehl <gabriel_ambuehl@buz.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= easysoap
+PORTVERSION= 0.5
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= EasySoap++-${PORTVERSION}
+
+MAINTAINER= gabriel_ambuehl@buz.ch
+
+LIB_DEPENDS= expat.2:${PORTSDIR}/textproc/expat2
+
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CXXFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lexpat"
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/net/easysoap/distinfo b/net/easysoap/distinfo
new file mode 100644
index 000000000000..6f0bee6108cd
--- /dev/null
+++ b/net/easysoap/distinfo
@@ -0,0 +1 @@
+MD5 (EasySoap++-0.5.tar.gz) = 473e08f8a0a0b0ea598f0fe024611fe9
diff --git a/net/easysoap/pkg-comment b/net/easysoap/pkg-comment
new file mode 100644
index 000000000000..28b31fffa421
--- /dev/null
+++ b/net/easysoap/pkg-comment
@@ -0,0 +1 @@
+C++ SOAP Library based on expat
diff --git a/net/easysoap/pkg-descr b/net/easysoap/pkg-descr
new file mode 100644
index 000000000000..09cbcf9ad368
--- /dev/null
+++ b/net/easysoap/pkg-descr
@@ -0,0 +1,3 @@
+C++ SOAP Library based on expat
+
+WWW: http://easysoap.sourceforge.net/
diff --git a/net/easysoap/pkg-plist b/net/easysoap/pkg-plist
new file mode 100644
index 000000000000..4e6f68e04a7f
--- /dev/null
+++ b/net/easysoap/pkg-plist
@@ -0,0 +1,44 @@
+include/easysoap/SOAP.h
+include/easysoap/SOAPArray.h
+include/easysoap/SOAPBase64.h
+include/easysoap/SOAPBody.h
+include/easysoap/SOAPCGIServer.h
+include/easysoap/SOAPDebugger.h
+include/easysoap/SOAPDispatchHandler.h
+include/easysoap/SOAPEnvelope.h
+include/easysoap/SOAPException.h
+include/easysoap/SOAPFault.h
+include/easysoap/SOAPHTTPServer.h
+include/easysoap/SOAPHashMap.h
+include/easysoap/SOAPHeader.h
+include/easysoap/SOAPMethod.h
+include/easysoap/SOAPNamespaces.h
+include/easysoap/SOAPPacketWriter.h
+include/easysoap/SOAPParameter.h
+include/easysoap/SOAPParse.h
+include/easysoap/SOAPParseEventHandler.h
+include/easysoap/SOAPPool.h
+include/easysoap/SOAPProxy.h
+include/easysoap/SOAPQName.h
+include/easysoap/SOAPResponse.h
+include/easysoap/SOAPSTL.h
+include/easysoap/SOAPServer.h
+include/easysoap/SOAPServerDispatch.h
+include/easysoap/SOAPSocket.h
+include/easysoap/SOAPStack.h
+include/easysoap/SOAPString.h
+include/easysoap/SOAPTransport.h
+include/easysoap/SOAPTypeTraits.h
+include/easysoap/SOAPUrl.h
+include/easysoap/SOAPUtil.h
+include/easysoap/SOAPonHTTP.h
+include/easysoap/XMLParser.h
+include/easysoap/es_comp.h
+include/easysoap/es_conf.h
+include/easysoap/es_msvc.h
+include/easysoap/es_mwerks.h
+lib/libeasysoap.a
+lib/libeasysoap.la
+lib/libeasysoap.so
+lib/libeasysoap.so.0
+@dirrm include/easysoap