aboutsummaryrefslogtreecommitdiff
path: root/net/etherboot
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-03-24 00:17:25 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-03-24 00:17:25 +0000
commitc200f82a2dd36c9261a81fd6261f78bf711af467 (patch)
tree4b10a22432438a2e7202fba1890376dbfaa9baf2 /net/etherboot
parent9e9ffbf1ac780be06fe875af41f338d6756e3417 (diff)
downloadports-c200f82a2dd36c9261a81fd6261f78bf711af467.tar.gz
ports-c200f82a2dd36c9261a81fd6261f78bf711af467.zip
Update port to 4.5.5
PR: 17516 Submitted by: Maintainer
Notes
Notes: svn path=/head/; revision=26999
Diffstat (limited to 'net/etherboot')
-rw-r--r--net/etherboot/Makefile6
-rw-r--r--net/etherboot/distinfo2
-rw-r--r--net/etherboot/files/patch-aa84
-rw-r--r--net/etherboot/files/patch-ab27
-rw-r--r--net/etherboot/pkg-descr9
5 files changed, 68 insertions, 60 deletions
diff --git a/net/etherboot/Makefile b/net/etherboot/Makefile
index e9e09356faff..55db0423e4ef 100644
--- a/net/etherboot/Makefile
+++ b/net/etherboot/Makefile
@@ -6,8 +6,8 @@
# $FreeBSD$
#
-DISTNAME= etherboot-4.2.11
-PKGNAME= etherboot-4.2
+DISTNAME= etherboot-4.5.5
+PKGNAME= etherboot-4.5
CATEGORIES= net
MASTER_SITES= http://www.slug.org.au/etherboot/ \
http://www.us.kernel.org/pub/linux/devel/gcc/ \
@@ -20,7 +20,7 @@ BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
NO_PACKAGE= lots of configuration necessary
USE_GMAKE=1
-WRKSRC= ${WRKDIR}/${PKGNAME}/src-32
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
BINUTILS_VER= binutils-2.9.1.0.25 # need newer version of gas for data32
pre-configure:
diff --git a/net/etherboot/distinfo b/net/etherboot/distinfo
index e105ad1170bd..35521126a047 100644
--- a/net/etherboot/distinfo
+++ b/net/etherboot/distinfo
@@ -1,2 +1,2 @@
-MD5 (etherboot-4.2.11.tar.gz) = 9fe7c9a689dfbb7f90b7afa453922598
+MD5 (etherboot-4.5.5.tar.gz) = 0c790b9158d33f03aceb299369bd046e
MD5 (binutils-2.9.1.0.25.tar.gz) = 2350a282f8fd53b409f523e77fccb904
diff --git a/net/etherboot/files/patch-aa b/net/etherboot/files/patch-aa
index 0e51fdf3df87..25c84b73596c 100644
--- a/net/etherboot/files/patch-aa
+++ b/net/etherboot/files/patch-aa
@@ -1,46 +1,60 @@
-*** Makefile.orig Thu Nov 25 00:34:35 1999
---- Makefile Mon Nov 29 14:25:36 1999
+*** Makefile.orig Sat Mar 18 00:30:20 2000
+--- Makefile Sat Mar 18 19:46:12 2000
***************
-*** 74,79 ****
---- 74,80 ----
- CFLAGS+= -DVERSION=\"$(VERSION)\"
- CFLAGS+= -DRELOC=$(RELOCADDR)
- #AS= /usr/ports/net/etherboot/work/binutils-2.9.1.0.25/gas/as-new
-+ AS= `echo ../../bin*/gas/as-new`
+*** 90,95 ****
+--- 90,98 ----
+ IDENT16= 'Etherboot/16 $(VERSION) (GPL) $@'
+ IDENT32= 'Etherboot/32 $(VERSION) (GPL) $@'
- IDENT= 'Etherboot/$(BITS) $(VERSION) (GPL) $@'
- # Stack must be below 640kb so we have real memory there
-***************
-*** 102,108 ****
-
- # Exactly one of the following definitions for AS86 should be uncommented
- # If you have not made any changes to the *.asm files (most people)
-! AS86= none
- # If you have made changes to the *.asm files
- # and you want to rebuild *loader.bin and floppyload.bin and you have as86
- # from the ELKS Dev86 package (not the one that normally comes with Linux)
---- 103,109 ----
-
- # Exactly one of the following definitions for AS86 should be uncommented
- # If you have not made any changes to the *.asm files (most people)
-! #AS86= none
- # If you have made changes to the *.asm files
- # and you want to rebuild *loader.bin and floppyload.bin and you have as86
- # from the ELKS Dev86 package (not the one that normally comes with Linux)
++ AS= `echo ../../bin*/gas/as-new`
++ LD32= `echo ../../bin*/ld/ld-new`
++
+ # Find out if we're using binutils 2.9.5 which uses a different syntax in some
+ # places (most prominently in the opcode prefix area).
+ NEWGAS:= $(shell $(AS) --version | grep -q '2\.9\.1' || echo -DGAS295)
***************
-*** 111,117 ****
- # If you have made changes to the *.asm files
- # and you want to rebuild *loader.bin and floppyload.bin and you have nasm
- # (not most people)
+*** 142,148 ****
+ #AS86= as86
+ # If you have made changes to the *.S files and you want to rebuild *loader.bin
+ # and {floppy,com}load.bin and you have nasm (not most people)
! #AS86= nasm
# if your as has trouble with the data32 directive, uncomment this
# but note that the premade start*.o will be larger than necessary because it
---- 112,118 ----
- # If you have made changes to the *.asm files
- # and you want to rebuild *loader.bin and floppyload.bin and you have nasm
- # (not most people)
+--- 145,151 ----
+ #AS86= as86
+ # If you have made changes to the *.S files and you want to rebuild *loader.bin
+ # and {floppy,com}load.bin and you have nasm (not most people)
! AS86= nasm
# if your as has trouble with the data32 directive, uncomment this
# but note that the premade start*.o will be larger than necessary because it
+***************
+*** 166,171 ****
+--- 169,175 ----
+ PRLOADER= bin/prloader.bin
+ RZLOADER= bin/rzloader.bin
+ PRZLOADER= bin/przloader.bin
++ FLOPPYLOAD= floppyload.bin.pre
+ COMLOAD= bin/comload.bin
+ endif
+
+*** Config.orig Sat Mar 18 00:27:39 2000
+--- Config Mon Mar 20 11:15:44 2000
+***************
+*** 114,120 ****
+ CFLAGS32+= -DPASSWD -DUSRPARMS -DFLOPPY
+
+ # For a serial console, which can run in parallel with CRT console
+! CFLAGS32+= -DCONSOLE_DUAL -DCOMCONSOLE=0x3f8 -DCONSPEED=57600
+
+ # Enable generic ELF, Multiboot ELF or FreeBSD ELF/a.out boot image support
+ CFLAGS32+= -DELF_IMAGE -DAOUT_IMAGE -DIMAGE_MULTIBOOT -DIMAGE_FREEBSD
+--- 114,120 ----
+ CFLAGS32+= -DPASSWD -DUSRPARMS -DFLOPPY
+
+ # For a serial console, which can run in parallel with CRT console
+! #CFLAGS32+= -DCONSOLE_DUAL -DCOMCONSOLE=0x3f8 -DCONSPEED=9600
+
+ # Enable generic ELF, Multiboot ELF or FreeBSD ELF/a.out boot image support
+ CFLAGS32+= -DELF_IMAGE -DAOUT_IMAGE -DIMAGE_MULTIBOOT -DIMAGE_FREEBSD
diff --git a/net/etherboot/files/patch-ab b/net/etherboot/files/patch-ab
index 9ca112f881a3..78d06d38afac 100644
--- a/net/etherboot/files/patch-ab
+++ b/net/etherboot/files/patch-ab
@@ -1,19 +1,14 @@
-*** Config.orig Fri Oct 22 09:20:07 1999
---- Config Fri Oct 22 09:20:40 1999
+*** linux-asm-string.h.orig Sat Mar 18 20:15:54 2000
+--- linux-asm-string.h Sat Mar 18 20:40:49 2000
***************
-*** 82,88 ****
- CFLAGS+= -DMOTD -DIMAGE_MENU
+*** 19,27 ****
+ * consider these trivial functions to be PD.
+ */
- # Enable for FreeBSD boot image support
-! # CFLAGS+= -DAOUT_IMAGE -DELF_IMAGE
+- #ifndef __FreeBSD__
+ typedef int size_t;
+- #endif
- # For prompting and default on timeout
- # CFLAGS+= -DASK_BOOT=2 -DANS_DEFAULT=ANS_NETWORK
---- 82,88 ----
- CFLAGS+= -DMOTD -DIMAGE_MENU
-
- # Enable for FreeBSD boot image support
-! CFLAGS+= -DAOUT_IMAGE -DELF_IMAGE
-
- # For prompting and default on timeout
- # CFLAGS+= -DASK_BOOT=2 -DANS_DEFAULT=ANS_NETWORK
+ extern void *__memcpy(void * to, const void * from, size_t n);
+ extern void *__constant_memcpy(void * to, const void * from, size_t n);
+--- 19,25 ----
diff --git a/net/etherboot/pkg-descr b/net/etherboot/pkg-descr
index 51c8e1d50155..84c661fac536 100644
--- a/net/etherboot/pkg-descr
+++ b/net/etherboot/pkg-descr
@@ -2,8 +2,7 @@ This code was originaly from FreeBSD and then the Linux folks greatly
enhanced its functionality and capabilities. It tftp's the kernel
and boots it. It also has a menu capability.
-.rom & .com images are built in work/etherboot/src-32. Edit "Config"
-in that directory for more features.
-
-Note this is a memory corruption issue when I pre-populate the bootinfo
-structure I need to look at it more.
+.rom images are built in work/etherboot/src/bin32. Edit "Config"
+in work/etherboot/src directory for more features. To make a floppy
+image cd in work/etherboot/src and type gmake bin32/<device type>.fd0 .
+.com images are made via gmake bin32/<device type>.com .