aboutsummaryrefslogtreecommitdiff
path: root/net/ethereal
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-01-10 11:35:47 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-01-10 11:35:47 +0000
commit0aacf342d74f25d90ef25117656869d9de30b7e0 (patch)
tree058d1cb4a3726e83b9c3df4fa2e6f7cfcf173e2f /net/ethereal
parent32c871b528168ca86c3b2599cc9a3092355fb89c (diff)
downloadports-0aacf342d74f25d90ef25117656869d9de30b7e0.tar.gz
ports-0aacf342d74f25d90ef25117656869d9de30b7e0.zip
[PATCH] ethereal-0.9.16 uses adns
Ethereal has a --with-adns switch. ./configure tests for presence of the library even if --with-adns is not specified, and if it finds it, the build fails later on because /usr/local/lib is not in -L. PR: ports/59855 Submitted by: Roman Neuhauser <neuhauser@bellavista.cz>
Notes
Notes: svn path=/head/; revision=97867
Diffstat (limited to 'net/ethereal')
-rw-r--r--net/ethereal/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/net/ethereal/Makefile b/net/ethereal/Makefile
index d5dab7e6cb18..686367365392 100644
--- a/net/ethereal/Makefile
+++ b/net/ethereal/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ethereal
PORTVERSION= 0.10.0a
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.ethereal.com/pub/ethereal/%SUBDIR%/ \
ftp://gd.tuwien.ac.at/infosys/security/ethereal/%SUBDIR%/ \
@@ -57,6 +58,13 @@ CONFIGURE_ARGS+= --with-ssl=/usr
CONFIGURE_ARGS+= --enable-snmp=no --without-ucdsnmp --without-net-snmp
.endif
+.if defined(WITH_ADNS) || (!defined(WITHOUT_ADNS) && exists(${LOCALBASE}/lib/adns.so))
+LIB_DEPENDS+= adns.1:${PORTSDIR}/dns/adns
+CONFIGURE_ARGS+= --with-adns=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --without-adns
+.endif
+
MAN1+= editcap.1 idl2eth.1 mergecap.1 tethereal.1 text2pcap.1
MAN4+= ethereal-filter.4