aboutsummaryrefslogtreecommitdiff
path: root/net/etrace
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-29 16:52:16 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-29 16:52:16 +0000
commit3f7de51d74c9d0fa5c0eafcafe91c5cc2dcc9146 (patch)
treeff5824f045aafa8356960989820fe833f0c1d0bc /net/etrace
parent4b3595c48b4e8cd67caa8bc6ac7c0b90137d25df (diff)
downloadports-3f7de51d74c9d0fa5c0eafcafe91c5cc2dcc9146.tar.gz
ports-3f7de51d74c9d0fa5c0eafcafe91c5cc2dcc9146.zip
etrace is a configurable static port network tracing tool, similar to
traceroute, but supporting ICMP, TCP, UDP and other IP protocols. etrace has a wealth of options ranging in function from controlling output to the detailed construction of trace packets. WWW: http://www.bindshell.net/tools/etrace PR: ports/100976 Submitted by: dave.ryan at gmail.com
Notes
Notes: svn path=/head/; revision=169050
Diffstat (limited to 'net/etrace')
-rw-r--r--net/etrace/Makefile29
-rw-r--r--net/etrace/distinfo3
-rw-r--r--net/etrace/files/patch-Makefile.in11
-rw-r--r--net/etrace/pkg-descr7
-rw-r--r--net/etrace/pkg-plist8
5 files changed, 58 insertions, 0 deletions
diff --git a/net/etrace/Makefile b/net/etrace/Makefile
new file mode 100644
index 000000000000..59e1c07c30d1
--- /dev/null
+++ b/net/etrace/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: etrace
+# Date created: 2006-05-07
+# Whom: dave.ryan@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= etrace
+PORTVERSION= 1.1
+PORTREVISION= 0
+CATEGORIES= net
+MASTER_SITES= http://www.bindshell.net/tools/etrace/
+DISTNAME= ${PORTNAME}.${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dave.ryan@gmail.com
+COMMENT= A configurable static port network tracing tool
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet \
+ ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
+
+WRKSRC= ${WRKDIR}/etrace
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-libdnet=${PREFIX}
+
+MAN8= etrace.8
+
+.include <bsd.port.mk>
diff --git a/net/etrace/distinfo b/net/etrace/distinfo
new file mode 100644
index 000000000000..94f0c7400c85
--- /dev/null
+++ b/net/etrace/distinfo
@@ -0,0 +1,3 @@
+MD5 (etrace.1.1.tgz) = 8e47908a75299e467b126b6730f88454
+SHA256 (etrace.1.1.tgz) = b4189c9ca317c659c7918f32cba6785ee987e978a17c830a3ec45bf7c7a201d4
+SIZE (etrace.1.1.tgz) = 47013
diff --git a/net/etrace/files/patch-Makefile.in b/net/etrace/files/patch-Makefile.in
new file mode 100644
index 000000000000..6429753594a3
--- /dev/null
+++ b/net/etrace/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- ./Makefile.in.orig Sat Jul 29 18:02:28 2006
++++ ./Makefile.in Sat Jul 29 18:02:54 2006
+@@ -25,7 +25,7 @@
+ mkdir -p -m 755 ${bindir} ${mandir}/man8 ${datadir}/etrace
+ @INSTALL_PROGRAM@ etrace ${bindir}
+ @INSTALL_DATA@ etrace.8 ${mandir}/man8
+- @INSTALL_DATA@ default.profile ${datadir}/etrace/profile
++ @INSTALL_DATA@ default.profile ${datadir}/etrace/default.profile
+ @INSTALL_DATA@ ${PROBE_DATA} ${datadir}/etrace/
+
+ clean:
diff --git a/net/etrace/pkg-descr b/net/etrace/pkg-descr
new file mode 100644
index 000000000000..06479a8bbb2e
--- /dev/null
+++ b/net/etrace/pkg-descr
@@ -0,0 +1,7 @@
+etrace is a configurable static port network tracing tool, similar to
+traceroute, but supporting ICMP, TCP, UDP and other IP protocols.
+
+etrace has a wealth of options ranging in function from controlling
+output to the detailed construction of trace packets.
+
+WWW: http://www.bindshell.net/tools/etrace
diff --git a/net/etrace/pkg-plist b/net/etrace/pkg-plist
new file mode 100644
index 000000000000..eb03aa615e92
--- /dev/null
+++ b/net/etrace/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+bin/etrace
+%%DATADIR%%/dns
+%%DATADIR%%/ike
+@unexec if cmp -s %D/share/etrace/profile %D/share/etrace/default.profile; then rm -f %D/share/etrace/profile; fi
+%%DATADIR%%/default.profile
+@exec if [ ! -f %D/share/etrace/profile ]; then cp %D/share/etrace/default.profile %D/share/etrace/profile; fi
+@unexec rm -r %D/%%DATADIR%% || echo "etrace: if you're finished with this port, clean up %D/share/etrace"