aboutsummaryrefslogtreecommitdiff
path: root/net/freeswitch
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2010-08-20 19:35:36 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2010-08-20 19:35:36 +0000
commitbf20ea165549d13f1ca60b04dfda2eb9714100de (patch)
treed5f952c69fbdb76968bffc649d62129037c47a2a /net/freeswitch
parent62f98d498cb0628413512527b913785c4393602d (diff)
downloadports-bf20ea165549d13f1ca60b04dfda2eb9714100de.tar.gz
ports-bf20ea165549d13f1ca60b04dfda2eb9714100de.zip
Update meta port to add subports
PR: ports/149767 Submitted by: Eric F Crist <ecrist@secure-computing.net>
Notes
Notes: svn path=/head/; revision=259643
Diffstat (limited to 'net/freeswitch')
-rw-r--r--net/freeswitch/Makefile47
1 files changed, 29 insertions, 18 deletions
diff --git a/net/freeswitch/Makefile b/net/freeswitch/Makefile
index 6c38d0e8e50c..55e64a9fa3d0 100644
--- a/net/freeswitch/Makefile
+++ b/net/freeswitch/Makefile
@@ -5,32 +5,43 @@
# $FreeBSD$
#
-PORTNAME= freeswitch
-PORTVERSION= 1.0.6
-CATEGORIES= net
-MASTER_SITES= # none
-DISTFILES= # none
-EXTRACT_ONLY= # none
+PORTNAME= freeswitch
+PORTVERSION= 1.0.6
+PORTREVISION= 1
+CATEGORIES= net
+MASTER_SITES= # none
+DISTFILES= # none
+EXTRACT_ONLY= # none
-MAINTAINER= ecrist@secure-computing.net
-COMMENT= FreeSwitch meta-port to pull in all the components
+MAINTAINER= ecrist@secure-computing.net
+COMMENT= FreeSwitch meta-port to pull in all the components
-NO_BUILD= YES
-SUB_FILES= pkg-message
+RUN_DEPENDS= ${LOCALBASE}/bin/freeswitch:${PORTSDIR}/net/freeswitch-core
-OPTIONS= CORE "FreeSwitch PBX Software" on \
- SOUNDS "Sound files for use with FreeSwitch PBX" on \
- MUSIC "Music on hold for use with FreeSwitch PBX" on
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+OPTIONS= SOUNDS "Sound files for use with FreeSwitch PBX" on \
+ MUSIC "Music on hold for use with FreeSwitch PBX" on \
+ PIZZA "Install Pizza Shop voice demo" off \
+ SCRIPTS "Install Freeswitch various scripts" off \
.include <bsd.port.options.mk>
-.if defined(WITH_CORE)
-RUN_DEPENDS+= freeswitch:${PORTSDIR}/net/freeswitch-core
-.endif
+
.if defined(WITH_SOUNDS)
-RUN_DEPENDS+= ${LOCALBASE}/share/freeswitch/sounds/.freeswitch-sounds:${PORTSDIR}/audio/freeswitch-sounds
+RUN_DEPENDS+= ${LOCALBASE}/share/freeswitch/sounds/.freeswitch-sounds:${PORTSDIR}/audio/freeswitch-sounds
.endif
+
.if defined(WITH_MUSIC)
-RUN_DEPENDS+= ${LOCALBASE}/share/freeswitch/sounds/music:${PORTSDIR}/audio/freeswitch-music
+RUN_DEPENDS+= ${LOCALBASE}/share/freeswitch/sounds/.freeswitch-music:${PORTSDIR}/audio/freeswitch-music
+.endif
+
+.if defined(WITH_PIZZA)
+RUN_DEPENDS+= ${LOCALBASE}/share/freeswitch/sounds/.pizza:${PORTSDIR}/misc/freeswitch-pizzademo
+.endif
+
+.if defined(WITH_SCRIPTS)
+RUN_DEPENDS+= ${LOCALBASE}/etc/freeswitch/scripts/.freeswitch-scripts:${PORTSDIR}/misc/freeswitch-scripts
.endif
do-install: build