aboutsummaryrefslogtreecommitdiff
path: root/net/gnomenettool
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /net/gnomenettool
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
downloadports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.tar.gz
ports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.zip
Presenting GNOME 2.10 for FreeBSD!
The release notes can be found at http://www.gnome.org/start/2.10/notes/rnwhatsnew.html, and will give you a good idea of what has gone into this release overall. However, a lot of FreeBSD specific additions and fixes have been made. For example, this release offers fixed ACPI support as well as new CPU freqeuncy monitoring support. See the FreeBSD GNOME 2.10 upgrade page at http://www.FreeBSD.org/gnome/docs/faq210.html for the entire list as well as a list of known issues and upgrade instructions. GNOME 2.10, as well as all of our releases, would not be possible without the great team that goes into porting and testign each and every component. Thanks definitely goes out to ahze, adamw, bland, kwm, mezz, and pav for all their work. We would also like to thank our adventurous users that chose to ride the walrus. We'd especially like to thank the following users that provided patches for GNOME 2.10: ade Yasuda Keisuke Franz Klammer Khairil Yusof Radek Kozlowsk And anyone else I may have accidentally omitted. As with GNOME 2.8, 2.10 comes with a brand-spankin' new splashscreen courtesy of Franz Klammer. However, unlike GNOME 2.8, we've included all of the FreeBSD GNOME splashscreen entries with gnomesession. You can use the deskutils/splashsetter port to choose the one you like best. As always, GNOME users should _not_ use portupgrade alone to upgrade to 2.10. Instead, get the gnome_upgrade.sh script from http://www.FreeBSD.org/gnome/gnome_upgrade.sh. Enjoy!
Notes
Notes: svn path=/head/; revision=130972
Diffstat (limited to 'net/gnomenettool')
-rw-r--r--net/gnomenettool/Makefile5
-rw-r--r--net/gnomenettool/distinfo4
-rw-r--r--net/gnomenettool/files/patch-src_info.c33
-rw-r--r--net/gnomenettool/files/patch-src_nettool.c16
-rw-r--r--net/gnomenettool/pkg-plist6
5 files changed, 37 insertions, 27 deletions
diff --git a/net/gnomenettool/Makefile b/net/gnomenettool/Makefile
index fd1c3489b785..354f8005f5bc 100644
--- a/net/gnomenettool/Makefile
+++ b/net/gnomenettool/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= gnomenettool
-PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTVERSION= 1.2.0
PORTEPOCH= 1
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-nettool/1.0
+MASTER_SITE_SUBDIR= sources/gnome-nettool/1.2
DISTNAME= gnome-nettool-${PORTVERSION}
DIST_SUBDIR= gnome2
diff --git a/net/gnomenettool/distinfo b/net/gnomenettool/distinfo
index 68ada1f9d863..9606b0ac5244 100644
--- a/net/gnomenettool/distinfo
+++ b/net/gnomenettool/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-nettool-1.0.0.tar.bz2) = a3261bd247960ba066b965c5a9a662e1
-SIZE (gnome2/gnome-nettool-1.0.0.tar.bz2) = 515045
+MD5 (gnome2/gnome-nettool-1.2.0.tar.bz2) = 277338cf5d54ae9941260dd993a14f7a
+SIZE (gnome2/gnome-nettool-1.2.0.tar.bz2) = 572511
diff --git a/net/gnomenettool/files/patch-src_info.c b/net/gnomenettool/files/patch-src_info.c
index 0891475e90ff..2d95d26204ac 100644
--- a/net/gnomenettool/files/patch-src_info.c
+++ b/net/gnomenettool/files/patch-src_info.c
@@ -1,6 +1,14 @@
---- src/info.c.orig Mon Jun 14 06:52:59 2004
-+++ src/info.c Sun Oct 31 23:35:06 2004
-@@ -37,6 +37,11 @@
+--- src/info.c.orig Tue Feb 1 06:05:58 2005
++++ src/info.c Thu Mar 3 23:39:57 2005
+@@ -20,6 +20,7 @@
+ #include <gtk/gtk.h>
+ #include <glib/gi18n.h>
+ #include <glib/gprintf.h>
++#include <sys/types.h>
+
+ #ifdef HAVE_CONFIG_H
+ # include <config.h>
+@@ -38,6 +39,11 @@
#include <sys/ioctl.h>
#include <stdlib.h>
#include <net/if.h>
@@ -12,7 +20,7 @@
#include "info.h"
#include "utils.h"
-@@ -57,6 +62,7 @@
+@@ -58,6 +64,7 @@
{ N_("Ethernet Interface"), INFO_INTERFACE_ETH, "16_ethernet.xpm", "eth", NULL },
{ N_("Wireless Interface"), INFO_INTERFACE_WLAN, "wavelan-16.png", "wlan", NULL },
{ N_("Modem Interface"), INFO_INTERFACE_PPP, "16_ppp.xpm", "ppp", NULL },
@@ -20,7 +28,7 @@
{ N_("Parallel Line Interface"), INFO_INTERFACE_PLIP, "16_plip.xpm", "plip", NULL },
{ N_("Infrared Interface"), INFO_INTERFACE_IRLAN, "irda-16.png", "irlan", NULL },
{ N_("Loopback Interface"), INFO_INTERFACE_LO, "16_loopback.xpm", "lo", NULL },
-@@ -97,9 +103,42 @@
+@@ -128,9 +135,42 @@
{
gint i;
gchar *path;
@@ -65,7 +73,7 @@
(*iface) = g_strdup_printf ("%s (%s)", info_iface_desc[i].name, dev_name);
if (info_iface_desc[i].pixbuf == NULL) {
path = g_build_filename (PIXMAPS_DIR, info_iface_desc[i].icon, NULL);
-@@ -187,17 +226,26 @@
+@@ -217,38 +257,87 @@
gchar tx[10], tx_error[10], tx_drop[10], tx_ovr[10];
*/
gchar iface[30]; /*, flags[30]; */
@@ -96,10 +104,9 @@
g_return_val_if_fail (info != NULL, FALSE);
model = gtk_combo_box_get_model (GTK_COMBO_BOX (info->combo));
-@@ -206,21 +254,61 @@
- else
+ text = info_get_nic (info);
+ if (!text)
return FALSE;
- /*text = gtk_entry_get_text (GTK_ENTRY (info->nic));*/
-
+
#if defined(__linux__)
@@ -160,7 +167,7 @@
if (g_ascii_strcasecmp (iface, text) == 0) {
/*
-@@ -248,7 +336,9 @@
+@@ -276,7 +365,9 @@
}
g_io_channel_unref (io);
@@ -171,7 +178,7 @@
return TRUE;
}
-@@ -382,8 +472,16 @@
+@@ -405,8 +496,16 @@
InfoIpAddr *ip;
gint flags;
mii_data_result data;
@@ -188,7 +195,7 @@
for (ifr6 = ifa0; ifr6; ifr6 = ifr6->ifa_next) {
if (strcmp (ifr6->ifa_name, nic) != 0) {
-@@ -429,7 +527,9 @@
+@@ -452,7 +551,9 @@
ifc.ifc_req = (struct ifreq *) buf;
ioctl (sockfd, SIOCGIFCONF, &ifc);
@@ -198,7 +205,7 @@
for (ptr = buf; ptr < buf + ifc.ifc_len;) {
ifr = (struct ifreq *) ptr;
-@@ -460,6 +560,45 @@
+@@ -483,6 +584,45 @@
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[3],
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[4],
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[5]);
diff --git a/net/gnomenettool/files/patch-src_nettool.c b/net/gnomenettool/files/patch-src_nettool.c
index 51f11e3f1e96..cae4f648fdf8 100644
--- a/net/gnomenettool/files/patch-src_nettool.c
+++ b/net/gnomenettool/files/patch-src_nettool.c
@@ -1,14 +1,14 @@
---- src/nettool.c.orig Wed Dec 22 07:07:36 2004
-+++ src/nettool.c Mon Dec 27 21:22:28 2004
-@@ -21,6 +21,7 @@
- #include <gnome.h>
+--- src/nettool.c.orig Fri Jan 7 23:13:56 2005
++++ src/nettool.c Mon Jan 24 21:03:48 2005
+@@ -22,6 +22,7 @@
+ #include <glib/gi18n.h>
#include <sys/types.h>
#include <sys/socket.h>
+#include <netinet/in.h>
#include <signal.h>
#include <errno.h>
#include <sys/wait.h>
-@@ -361,6 +362,10 @@
+@@ -357,6 +358,10 @@
len, NULL);
}
@@ -19,17 +19,15 @@
} else if (status == G_IO_STATUS_AGAIN) {
char buf[1];
-@@ -372,12 +377,14 @@
+@@ -368,12 +373,13 @@
}
g_string_append_c (netinfo->command_output, buf[0]);
}
+
+ g_free (text);
-+
+ return TRUE;
} else if (status == G_IO_STATUS_EOF) {
-- }
-+ }
+ }
g_free (text);
-
diff --git a/net/gnomenettool/pkg-plist b/net/gnomenettool/pkg-plist
index a61ce1a0947e..b1f5ab614ccf 100644
--- a/net/gnomenettool/pkg-plist
+++ b/net/gnomenettool/pkg-plist
@@ -24,21 +24,26 @@ share/locale/en_CA/LC_MESSAGES/gnome-nettool.mo
share/locale/en_GB/LC_MESSAGES/gnome-nettool.mo
share/locale/es/LC_MESSAGES/gnome-nettool.mo
share/locale/eu/LC_MESSAGES/gnome-nettool.mo
+share/locale/fa/LC_MESSAGES/gnome-nettool.mo
share/locale/fi/LC_MESSAGES/gnome-nettool.mo
share/locale/fr/LC_MESSAGES/gnome-nettool.mo
share/locale/ga/LC_MESSAGES/gnome-nettool.mo
share/locale/gl/LC_MESSAGES/gnome-nettool.mo
share/locale/gu/LC_MESSAGES/gnome-nettool.mo
share/locale/he/LC_MESSAGES/gnome-nettool.mo
+share/locale/hr/LC_MESSAGES/gnome-nettool.mo
share/locale/hu/LC_MESSAGES/gnome-nettool.mo
share/locale/id/LC_MESSAGES/gnome-nettool.mo
share/locale/it/LC_MESSAGES/gnome-nettool.mo
share/locale/ja/LC_MESSAGES/gnome-nettool.mo
share/locale/ko/LC_MESSAGES/gnome-nettool.mo
share/locale/lt/LC_MESSAGES/gnome-nettool.mo
+share/locale/mk/LC_MESSAGES/gnome-nettool.mo
+share/locale/ml/LC_MESSAGES/gnome-nettool.mo
share/locale/mn/LC_MESSAGES/gnome-nettool.mo
share/locale/ms/LC_MESSAGES/gnome-nettool.mo
share/locale/nb/LC_MESSAGES/gnome-nettool.mo
+share/locale/ne/LC_MESSAGES/gnome-nettool.mo
share/locale/nl/LC_MESSAGES/gnome-nettool.mo
share/locale/no/LC_MESSAGES/gnome-nettool.mo
share/locale/pa/LC_MESSAGES/gnome-nettool.mo
@@ -53,6 +58,7 @@ share/locale/sr/LC_MESSAGES/gnome-nettool.mo
share/locale/sr@Latn/LC_MESSAGES/gnome-nettool.mo
share/locale/sv/LC_MESSAGES/gnome-nettool.mo
share/locale/ta/LC_MESSAGES/gnome-nettool.mo
+share/locale/th/LC_MESSAGES/gnome-nettool.mo
share/locale/tr/LC_MESSAGES/gnome-nettool.mo
share/locale/uk/LC_MESSAGES/gnome-nettool.mo
share/locale/vi/LC_MESSAGES/gnome-nettool.mo