aboutsummaryrefslogtreecommitdiff
path: root/net/go.net
diff options
context:
space:
mode:
authorJulien Laffaye <jlaffaye@FreeBSD.org>2012-05-14 22:09:08 +0000
committerJulien Laffaye <jlaffaye@FreeBSD.org>2012-05-14 22:09:08 +0000
commitb990fcd821626da24b2aa415d09d9e46c385ad6b (patch)
tree969f8bde6f139dc643fb9be596ee31ff31520951 /net/go.net
parent5bbc442ee2212835e09afa36884d83ef074ba991 (diff)
downloadports-b990fcd821626da24b2aa415d09d9e46c385ad6b.tar.gz
ports-b990fcd821626da24b2aa415d09d9e46c385ad6b.zip
- Add go.net, a collection of Go packages related to networking.
Notes
Notes: svn path=/head/; revision=296618
Diffstat (limited to 'net/go.net')
-rw-r--r--net/go.net/Makefile33
-rw-r--r--net/go.net/distinfo2
-rw-r--r--net/go.net/pkg-descr4
-rw-r--r--net/go.net/pkg-plist26
4 files changed, 65 insertions, 0 deletions
diff --git a/net/go.net/Makefile b/net/go.net/Makefile
new file mode 100644
index 000000000000..a62e603de5b2
--- /dev/null
+++ b/net/go.net/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: go.net
+# Date created: 2012-05-02
+# Whom: Julien Laffaye <jlaffaye@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= go.net
+PORTVERSION= 20120502
+CATEGORIES= net devel
+MASTER_SITES= http://jlaffaye.net/ LOCAL/jlaffaye
+
+MAINTAINER= jlaffaye@FreeBSD.org
+COMMENT= Additional Net packages for Go
+
+GO_PKGNAME= code.google.com/p/go.net
+GO_TARGET= ${GO_PKGNAME}/dict \
+ ${GO_PKGNAME}/spdy \
+ ${GO_PKGNAME}/websocket
+
+do-install:
+ ${MKDIR} ${GO_LOCAL_LIBDIR}/${GO_PKGNAME}
+.for t in ${GO_TARGET}
+ ${INSTALL_DATA} ${GO_WRKDIR_PKG}/${t}.a \
+ ${GO_LOCAL_LIBDIR}/${GO_PKGNAME}
+ ${MKDIR} ${GO_LOCAL_SRCDIR}/${t}
+ (cd ${GO_WRKDIR_SRC}/${t}/ && ${COPYTREE_SHARE} \* \
+ ${GO_LOCAL_SRCDIR}/${t})
+.endfor
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/net/go.net/distinfo b/net/go.net/distinfo
new file mode 100644
index 000000000000..c05e6f5fb5d9
--- /dev/null
+++ b/net/go.net/distinfo
@@ -0,0 +1,2 @@
+SHA256 (go.net-20120502.tar.gz) = c786e087706ed09ce950d3824bc11c1a971f37b4ffddb807771c230797b39ff0
+SIZE (go.net-20120502.tar.gz) = 26302
diff --git a/net/go.net/pkg-descr b/net/go.net/pkg-descr
new file mode 100644
index 000000000000..c2b19b07089b
--- /dev/null
+++ b/net/go.net/pkg-descr
@@ -0,0 +1,4 @@
+go.net contains additional Go packages for net applications such as dict (the
+Dictionary Server Protocol), spdy and websocket.
+
+WWW: http://code.google.com/p/go/source/browse?repo=net
diff --git a/net/go.net/pkg-plist b/net/go.net/pkg-plist
new file mode 100644
index 000000000000..c90a72331b7e
--- /dev/null
+++ b/net/go.net/pkg-plist
@@ -0,0 +1,26 @@
+@comment $FreeBSD$
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/dict.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/spdy.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/websocket.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/dict/dict.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/spdy/read.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/spdy/spdy_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/spdy/types.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/spdy/write.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/websocket/client.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/websocket/hixie.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/websocket/hixie_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/websocket/hybi.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/websocket/hybi_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/websocket/server.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/websocket/websocket.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/websocket/websocket_test.go
+@dirrm %%GO_LIBDIR%%/%%GO_PKGNAME%%
+@dirrmtry %%GO_LIBDIR%%/code.google.com/p
+@dirrmtry %%GO_LIBDIR%%/code.google.com
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/dict
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/spdy
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/websocket
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/
+@dirrmtry %%GO_SRCDIR%%/code.google.com/p
+@dirrmtry %%GO_SRCDIR%%/code.google.com