aboutsummaryrefslogtreecommitdiff
path: root/net/grive/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-10-21 12:34:44 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-10-21 12:34:44 +0000
commit31f07d74b65888b34fbb0ed1fbd6e108d445bd2b (patch)
treefb83a749df464c1081b00a9db1655fd345dc4fda /net/grive/Makefile
parent065f8bcc6007040ce96bec7c01e7f3de9a3b7ee7 (diff)
downloadports-31f07d74b65888b34fbb0ed1fbd6e108d445bd2b.tar.gz
ports-31f07d74b65888b34fbb0ed1fbd6e108d445bd2b.zip
Modernize LIB_DEPENDS syntax, stagify, improve wording in port description.
Notes
Notes: svn path=/head/; revision=331128
Diffstat (limited to 'net/grive/Makefile')
-rw-r--r--net/grive/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/net/grive/Makefile b/net/grive/Makefile
index cf4d88c15e4e..14cc49ff5c0c 100644
--- a/net/grive/Makefile
+++ b/net/grive/Makefile
@@ -11,11 +11,11 @@ COMMENT= Open source client for Google Drive
LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/lib/libiberty.a:${PORTSDIR}/devel/binutils
-LIB_DEPENDS= boost_filesystem:${PORTSDIR}/devel/boost-libs \
- curl:${PORTSDIR}/ftp/curl \
- expat:${PORTSDIR}/textproc/expat2 \
- gcrypt:${PORTSDIR}/security/libgcrypt \
- json:${PORTSDIR}/devel/json-c
+LIB_DEPENDS= libboost_filesystem.so:${PORTSDIR}/devel/boost-libs \
+ libcurl.so:${PORTSDIR}/ftp/curl \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libjson.so:${PORTSDIR}/devel/json-c
USE_GITHUB= yes
GH_ACCOUNT= Grive
@@ -26,15 +26,13 @@ GH_TAGNAME= v${PORTVERSION}
USES= cmake
CXXFLAGS+= -I${LOCALBASE}/include
-PLIST_FILES= bin/grive
-MAN1= grive.1
+PLIST_FILES= bin/grive man/man1/grive.1.gz
# Allow to build with GCC 4.2
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's,log::,gr::&,g' ${WRKSRC}/grive/src/main.cc
post-install:
- @${STRIP_CMD} ${PREFIX}/bin/grive
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/grive
.include <bsd.port.mk>