aboutsummaryrefslogtreecommitdiff
path: root/net/grive/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-05-24 10:16:58 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-05-24 10:16:58 +0000
commitffdd97b0e6a8904e5fb9a9ff1cc7a239069d3c85 (patch)
treef28ef23bb6a2826ce5adfd4c7183fb51f8520ed1 /net/grive/Makefile
parent30588c5645755db3fee0ff1cc95410ee3a4c366a (diff)
downloadports-ffdd97b0e6a8904e5fb9a9ff1cc7a239069d3c85.tar.gz
ports-ffdd97b0e6a8904e5fb9a9ff1cc7a239069d3c85.zip
Grive is an independent implementation of Google Drive client. It uses
the Google Document List API to talk to the servers in Google. WWW: http://www.lbreda.com/grive/ PR: ports/178025 Submitted by: Key-Teck SIN <ktsin@acm.org> Approved by: culot (mentor)
Notes
Notes: svn path=/head/; revision=318949
Diffstat (limited to 'net/grive/Makefile')
-rw-r--r--net/grive/Makefile61
1 files changed, 61 insertions, 0 deletions
diff --git a/net/grive/Makefile b/net/grive/Makefile
new file mode 100644
index 000000000000..ac5b11af2e73
--- /dev/null
+++ b/net/grive/Makefile
@@ -0,0 +1,61 @@
+# Created by: ktsin@acm.org
+# $FreeBSD$
+
+PORTNAME= grive
+PORTVERSION= 0.2.0
+CATEGORIES= net
+MASTER_SITES= GH
+
+MAINTAINER= ktsin@acm.org
+COMMENT= Open source client for Google Drive
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libiberty.a:${PORTSDIR}/devel/binutils
+LIB_DEPENDS= boost_filesystem:${PORTSDIR}/devel/boost-libs \
+ curl:${PORTSDIR}/ftp/curl \
+ expat:${PORTSDIR}/textproc/expat2 \
+ gcrypt:${PORTSDIR}/security/libgcrypt \
+ json:${PORTSDIR}/devel/json-c
+
+USE_GITHUB= yes
+GH_ACCOUNT= Grive
+GH_PROJECT= ${PORTNAME}
+GH_COMMIT= 93d696a
+GH_TAGNAME= v${PORTVERSION}
+
+USES= cmake
+CXXFLAGS+= -I${LOCALBASE}/include
+
+MAKE_JOBS_UNSAFE= yes
+
+FETCH_ARGS= -pRr
+
+PLIST_FILES= bin/grive
+MAN1= grive.1
+
+.include <bsd.port.pre.mk>
+
+# We need clang or GCC 4.6+ to build
+# Piece of code copied from bsd.gecko.mk
+.if ${CC} == "cc" && (exists(/usr/bin/clang) && ${OSVERSION} >= 900014)
+CC= /usr/bin/clang
+.endif
+.if ${CXX} == "c++" && (exists(/usr/bin/clang++) && ${OSVERSION} >= 900014)
+CXX= /usr/bin/clang++
+.endif
+.if ${CPP} == "cpp" && (exists(/usr/bin/clang-cpp) && ${OSVERSION} >= 900045)
+CPP= /usr/bin/clang-cpp
+.endif
+.if ${CC} != "cc" && ${CPP} == "cpp"
+CPP= ${CC} -E
+.endif
+# fallback to gcc otherwise
+.if ${CC} == "cc" || ${CXX} == "c++"
+USE_GCC= 4.6+
+.endif
+
+post-install:
+ @${STRIP_CMD} ${PREFIX}/bin/grive
+
+.include <bsd.port.post.mk>