aboutsummaryrefslogtreecommitdiff
path: root/net/hexinject
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2011-06-29 09:39:58 +0000
committerSofian Brabez <sbz@FreeBSD.org>2011-06-29 09:39:58 +0000
commita1a1818dcf9064170c171348fd088fc12213f255 (patch)
tree83283742dc77d0863ff3f3d42c403b1500455ddc /net/hexinject
parent179a102240ac468d9fe53c9c0787d3e6b5e73b5d (diff)
downloadports-a1a1818dcf9064170c171348fd088fc12213f255.tar.gz
ports-a1a1818dcf9064170c171348fd088fc12213f255.zip
- Update to 1.3
PR: ports/158341 Submitted by: Jin-Sih Lin <linpct at gmail.com> Approved by: miwi@ (mentor)
Notes
Notes: svn path=/head/; revision=276648
Diffstat (limited to 'net/hexinject')
-rw-r--r--net/hexinject/Makefile13
-rw-r--r--net/hexinject/distinfo4
-rw-r--r--net/hexinject/files/patch-hexinject.c22
3 files changed, 25 insertions, 14 deletions
diff --git a/net/hexinject/Makefile b/net/hexinject/Makefile
index 3c6ffd87ae29..e5673725b565 100644
--- a/net/hexinject/Makefile
+++ b/net/hexinject/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= hexinject
-PORTVERSION= 1.2
+PORTVERSION= 1.3
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -20,7 +20,16 @@ PLIST_FILES= bin/${PORTNAME}
WRKSRC= ${WRKDIR}/${PORTNAME}
+post-patch:
+ ${REINPLACE_CMD} -e '2s#-lpcap#-L${LOCALBASE}/lib -lpcap#' ${WRKSRC}/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSREL} < 8
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/hexinject/distinfo b/net/hexinject/distinfo
index 045f6defede2..e070a913f72e 100644
--- a/net/hexinject/distinfo
+++ b/net/hexinject/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hexinject-1.2.tar.gz) = c81903f940db7a3dbf99feffe5eafae91dca3faf14ff5b29d633db004be8ea90
-SIZE (hexinject-1.2.tar.gz) = 4991
+SHA256 (hexinject-1.3.tar.gz) = 7a778728f7e30c0de4a26cc3a54e1ed6b969a8815c89cb8ac35d3cfe358ba6f9
+SIZE (hexinject-1.3.tar.gz) = 5881
diff --git a/net/hexinject/files/patch-hexinject.c b/net/hexinject/files/patch-hexinject.c
index 0f1510501617..369f0c093c5e 100644
--- a/net/hexinject/files/patch-hexinject.c
+++ b/net/hexinject/files/patch-hexinject.c
@@ -1,11 +1,13 @@
---- ./hexinject.c.orig 2010-10-24 06:23:57.000000000 +0200
-+++ ./hexinject.c 2010-10-24 06:24:17.000000000 +0200
-@@ -424,7 +424,7 @@
- if ( (fp = pcap_open_live( options.device, // name of the device
- BUFSIZ, // portion of the packet to capture
- 1, // promiscuous mode
-- -1, // read timeout
-+ 1000, // read timeout
- errbuf // error buffer
- )) == NULL)
+--- ./hexinject.c.orig 2011-06-11 15:56:47.000000000 +0200
++++ ./hexinject.c 2011-06-28 18:11:46.000000000 +0200
+@@ -678,8 +678,8 @@
+ }
+
+ /* Set read timeout */
+- if(pcap_set_timeout(fp, -1) != 0) {
+- fprintf(stderr,"Unable to set read timeout: the interface may be already activated\n");
++ if(pcap_set_timeout(fp, 1000) != 0) {
++ fprintf(stderr,"Unable to set read timeout: the interface may be already activated (%s)\n", errbuf);
+ return 1;
+ }